Issues with updating RS+ and RS devices to v2.22.0

Hi everyone,

I have upgraded all my RS2 to 2.22 via ReachView without a problem.

However, when I upgraded one of my RS+ and rebooted it (again, via ReachView), the system won’t load anymore. It got stuck, with the power led (amber) always on. The other leds (blue and green) remained off. I tried to manually reboot it many times after that, but the behaviour is the same.

The RS+ was running 2.18.1 before the upgrade.

Any ideas/suggestions?

Thanks

1.Make sure it has enough power. Charge it for a while and try again
2.Hard reset. Hold the power button for min 15 seconds.
3.Reflash the unit described in the doc section

Hi Fernando,

Please let us know if any of @TB_RTK suggestions help. At the moment, it looks like the unit is discharged.

Hi @TB_RTK, @tatiana.andreeva,

Here is what happened after your suggestions:

  • Charged the unit overnight and tried to turn it on this morning. Same issue… only the PWR led went on and nothing else happened
  • I then tried the hard reset option. No success

I moved to the reflash option. The only RS+ image available from the Emlid website is 2.20.8. So I started with that one. After reflashing, the unit finally completed the load process and I could access ReachView again. With the unit back, I used ReachView to update the unit to 2.22. Now it seems to be ok, but did not test in the field yet.

I’m now keen on upgrading my two RS units to 2.20, but the only image available in the website is also 2.20.8. Where can I get the RS 2.22 image from?

Thanks

You flashed it with 2.20.8 but i dont understand what you did here: Do you mean 2.22 ?

What version are the RS units running?
If it isnt to old i would use the dev. image from the doc section here.
https://docs.emlid.com/reachrs/common/reachview/firmware-reflashing/#reach-rs-rtk-firmware-download

Hi @TB_RTK,

Yes, I meant 2.22. Sorry for the confusion… I’ve fixed my previous post.

My RS units are running 2.20.8. It is not really urgent to have those units updated, so I guess I will wait for the 2.22 image to be published on the website and then update.

Thanks for your help!

Hi Fernando,

We’ve just updated the Reflashing guide and added links to v2.22.0 firmware image. To update the Reach RTK or Reach RS device from v2.20.8 to v2.22.0, you need to reflash it.

3 Likes

Hi @tatiana.andreeva,

Thanks for that. All my units are now updated. Field tests will happen soon.

Hi Fernando,

It’d be nice to see the results of the field tests :slightly_smiling_face:

2 posts were split to a new topic: How to reflash Reach RS to v2.22.0

2 posts were split to a new topic: Only red LED turns on after updating RS+ to v2.22.0