Issues with RTKlib fix using NEO6-T dongle

Hello,

I’ve been trying to figure out how to use the NEO6-T USB dongle.
I have started out with an http://tinyurl.com/qzo665p as the antenna. Using this I do not get a fix and it wanders far, when sitting still. It isn’t a requirement that it gets a fix, but atleast a small range float within 1 meter or less. Current theory is that the antenna gives a too weak singal strength.
If it matters; I live in Sweden.

Is there any obvious mistakes I am doing? Is there any other antenna I should use? Following is photos of settings, setup and output when trying to use the dongle connected to a computer.

http://i.imgur.com/Mqbos9r.jpg, http://i.imgur.com/bQFzSUq.jpg, http://i.imgur.com/RTUMg65.jpg, http://i.imgur.com/7TwALPY.jpg, http://i.imgur.com/njtoVt0.jpg, http://i.imgur.com/8fRavs1.jpg, http://i.imgur.com/068ShAc.jpg, http://i.imgur.com/Iav3ZpW.jpg, http://imgur.com/ajrihvD

Thanks
Trygve

Hi Trygve,

  1. We usually work with Tallysman antennas, can’t really say anything about this one. SNRs do not look perfect, but should suffice.
  2. How far are you from the base station?
  3. Try to switch U-blox to higher baudrate (115200 for example), 38400 may be not enough for 5hz raw data, messages can be missed sometimes.

Thank you for the quick reply!
We have no previous experience of antennas and chose this one primarily for the price. We would be open for a more expensive antenna, but are not completely sure what we require. Where can you read the SNR specification of the antenna in the datasheet?
The base station is a network-RTK provided by SWEPOS (https://swepos.lantmateriet.se/tjanster/realtid/natverksrtk/natverksrtk.aspx) which covers Sweden in base stations (https://swepos.lantmateriet.se/tjanster/kartstod/fs_karta.aspx). The closest two stations being about 5km from our location and another one at 7km.
I just tested with a higher bitrate as you suggested, sadly it appeared to do not much difference.
Here is at 57600 - http://i.imgur.com/HBwrJKX.jpg and
here is 115200 - http://i.imgur.com/Tun0jQN.jpg.
As you can see, the position drifts far beyond what we would expect with a network-RTK capable of centimeter level accuracy!
Thanks again for your time!

Hello fellow swede.
Make sure you got the latest patch for rtklib for optimal performance, http://www.rtklib.com/rtklib_support.htm . the latest patch is p11 http://www.rtklib.com/prog/rtklib_2.4.2_p11.zip extract new binaries to the bin folder of rtklib.
Start in the input streams and change the option transmit NMEA to base, to single solution. This way Swepos network rtk will generate a virtual base as close to you as possible.
Second: enable the option RAIM FDE in the Setting1 tab, this will allow rtklib to remove “bad” satellites from the solution.
Third: install u-center from ublox and make sure that the receiver is in High Sensitivity mode, this should improve the low signal level

Remember to change the dynamic model of the receiver, NEO-6T receiver is configured for stationary mode by default http://docs.emlid.com/Navio-dev/GPS-ucenter/#dynamic-model

Sometimes “fix and hold” works better than “continuous” in bad sky view.

Edit: remember that it takes 10 to 15 minute before a good fix.
following picture is with swepos base and older ublox LEA-4T receiver.

Hello Robert, thanks for your reply!

I have followed the tips you gave this far but encountered a little problem. In the reciever manager in u-center, there is no option for high sensitivity mode! http://i.imgur.com/7ppbh7C.jpg
I could not find any similar settings in the other entries either.

I figured it might be a firmware issue, but there does not seem to be a suitable firmware update for NEO-6t ( http://www.u-blox.com/en/firmware/gps-modules-firmware/u-blox-6-firmware-update.html).
Is it possible that high-sensitivity is not an option for NEO-6t or did I do something wrong?

If the option is not available there is no need to change it.
I have a 2 generations older ublox receiver and forgot to read the datasheet for the 6t.

Do you got a clear view off the sky and no strong radio transmitters nearby?
You could also measure the voltage to the antenna on the center pin on the bottom of the antenna connector,
there are an amplifier in the antenna that requires 3 volt to operate normally.

I did another try today with the changes you suggested, however the main problem with drifting position persists! This picture is taken after 25mins of running.

The GPS is connected to a USB-port of a laptop and the antenna is at a distance of a few decimeters. The laptop has an active Wi-Fi-link to a smartphone which is sharing internet through 4g. I have no yet been able to measure the voltage through the antenna, but I would assume that the USB-port of the computer is at least supplying the intended 5V to the dongle.

Below the coordinates in rtklib main window is a section that says ratio and a number. the ratio must be above 3.0 to get a rtk fix.
Click the square button in the lower left to open the monitor window and change to display Error/Warning. What errors/warnings do you get?
You could also turn of Glonass in setting 1 tab because the receiver you have is gps only.
Do a test with single instead of kinematic with phone off and wifi in laptop off and see if signal strength is increased, put gps antenna away from laptop on a large metal ground plane like a car roof.
In single the position is all over the place but it is only to see the signal strength

The error/warnings seem to be mainly “large residual” as you can see in the pictures.

This is with settings as before but with laptop connected to wifi and no mobile phone after about 5-10 mins of logging. There was a section of good fixes, before it started drifting again.

This is the setup of the antenna and the laptop:

This is the second try after disabling GLO. Once again, a section of good fixes which diverted after some minute or two.

This is the signal strength in SINGLE mode with wifi off and with phones far away, I could not see a big difference in signal strength.

@Trygve

Satellite levels don’t look good on your screenshots and as you’ve turned off all the radio around then maybe it is the poor antenna.

The antenna you link to in the first post got 5 meter cable and a right angle connector, have you shortened the cable and change the connector? Do you have another antenna to try with?

Try get away from trees, houses and other obstacles.
The errors you have happens when the signal is partly blocked, on the edge of visible.

That is correct, we shortened the cable and attached a new connector. We hoped that the shorter cable would improve signal but there was not much difference, we also need it shorter for our quadcopter application.

I tried again in an open field with good view of the sky, and not very surprisingly the accuracy improved markably. there was still some drifts, but with much smaller amplitude. Many “slip detected” and “ambiguity validation failed” errors now.

try 2:

The signal obtained in these two trials is probably sufficient for our intended application, however the drastic loss of performance close to obstacles is a problem.

@Trygve

This time SNRs look even worse. You have very little chance of getting a stable result when your max SNRs are just 40. You need at least 2-3 satellites close to 50. Look at the levels on the base station - that’s how it should look.

“ambiguity validation failed” is when the “ratio” value is below threshold.
For the plot i posted earlier a min ratio of 5.0 and fix and hold was used.
Higher value forces a higher certainty before the algorithm locks.
“slip detected” is when the receiver momentarily loses the signal from one satellite.

The signal to noise ratio is to low to get a consistent fix, at least 5 signals above 40 is required.
Get a good multimeter and measure that you got at least 3.0 volt on center pin in sma connector.
When you got good signals you should set a snr mask at 40 to discard bad signals.

Okay, I have now measured voltage and tried the SNR mask. Measured voltage was 3.1V which should be sufficient looking at the antenna datasheet ( http://www.navilock.de/produkt/60543/pdf.html?sprache=en).

Testing the GPS at a slightly less open location the following result was obtained using the SNR mask at 40.

It was hard to get a stable fix, which probably has to do with the slightly more obstructed signal… Our application however demands decent accuracy despite some limited obstructions. A better antenna would perhaps do the trick?

Your SNR levels do not look good, they should be around 50, as on the base station. I suggest that you replace your antenna by one from Tallysman. For example TW2410, or another high quality antenna.