Issues connecting to M2

In the M2 module I have problems being able to work with the bluetooth of the cell phone in configurations of the cell phone it is connected but when searching in the Emlid Flow application the M2 device does not appear.

Try connecting your phone to the M2’s Wifi, instead of connecting with bluetooth. Once connected to the M2 over wifi or your phone and M2 are configured to connect to the same wifi hotspot, you should see it in the Emlid Flow app.

From the wifi the following appears. but it still doesn’t recognize the M2 device in the Emlid Flow app.

Hi sarteaga21. I may be confused on your setup. I assumed you had a cell phone and one M2 connected to an external antenna. Is this correct?

Also, the attached screenshot shows you connected to the M2 and those are the M2 settings. So, you won’t see the M2 as one of the connected device, because you are in the M2 settings.

It does show the M2 connected to a device, the “santy.art21”. Is that your phone? If so, then it looks like you are connected.

What are you trying to do with bluetooth? Just curious, because I only use it to send NMEA string data to my laptop for a 3rd party application.

I am trying to work on NTRIP over bluetooth from the cell phone with the Emlid Flow app.

I have never tried that, so I may not be much help.

Is this a NTRIP on the internet or a local NTRIP? If it is on the internet, then can you connect the M2 to your phone’s wifi hotspot. With the M2 connected to the internet, you can configure the M2 to connect to the NTRIP directly.

Hi Santiago,

NTRIP over Bluetooth works only with devices that connect via BLE, that stands for Bluetooth Low Energy. This feature works only for Reach RS2/RS2+, Reach RS+ and Reach RX.

In your setup, I see that Reach M2 is connected to a Wi-Fi network that assigned a particular IP address to it. You need to connect your iPhone to the same network and disable mobile data beforehand. Then, Reach M2 will appear in the list of available receivers. After that, you can configure NTRIP profile in the Correction input tab.

Thanks for the previous comment.

Reach connecting to the Internet through a mobile hotspot but keeps disconnecting the M2 device does not stay connected.

Hi Santiago,

What if you try Reach’s hotspot or another mobile hotspot? Just want to check if connection loses in other Wi-Fi networks.

I used an android cell phone and it worked fine only once the M2 equipment was disconnected. What I suppose is that in the Iphone SE 2020 it has problems, in that it used for the initial tests.


Hi Santiago,

Do I get it right that Android connection works fine now?

As for iOS connection, you can read our Support tip describing main things to check if you face such issues. It may help troubleshoot it.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.