I can't update ReachView

Hello, I’m writing to you because I can’t update some RS +, the version they have installed is v2.18.1 and I want to take it to v2.22.7
I do the update : 5000 -Test ok -Wi-Fi ok -Time Sync ok -Receiver update ok -ReachView fail


1 Like

Hi Gabriel,

Could you please share the screenshot of the Updater page? To reach it, you need to go to the Reach’s_IP:5000 address in your browser. It’ll help us see at what stage the update fails.

It’d also be great if you checked the updating process using another Wi-Fi network, for example, your phone’s hotspot.

1 Like

Hi Polina

After just buy the RS2 system last week I get the same. I’ve tried the office network and the iph mobile data as hotspot.

Hi Polina,

I’ve been having the exact same issue today. Trying to update my RS2’s firmware to work with ReachView 3, and getting the same “Failed to perform update” message that Gabriel posted.
Firmware is currently v.2.20.5, and I was unable to update to either the latest dev firmware, or 2.22.7. Neither home network nor phone hotspot worked. Any other suggestions?
Thanks so much!


Try using the firmware tool from your PC. I got it to work after starting the firmware tool by right-clicking “run as administrator” option. If update fails, restart the PC and try again. Firmware was verified on the 2nd try. I was using 2.22.5 firmware on RS2. Will try 2.22.7 later after I see all the complaints are resolved.

Hi Troy,

Could you please share the Full System Report on your device with me in PM?

It’d b great if you could share the screenshot of the Updater page with me as well. This will help me to see which error you get: the process is stuck in the downloading the image or it’s the “Fail to perform update” error.

Hi Tim,

Welcome to the community forum!

Please share the Full System Report from your Reach RS2 with me in PM as well.


May I ask you if you tried to update your receivers via the Updater?

We don’t recommend using the reflashing procedure for the issues that can be solved without it. It should be possible to update your receiver to v2.22.5 without using the Reach Firmware Flash Tool.

Yes, I tried it using the Reachview app on IoS. It returned error several times. Tried it on the PC via Firmware Tool. First time also returned an error. Something wrong with USB connection because unit was not detected. Was successful after running it via Administrator option.

Hi Polina,

I tried sending you a direct message last week including the full system report for one of my two RS2 units as you requested. Can you confirm that you received it? If not, can you PM me so I can reply back directly?

Many thanks,


Tim @timhorsley, I’ve received your report, thank you! Please check my message in PM.

Juan @jjb, is there any chance you generated the Full System Report prior to reflashing your device? It’d be great if you shared it with me in PM.

Sorry, I just went straight with the update.
Question, if something goes wrong, is it the same procedure to downgrade to a previous firmware? Just load the image file?

The same issue I repored last week. All my RS+ could not upgrade from current stable firmeware to latest dev firmeware.

Im having the same issue. Is there a specific log to look at that is the output of the update script?

I am having the same issue with both my rs+ units

Hey everyone,

We’re currently working on solving issues with the update process. I’ll reach out once there’s news.

1 Like

Juan @jjb, we don’t recommend downgrading the firmware version. It’s better to keep your device up-to-date as the latest firmware updates contain important improvements and fixes.

@KG7OOW, Joel @brightorangetech , please check your PMs.

But the I tried to update to 2.22.7 and also got stuck. I then tried to downgrade to 2.22.5 . Several tries later I was able to install 2.22.5.

I think the solution is to disable Windows Defender Real Time Protection, any virus software and run the Firmware Tool as Administrator

I’m having the same issue on two RS2 units. It seems like this might be a broader issue with ReachView / the update process. Is there any update on this?