How to use the Navio?


I am unable to connect the Navio + with my PC.

I destroyed 2 RFD900 $ 300

How to connect?

How to use the Navio + on the copter or the rover?

it’s been 3 weeks since I work on it
without results.
My patience to the limits

thank you for your help

I did all the steps as mentioned
rfd900 my modem was connected to UART

the modem sent the info RFD900 PC modem
and burnt it to.

He does not accept the configuration and there is nothing left.

I worked like a madman to understand

I’ve realized that the Navio + does not seem to work.
He sends me Chinese codes in the display.

Hi JeanSeb,
Are you using rpi2 or odroid-c1?
It took me ~5 minutes from open box to running the navio sensor test to validate communication between navio+ and rpi2. And that was just by following the steps on the online doc.
I would say good starting point is to run some example app.
The online doc is pretty good.
The online doc also explains how to download the APM image and run it.
Once running you can communicate with the board using one of the dronecode GCS running on your PC to do the setup for your copter.

The APM binary does not come installed with the Linux emlid image so you do need to install it manually.
Maybe this is the step that you are missing?

You need to clarify with us what step you are in. Did you load the RTOS on the Pi? Did you install the APM? goes through the steps very clearly. Did you follow these?


congratulations on your 5 minutes

could you tell me how to make it work.

RPi2 Model B
3DRadio in UART
Connected via HDMI
Connected to the module POWER

I downloaded the Emlid RT
I put in the RPi
I made the boot

I join the apm.deb
I registered my dpkg -i

From here
I run commands like ‘sudo arducopter quad–C / dev / ttyAMA0’

everything starts to go wrong
I receive Chinese writings in my screen

I followed step by step over the last 3 weeks

I do not understand what’s wrong

I get too angry right now

thank you for wanting to help me

I’m someone who always manages itself without problem in electronics
I am very resourceful

I do not know what’s wrong

I’m hating that thing

the worst I bought 2

thank you everyone for helping me

What should I do after the line

Setting up apm (3.1.0a) …

in the screen?

if I write

sudo APMrover2 -C / dev / ttyAMA0

my screen says:


to infinity

I just bought new RFD900

we must make it work

that’s what I thought

likely a uart baudrate speed issue?

What speed your RFD900 is configured for?
APM secondary © port is 56700 and the primary (A) is 115200.

You need to adjust the baudrate of your RFD900 to one of the two and use that port (C or A).

it’s already done

it does not work

Baud rate is 57600

thank you a lot

Hi Jeanseb,
Have you tried the following 3 tests, which one is failing?
Test #1: plug the RFD900 to a PC and see what shows on a console screen. This will confirm the uart connection is working at expected speed.
Test #2: use udp to send telemetry to a PC (cable or wifi). This will confirm the navio+ is working properly.
test #3: use uart with APM again but connect to a PC instead of RFD900.

Please report the results. Those tests won’t fix anything but will help narrow down the problem.


Also I believe the RPI is 3.3v level, 8bit, no parity, 1 bit stop and no Hw flow control.
You might need a ttl to rs232 level converter to your PC.
You also can use Serial over USB with a proper USB to serial converter.

Is the RFD900 use ttl level with same uart setup as RPI (indicated above)?


I already do all that you said.

I am not able to connect the RPi and Navio + to my PC.with cable USB

It is the micro USB port on the RPi I should use?

My PC does not recognize
the RPi2 when I connect it.

PC shows no COM port

sorry for my very bad english

I tried all connection methods without result.

this is not a joke, I think I lost neuronnes this week

yesterday I really was out as I have never been

this is the first time in my life that I do not manage my work

if you already did test #3 then there is nothing wrong with navio+ and rpi2 then and this part is working as expected.

I would recommand posting on RFD900 forum or use 2 RFD900 to loopback with your PC to make sure it works the way you think it should be.

Could the RX and TX be inverted?

rfd900 are the perfect
they work with the Pixhawk

trouble is Navio + or RPi

no connections operate

is that I can connect with the micro USB on the RPi
to communicate with the PC directly?

if so, how?

and why my PC does not recognize the RPi?

the Navio + does not connect to: