Help setting Navio up, no telemetry connection

Installed the RTOS and APM binaries ran sudo AuduCopter-hexa -A udp:(my IP address)
got back: Raspberry Pi 2 with BCM2709!
is that right? I hit connect in APM Planner and no error message shows up but no telemetry either

edit- seems it doesn’t like the processor this has? I just physically checked my Pi2 and is says BCM2836R so idk what’s up

The startup is always like that. The telemetry seems to be going somewhere, too. Otherwise you would see the telemetry as text output in the console after the 0.
What IP address did you enter? It has to be the IP of the computer running the GCS, followed by a port.
14550 for example.
APMplanner picks up any udp telemetry stream automatically, no need to press connect.

I did the IP but no port, how do I find what port to put? And is this the private IP I’m putting in?
I use 14550?

ok getting read failed- connection refused now so that worked lol, probably just not set up properly PC side, working on it

Not sure what else to do the radios show solid green and cant properly shut down cause that message keeps showing up. Navio is blinking yellow if that helps any. So it it’s set up correctly I don’t need to press connect? Drivers seemed to install correctly when I plugged the radio in is there some PC side setup I missed?

Ok, you might have got something wrong here. If you use telemetry radios, you do not use UDP/IP.
With radios you have to use the right serial device, depending on where you connected them. For RPi USB it is -A or -C /dev/ttyUSB0 and for the UART connector it is -A or -C /dev/ttyAMA0.
You will have to change the baudrate of the Ardupilot serial ports with APMplanner to match the baudrate of your radios. -A is serial0 (default is 115200 baud), -C is serial1 (default is 57600 baud).
3dr radios are set to 57600 baud by default.
If you use an ethernet cable or wifi, then UDP is right.
You can use whatever port you like, but 14550 is the port usually used by APM telemetry.

where can I find what to type after dev/tty for different things? Still learning terminal commands
so the udp is only if I was trying to connect through the network? That explains it I was trying to connect with ethernet before I got the radios. I was wondering why I needed the IP address if I had the radios already lol (at the same time idk why I never could connect over ethernet but I’ll figure that out later)
so for primary telemetry I use 115200 baud and secondary I use 57600 baud? alright

In the console type “ls /dev”. It will show you all devices existing.
ttyAMA0 is the UART/telemetry port on the Navio (6 pin df13 connector).
If you connect an USB to serial device, a ttyUSBx device is created. ttyUSB0 for the first device, ttyUSB1 for the second and so on.
What baudrate to use depends on the baudrate your radios are set to. 115200 and 57600 are just the preset rates in the Ardupilot firmwares. If your radios are set to 57600 baud, use the -C option. If they are set to 115200 baud, use the -A option.
UDP is much faster and does not care about baudrates.
With Arduxxxxx -A udp:GCSComputerIP:14550
it should work.

Ok after I so that now “ArduCopter-hexa - A /dev/ttyAMA0” it says:
Raspberry Pi with BCM2709!
Can’t open /dev/mem

As APM works with GPIO directly it requires superuser access.
All that is needed is to add “sudo” to the beginning of the command:

sudo ArduCopter-hexa -A /dev/ttyAMA0

Sorry do it almost sub conceoisly now- I did do that lol. I can’t seem to get the Is /dev/tty (or just Is /dev as you said) command to work if that means anything. The radio shows solid green

**Nevermind didn’t but I did now and the blinking started and it output 0 but APM planner still isn’t getting anything on my PC
Set to 115200 Baud on com 16(only one avalible)

Does flashing red LED mean it’s transmitting data? (on the radio)

What radio model do you use? Is that 3DR radio?

Yes the US version. amber is blinking on the RX side as well. Trying on my phone also no connection either

Then you’re probably in the same situation as in another topic. Do not connect CTS line (cutting the wire would do).

Continuing the discussion from NAVIO+ Telemetry Problem:

It’s not solid red though it’s just blinking at 1Hz Which the user guide sys that means it’s transmitting data. It did go solid red once but that was a one time fluke cause it hasn’t done that since(not sure what caused it)
idk if I said but both Tx and Rx are solid green there’s a blinking red light on the Rx which from what I read means it’s transmitting and there’s a small amber led that’s blinking at the same time the red Tx led does on the Rx

Okay, that’s good to hear:)
Did you set the baudrate to 115200 for both radios in APM Planner?
Its on “Initial setup” tab, “3DR radio” menu, “baud” option.

both Tx and Rx are set up in the APM GCS software, right? and not the air baud option but the one above it? then yes. Even hit restore to default in case I messed with some setting

I think the amber led is a USB indicator since its right next to the port

Realised that com 16 wasn’t selected, selected that now under status it says entering command mode then said failed when I click load settings. Would I possibly need to re-flash the firmware on the radio?

Okay, if the speed is set to 115200 on both radios, could you please try the following:

  1. On Raspberry Pi run “sudo screen /dev/ttyAMA0 115200”. It will open a terminal that works with the radio.
  2. On your computer (don’t forget to turn of the serial link in APM planner):
    Windows - use serial terminal like SerialTerm to open the COM-port of the radio with the baud 115200.
    Mac OS - use serial terminal like SerialTools to open the COM-port of the radio with the baud 115200.
    Linux - run “sudo screen /dev/ttyUSB0 115200”
  3. Type something in the terminal on your computer, do you see the same symbols showing on Raspberry?

I guess the speed would be set up at 115200 out of the box?

As far as I remember the default baud for 3DR Radio is 57600, If you didn’t change it in APM Planner.
So you can try what I described previously by replacing values to 57600.
Also, -C port in APM by default is expected to work on 57600, so you can try to run APM as “sudo ArduCopter-hexa -C /dev/ttyAMA0” to connect to APM Planner.