Help! Reach RS2+ cellular stopped working

Hello everyone. I have the Reach RS2+ set up as a permanent base install. Using it for NTRIP for our tractors and combines. It’s been working very stable for about 3 months now. Now all the sudden 2 days ago my cellular connection has been dropping. I popped aim card out a few times and wiped it clean and installed…the cellular icon shows up up top then goes away and it’ll do this for a minute or so then nothing. It acts like cellular is disabled. But shows sim card still available in the settings. As when I pop sim card out…the sim card installation instructions pop up. I put sim card back in and all my cellular settings come back. Do I have a bad sim card?? Is something wrong with the reach base itself? Everything has been working great. And we are in the dead of harvest and can’t have this type of drop out.
Any help greatly appreciated!!

Is the card still active?

1 Like

Better try another sim card real quick to rule that out. Use phone hotspot or other connection if further issues until u figure it out?

1 Like

I had the same problem with my RS2- I forgot to pay the bill !!!

I’ve since cancelled the card and use my hotspot


My card shows active on my account.

1 Like

Have you tryed it in a phone to see if it works


I will do that. I have a mobile hotspot so I can just interchange cards and not have any issues right? Any care will interchange with any device? I’m on Verizon.

i went through that with our rs2+ we are using as a permanent base with telus cellular in Canada had to go through the settings and install 3 times to sync it is 4g same thing worked until it didn’t
and i reset it and its working currently 24 hrs a day
have you entered all the passwords and allowed access to the network ?


I didn’t have any passwords. Just had to put the correct APN in. And worked right away for 3 months until 2 days ago. When I get home I will swapp sim cards with my hotspot.
Thank you guys for the replies and suggestions!!


Well the base started working again late afternoon. Now this morning nothing. I pulled the sim card and loaded in a working one from my hotspot. It acted the same as the original card. I took a screen recording of what it does when I put in the card. Both cards act the same. Quality of the video gets worse as video plays unsure why that is but I apologize.
You will see the slider turn on and off for the cellular…this is not me doing that. And when it turns on you will see the cell bar signal up top.

I think I am going to try for a warranty claim. Has anyone delt with trying to do a warranty claim and is it a difficult process?? There’s definitely something up with the cellular modem in this rs2+

1 Like

You might want to provide the details of the sim card, carrier, band used etc.

The card(s) may just not be compatible?

Search posts about this.

I’d still work with Emlid though to get things started

It’s Verizon wireless set up on VZWIRELESS APN credentials. That’s all the info I know. This morning I connected it to my wifi which is pretty iffy since it’s on the edge of my Network. But it connected and had no cell bars. I switched to my mobile hotspot and still didn’t see cell bars. I restarted the rs2 and cell bars popped up and is currently working at the moment. I have no clue what’s going on but I need stability on this system. I can’t be running home from the field all the time to restart the base. I will try a factory reset tonight, and then if that doesn’t provide stability then I will ask for a new sim card.


It also seems that the cell service bars only pop up if I have it connected to wifi or a stable wifi connection…that completely defeats the purpose of cellular lol

What’s the steps for factory reset? Hold button for 15 seconds?

You might want to find out exactly what the sim card is… i.e. 2G 3G 4G 5G

I don’t think Verizon supports 3G and below anymore in the USA…

I don’t think the RS2+ supports 5G? (Not sure, but older RS2 Also doesn’t support 4G? And in USA, 3G sunsetted, so no go there also?)

Using a phone hotspot iffy too? May need to reflash?

It worked before with same sim card for awhile?

Keep at it i guess. Hopefully Emlid can help.

1 Like

The card says 5G on it. But I’m sure that doesn’t mean it’s locked on to 5G. I mean it’s been working for 2 months prior. I can’t even get 5g at my house. The hotspot I have is solid and works good off of that. And cell service Icon showed up this morning on the emlid app when I connected the hotspot.

1 Like

That’s probably your problem.

But I hear you. Good luck figuring the issue out. Seems from reading posts over the years here, the common thing I see is some sort of SIM card issue be it the Emlid receivers or the carriers or the cards and variations of them all? :upside_down_face:

Thank you for your help and suggestions. So over your years of experience have you seen many rs2 rs2+s faulty? Need sent in for warranty or anything like that? Lightning ?? I mean how bullet proof are these?


To be clear, if you search back posts in relation to SIM cards, just seems to be a headache overall with users, being the particular model RS2/RS2+ that supports the current tech or it doesn’t or vice versa with the SIM card supporting the tech or even depending on the country supporting it. i.e. USA no longer supports 3G.

So it’s not necessarily the Emlid product. But you really need to start the process with Emlid as also from reading over the years, they are VERY HELPFUL. :wink:


Hi @FarmerMP,

This shouldn’t work this way, let’s check what can cause this issue. Usually, such difficulties can be solved by adjusting the setup, so we need to look into that first.

As the Full System Report contains sensitive information and should not be shared publicly, please send it to us at

Please also include the details below in an email:

  • Were there any changes before the SIM card stopped working? For example, firmware update or change of the survey location?
  • Does the receiver work on the latest firmware version? Please also check the Emlid Flow version.