Helical antenna problem?

Hi,
my M2 doesn’t “see” any satellites as of 24/12. I use the Helical antenna.
Tried 3 different cables with the same result. I was using firmware v27.0 and updated to 28.1 but nothing changed.
The M2 boots normally. Nothing notable happened from the last time I used the M2.
Is there a way to check if the Helical Antenna works properly?

1 Like

Try and put another antenna on it and see if that helps.

I don’t have another antenna right now.
Besides that is there any way to check the antenna with some digital multimeter or something else?

A quick google search reveals some basic tests like http://www.innercell.net/cable-television/test-the-connections-and-signals-of-antenna/

1 Like

Thanks, I will check it.
I hope it is the antenna and not the M2 because I am waiting for a gps500 harxon the next days.
If it is the M2 i am unlucky.

2 Likes

Hi @vgo195,

Have you noticed when your M2 stopped to detect any satellites? Do you have another M2 to test the antenna with? If the antenna works fine with the other M2, something is wrong with this first M2.

@vgo195,

It seems like you’re already in touch with us via a direct support ticket. Please, let me know if it’s right. We just want to gather all the details we have on your case in one place.

Yes, I opened a support ticket.
I opened this thread in case some user had a similar problem.

I’m afraid the M2 failed. I had the same problem and Emlid support has no solution. If it is out of the warranty period, you can throw it in the trash can. Another user also had a similar problem:

Thanks for the info @JAGUERO. Your M2 was bricked? Mine does boot normally and connects to the wifi.
The issue seems fixable if it is the short circuit problem you mentioned.
Maybe I should flash the M2 from the pc in order to fully reset?

Hi @vgo195.
It can connect to Wifi and shows all the normal configurations but does not receive the signals from the antenna, even changing the cable and other antennas that work well with other modules.
It can also be flashed but it doesn’t fix the problem.
In my case I think the mcx cable was loose and this produced the problem.

Maybe someone from emlid can tell us how to issue the command that resets the antenna short circuit?

1 Like

Hi emlid team!
Any news about the antenna problem?
Can you give me some feedback if it is possible to reset the board so it can detect the gnss signals again? Sorry to push you but I am in need to set the M2 base station again for my projects!

Hi guys,

We always investigate each case separately, independent of warranty. The issue may be both hardware and software related, but we need to know what happened exactly.

In the meantime, we continue our conversation with @vgo195 via email for further investigation. If there is any news on this case, I will let you know here.

Hi vgo195,
I had exactly the same problem with two of my M2 units, which no longer supply power to antenna. I didn’t succeed to find if it’s a software failure (short circuit protection locked) or an hardware one. Anyway, don’t throw it in the trash can !
I succeeded to repair them with a quite simple fix : connect TP24 pad to antenna inner pin connector pad through a 18 ohms resistor and a diode. TP24 is linked to 5V M2 external power. This way the antenna is directly powered from the external source.
I cannot guarantee it is completely safe for the device but it works anyway. Always connect or disconnect the antenna when the M2 is not powered, it prevents shorts.

2 Likes

Given that any random usb charger can be used, I would really not recommend this approach. So much risk of damaging the GNSS chip or getting noise/cycle slips in your data, and unstable operation.

As this unit was about to be thrown, I took the risk.
Anyway I used a safer but more complex circuit for the first flawed unit. In this one a MCP1700 3.3V voltage regulator with capacitors and an inductor are added between power and antenna (sorry for the crude schematic).

2 Likes

Thank you so much for the solution. Although I have some basic soldering skills I am not very confident by doing such a repair.
If it is possible emlid to provide a solution by using "ANT_SHORT_N"command mentioned above it would be great.
If not I will try to send the device back to emlid to repair it if the cost is reasonable.
Anyway I think that emlid should revise the M2 hardware (or firmware) to avoid such condition with short circuit because it seems very easy to happen. I didn’t do anything different than before and I use the same cables all the time.

It seems that these M2 modules are very sensitive to failing with the reception of the satellite signal. Most of us are not experts in the @zipang solution.
Emlid support should give us a solution to these bugs.

2 Likes

It would be nice to know if the ANT_SHORT_N would clear it. Since we cannot “root” I doubt it is possible. Perhaps they could try it as a “patch” to their Firmware Flash Tool. Any one of us that has an M2 that has had this happen to would be willing to “Beta” it.

4 Likes