GPS data over USB

I have a reach connected to my laptop by USB. Is it possible to get access to the raw GPS data this way? I would just like to have the data printed in a terminal in real time if possible.

I’m running ubuntu but I’ve never managed usb connections with the terminal, so any help is appreciated!


  1. set up ethernet over USB
  2. tell ReachView to direct the position solution to a TCP port
  3. connect to the TCP port on Reach[RS]
  4. display the NMEA GPS messages on the screen

**How to**

At the command line in xterm or at the console:

sudo ifconfig -a | grep usb

  • if you see usb0 or similar, then:
    sudo ifconfig usb0 up
  • otherwise:
    sudo ifconfig -a | grep enx
  • if you see enxXXXXXXX, then:
    sudo ifconfig enxXXXXXXX up

Use your web browser to surf to and see ReachView
Go to the position output tab and set to a TCP port, for example:

  • Port: 7777
  • Output type: NMEA

Back at the command line now:
nc 7777
See the NMEA messages displayed on the screen
CTRL-c to quit

1 Like

Or you could use USB-to-pc serial connection, available among the position output options, for the same purpose.

Thanks @bide that worked fine!

@egor.fedorov I tried that but I don’t know how to access the data on my laptop after setting up the connection. If anyone knows the procedure I would really like to know though

When connected over USB, Reach will automatically create a /dev/ttyXXX entry. You can open this port with something like screen /dev/ttyXXX baud_rate. The XXX name differs from time to time, usually it’s ttyACM0 or ttyUSB0.

1 Like

Hi! I have a very similar problem, but I am using Windows. I’ve configured our Emild Reach to send data via USB-to-pc. The software of our thermal camera is supposed the accept GPS information (NMEA, RMC), but it (and either the laptop itself) does not recognize the emild Reach connected via USB. Could somebody please help?

I can find the ttyACM0 entry but when I run screen /dev/ttyACM0 baud_rate it just prints [screen is terminating] and terminates.

I also tried screen /dev/ttyACM0 115200 in case that’s what you meant but it gives the same result

edit: it works if I use sudo


See if Reach creates a COM port on your Windows machine. Try to read the COM ports on your PC with a terminal app, like RealTerm. If none of the COM ports contain NMEA output, install the flash tool for Windows(found here). It will also install special drivers, which will help.

Yeah, by baud rate I meant a real number you chose in the ReachView settings.

My bad, screen requires super user rights, unless you add your user to group dialout and relogin.

Did you manage to see valid data after all?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.