Connect Emlid M+ with Nvidia Jetson TX2 with USB

Hi, I am building a Robocar which is driven by Nvidia Jetson TX2 and Emlid Reach M+. The M+ works with another Emlid Reach RS+. I connect the M+ and Nvidia Jetson TX2 through USB cable. This way, M+ is powered by the TX2 and I do not need addition battery for it. I also want my TX2 to receiver the GPS data from the USB so when I run this car, no WIFI or Cellular data is needed. I setup the M+ position output with TCP following the instruction here GPS data over USB by bide Pro user. Basically, use server, localhost, port 7777 and NMEA format. After the setup, I can see the NMEA data with linux command

nc 7777

However, I found that sometimes this nc command got stacked there. It did not return the NMEA data for a long time. Sometimes never return at all. This means the data can not be accessed by the TX2.

Why? How can I fix it?

1 Like

Hi @AutoCar,

May I ask you to try any port below 3000? These ports are reserved especially for position output now.

In ReachView, the App requires to select port above 3000

Hi @AutoCar,

Sorry for misleading you, it seems I mixed things up a bit.

We’ll try to repeat your setup with RPi, however, I’m afraid, it may take a bit longer as we’re working remotely now and don’t have access to all the equipment.

In the meantime, may I ask you to try getting the data from /dev/ttyUSB0 using the screen command? Does the issue persist in this case? For this, you need to change the TCP option to USB-to-PC.

Hey there,

We’ve tried to reproduce the behavior and would like to post the update here so that it might be useful for others in the future.

There are two possible causes for that behavior. The first one is that the receiver loses connection to the Nvidia Jetson computer. This can be checked by simultaneously pinging the Reach M+ from Nvidia’s side.

The second possibility is that the NMEA stream might freeze when the receiver is unable to calculate the solution. In this case, there are simply no coordinates to send.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.