Getting Started

Bide, So that’s the good news. in my house and surroundings, there are many houses with wi-fi, as well as the wifi on my iPhone. The question then, is which one.

I suppose you could put Reach in a metal box or metal filing cabinet or similar place like the trunk of a car to reduce the WiFi signal. Then push the power button and close the door and wait for 1 minute or so for the boot up. Then you can see if Reach RS has solid blue LED which means hotspot mode. Now you could connect your iPhone to Reach RS hotspot once more and take the opportunity to delete any WiFi networks in the Reach RS settings, and then once more enter your iPhone hotspot information into Reach RS. Turn off Reach RS, enable iPhone hotspot, Turn on Reach RS and hope for a proper connection!

Recently one other forum member had trouble connecting with his Reach. His problem was that one character was being entered incorrectly, even though he was sure it was correct. I think it was the uppercase letter ‘i’ and the lower case letter ‘L’ --> IlIlIl (they look the same on my screen here. So just make sure that your hotspot name has no characters that could be confused. Maybe even consider using only numerals and characters from the Latin alphabet in case there could be problems with international character encodings.

If you don’t have success this time, I may have to let someone else pick up the torch on this problem!

It was the capital J but the L would be similar. The iphone automatically capitalizes the first letter in a name or sentence unless you manually make it uncapitalized. so if you do not notice that the reach may hvae a small letter. My problem was I had 3 other devices that would connect no problem, that was because they located the wifi names automatically so I did not have to enter it as I did on the reach. Hope that makes sense.
Jim

1 Like

bide, I tried as you suggested. Using the Rover unit.

Blue light was pulsing. In Wifi, reach:f2:bf was detected. I selected it.

Response: No internet connection.

OK, please give more detail or upload a screenshot about this:

Basically, I want to know if:

  1. Your iOS is complaining it cannot access the global internet through the Reach RS, or
  2. if ReachView is saying that it cannot access the internet through your iPhone.

If someone else has the iPhone and understands the problem, please put down your popcorn and chime in :wink:

I repeated the whole process with the Base unit.
Again, negative results.

Next I tried with the Rover unit and managed to go one step further before getting stuck.

  1. iPhone hotspot on,
  2. Power on Reach RS Rover unit,
  3. In Settings, Wi-Fi on. Choose network reach:f2:bf,
  4. Response: No internet connection,
  5. Open Browser: Load 192.168.42.1. Saw ReachView Updater Window this time. Press Blue circle with + sign.
  6. Asked for Network. It showed some preset characters (can’t remember what). I over-wrote it with reach:bf:bf (not sure if this was a mistake or not),
  7. Security displayed: WPA2-PSK,
    then entered password: emlidreach. SAVE.
  8. Go to Browser: 192.168.42.1, enter.
    Save password.
  9. In Browser, click reach:f2:bf, connect. Response: Reach is connecting to another network.
  10. Try ReachView app in iPhone.

Comments: Unlike my attempts with the Base unit, where on 1 occasion I had to grant access to the iPhone hotspot and enter the access password, the Rover unit never asked for that.
There was a message to check the version of the ReachView app to ensure it was v2.8.0. The app was only downloaded this week, so I presume it must be the latest version. I am unable to find any information of what version is it.

Thanks to everyone for your help so far.


This is from iPhone Settings Wi-Fi.

In the Browser,

,
I select reach:f2:bf, it asks: Forget or Connect. I click Connect,
Response:

Thank you for the details and the pictures!

  1. iPhone hotspot on,

OK

  1. Power on Reach RS Rover unit,

OK

  1. In Settings, Wi-Fi on. Choose network reach:f2:bf,

OK, taking this action turns off your iPhone hotspot because your iPhone WiFi can’t be in hotspot mode and client mode at the same time.

  1. Response: No internet connection,

Correct! Reach RS is not an internet provider, and so it will always have this message.

  1. Open Browser: Load 192.168.42.1. Saw ReachView Updater Window this time. Press Blue circle with + sign.

Good.

  1. Asked for Network. It showed some preset characters (can’t remember what). I over-wrote it with reach:bf:bf (not sure if this was a mistake or not),
  2. Security displayed: WPA2-PSK,
    then entered password: emlidreach. SAVE.
  3. Go to Browser: 192.168.42.1, enter.
    Save password.
  4. In Browser, click reach:f2:bf, connect. Response: Reach is connecting to another network.

I think you are feeding the snake it’s own tail here. This is where you should enter the particulars of your iPhone hotspot: name, encryption type, password. It will be something like: “Wong’s Iphone”, WPA2-PSK, Wongpassword

  1. Try ReachView app in iPhone.

Correct!

So try once more and I think you’ll have it!

Thanks Bide. Do I need to switch off the Wi-Fi and enable the iPhone Mobile Data?

I did that, no luck.

Next I switched on Wi-Fi and enable my hotspot on the iPhone, automatically the iPhone selected reach:f2:bf, with the same response: No Internet Connection.

Next I try the browser. It stated that another network is used and instructed to switch to iPhone.
I turned off Wi-Fi and enabled iPhone Hotspot.
It says Personal Hotspot 1 connection. Safari cannot open the page because it could not connect to the server.

After you have set Reach RS WiFi settings to automatically connect to your iPhone hotspot, then:

  1. Turn on your iPhone hotspot.
  2. Only enable iPhone Mobile Data if you want to (it will let Reach RS check for updates).
  3. Use the iPhone ReachView ‘app’ to find your Reach RS.

The part written above does not make sense. If you turned on the hotspot, then your iPhone will not automatically connect to Reach RS. It is the opposite. Reach RS needs to be rebooted and it will look for your iPhone and connect to your iPhone.

Yes, this is what you should see when you power on your Reach RS and the blue LED starts to pulse.

If that connection actually is the Reach RS then you should be able to find it with the app. The iPhone will give Reach RS it’s own address and so it will not be like 192.168.42.xxx or 192.168.2.xxx

Bide,

The Wi-Fi is off. Only mobile data and hotspot is on. I rebooted the Reach RS. Blue is pulsing.

I start ReachView. This is the message.

Just to clarify, I am doing this exercise inside the house.

OK, so to confirm:

So if the Reachview app does not find your Reach RS, then maybe try and download the “Fing” app on your iPhone which is what was previously recommended for finding Reach devices on the local network.
https://docs.emlid.com/reachrs/quickstart/#accessing-reach-rs-device-in-a-network

Reach devices are usually listed as “Murata Manufacturing” in the Fing app. Take the IP address that Fing provides and type that into your browser. It will probably be something like: 172.20.10.xxx


If that still doesn't work, I think the next step is to connect Reach RS to a computer by USB. Once set up over USB, then you can access the ReachView web page over the USB cable and play with the wireless settings much more easily.

I think the simple answer is eluding us somehow.

Bide, I have fing. I didn’t use it because the documents said it was for android.

!

In fing, Wi-Fi chose reach:f2:bf. Response: No Internet Connection.

I looked around and selected iPhone in the network. It showed this:

It shows:
Enter a name,
Enter additional notes,
Enter where device is located.

Can you advise what information to provide?

Just a sidenote about blue led flashing.
On RS.
When blue led is flashing slowly, RS is connected to wifi/hotspot
When blue flashing fast, it could be in hotspot mode but i notice it also sometime get stuck in this mode if i hammered in alot of changes and/or if i am pushing the range of wifi to where it loose connection. Reboot usually fix this for me.
Other thing if its not been mention before. Use simple password and avoid special signs. Safari browser is also or has been problematic before. And to rule out iOs bug for the reachview app, use Fing as suggested. For fing to see reach, both phone with fing and reach must be on the same network.

On my samsung when i use it as hotspot, i can see when reach connects to it in the network options, does Iphone have this?

1 Like

Bide, I connected the Rover to the laptop with USB.

  1. Open Settings/show available network.
  2. Selected reach:f2:bf, password: emlidreach.

It shows: “No internet, secured.”

To send this message, I have to revert to my house wifi.

This is what I see in the Documentation:

• Find the IP address using “Fing” app.
Android
Android does not support name resolution in local network. You will need to find the IP address:
• Find the IP address using “Fing” app.
• Use “Network Tools” app, it is also able to find Reach IP address when it is connected to your smartphone hotspot.

Tx TB_RTK, The blue light is blinking slowly

Fast or low?
Edit: ah noticed

In this picture, I see your iPhone hotspot is off. I also see that Reach RS is in hotspot mode. (is that correct?)

This is totally opposite to what I was trying to help you accomplish. I was hoping your iPhone hotspot would be on, and the Reach RS would be in client mode and able to be discovered by Fing. And that Fing would display the Reach RS IP address.

I am out of ideas for now. Maybe TB_RTK can illuminate the situation.

**note: Is it me, or did the blue pulsing light mean Hotspot mode in older ReachView and now blue solid means hotspot mode. If that is correct, then maybe the installed ReachView software is not new and not supportive of detection by the ReachView app. --Just a thought.

I pretty sure solid blue is hotspot in recent version.
As mention above, i noticed it starts flashing fast if i push the range and loose connection, but i still see reach hotspot on my wifi but not able to connect to it before i reboot.

I`m not sure i have more to add, other then for the user to start over and re-read every step to make sure its done in the right order