Getting Started: Unable to upgrade to ReachView v2.9.3 with iPhone 6+

It is necessary to provide following information to get help:

  1. Firmware image and ReachView version.
  2. Detailed problem description. How does observed behavior differ from the expected one?
  3. Your step by step actions.
  4. Picture of the setup and connection scheme.
  5. If using any additional hardware please provide exact make and model.

Current ReachView version 2.9.2.
Objective: To upgrade to 2.9.3

Hardware: iPhone 6+,
Wi-Fi connection: iPhone Personal Hotspot.

  1. Switched off all Wi-Fi networks,

  2. Switched on iPhone with Wi-Fi off.

  3. Power on Reach-Rover.

  4. Go to iPhone settings, select reach-rover:f2:bf

  5. In Browser, load 192.168.42.1, EMLID ReachView displayed. Notification: ReachVie v2.9.3 is available. Upgrade now.
    Screenshot 1:

  6. Click on “Upgrade now”.

  7. Screenshot 2: Welcome to ReachView.

  8. Switch iPhone Wi-Fi back to data and Personal hotspot.

  9. Return to Browser, “Welcome to ReachView”.

  10. Select iPhone. Screenshot 3 is displayed.

  11. Click “Connect”. Message: Reach is connecting to another nettwork. Switch to iPhone to continue. This was already done in Step 8 but it is not recognized.
    Screenshot 4:

  12. Return to iPhone settings to confirm that Personal Hotspot is on.
    Screenshot 5:

  13. Return to Browser, refresh 192.168.42.1. Message: Safari cannot open the page because the server stopped responding.
    Screenshot 6:

  14. Refresh: Returned to “Welcome to ReachView” page. Doesn’t happen all the time. Most times, it ends up with Screenshot 6.
    Screenshot 7:

  15. Tried fing. Devices. Screenshot 8

  16. Checked fing, MyNetwork. Screenshot 9

I have repeated the procedures over and over the past few days and kept getting stuck at Step 13.

Where have I gone wrong please?

*BTW: nice demonstration explaning what you tried, and including screenshots :+1:

1 Like

Proposed connection scheme for software update:

  • addresses within {} are IP addresses
  • arrows indicate which side is the client and which is the host (or server)

Reach device (WiFi client) emission_right_sm {172.20.10.x} ----private_network----> {172.20.10.1} emission_left_sm (WiFi hotspot) iPhone 6+

iPhone 6+ (cellular client) emission_right_sm {i.j.k.l} ----private_network----> {i.j.k.1} emission_left_sm (cellular host) Cellular data provider

Cellular data provider (client) {a.b.c.d} ----public_internet----> {e.f.g.h} (server) Reachview update server

1 Like

Upgrading the ReachView software via the Internet when your Reach is normally being used in hotspot mode. (which means it normally has no internet access)

A. Check to make sure Reach is configured to connect to my iPhone hotspot.

  1. Switch off all Wi-Fi networks which are familiar to Reach.
  2. Power on Reach device.
  3. Power on iPhone.
  4. Go to iPhone settings, select Reach device. ( reach-rover:f2:bf )
  5. In Browser, load http://192.168.42.1:5000 , the static address of the ReachView update page (when Reach is in hotspot mode).
  6. See that “iPhone” is saved, and optionally check the name, security type, and password for correctness. Otherwise if not already saved, enter your new iPhone hotspot information.

B. Let Reach connect to iPhone hotspot.

  1. Power off Reach.
  2. Enable iPhone hotspot (and mobile data)
  3. Power on Reach.
  4. See "1 device connected"on iPhone screen.
  5. Use Reachview “app” or use Fing to learn which IP address your iPhone has given to Reach.
  6. In Browser, load [that IP address] ( possibly: 172.20.10.x )
  7. See notification: “ReachView v2.9.3 is available. Upgrade now.”
  8. Click “Upgrade now.” (or in Browser, load [that IP address] with :5000 appended)
  9. Proceed with update.

Finished!

(4th edit)

1 Like

Let me emphasis and second this one :wink:

@bide, tx. I am starting to get the idea.

@bide, I followed your steps. Eventually, I succeeded in upgrading the ReachView but not in the way expected. Below is a table showing the steps.

A few things I don’t understand:
Step 10.


fing shows iPhone MyNetwork presence of reach:f2:bf and not reach-rover:f2:bf.

Step 11. IP adddress is 192.168.42.0/24.

Step 12. In Browser, load 192.168.42.0/24. It jumps to google search.

Step 13. Tried to load reach-rover.local in browser. Welcome to ReachView. Click Update.

Step 14. Upgrade fail.

Step 15. Fiddled around, trying different things. Eventually, it appeared as if upgrading seemed to take place but it was very slow, appearing to hang at times. Version 2.9.3-r0. After waiting about 20 minutes, upgrade was successful. Clicked “Reboot and go to the app!”. But if I am asked to replicate it, I don’t think I would know how. Anyhow, thank you for your advice. The upgrade was done eventually.

Following the successful upgrade, I tested the Base and the Rover in the field. After a bit of muddling, I managed to survey a few points.
Just now, I took the Rover and the iPhone into the field, away from the effects of ASUS.
Steps:

  1. Off iPhone,
  2. Power on reach-rover,
  3. On iPhone, enable iPhone data and hotspot,
  4. In browser, load reach-rover.local. After a few minutes, the EMLID Status window came on. And I saw this:
  5. Reach-rover 172.20.10.8. So you were right on your step B12.

    But I am confused. Why is it not shown on fing?
1 Like

Tried to load 172.20.10.8 on the browser with reach-local powered on.

Message: This site can’t be reached.

What is the reason for that?

Edit 1:
Power LED (orange) Stationary - Normal operation
Network LED (blue) pulsing - Client Wi–fi mode
Stat LED (green) Stationary - Normal operation

reach-base works fine.

If you do this, you need to connected your phone to Reach hotspot and NOT use phones hotspot.
IF you are gonna make step 2 and 3 work, you need to boot iphones hotspot FIRST and then boot reach.

1 Like

Also, the 172.20.10.x network is controlled by your iPhone. Each time that Reach RS connects to the iPhone hotspot, iPhone will probably assign a different address to Reach RS. The address given will be one of 13 addresses within this range:

  • 172.20.10.2
  • 172.20.10.3
  • 172.20.10.13
  • 172.20.10.14

Really, it [your Reach device] should be appearing on Fing [with one of those listed addresses] and [it should] also appear in your ReachView app.

1 Like

If I may Bide…on my iphone fing wont show me its own hotspot. I have an Ipad that has fing and it will show me the iphones hotspot and any connected devices that way(clear as mud).

2 Likes

I corrected my wording in the post above. Does that make better sense?

So Jim, what you are saying is that Fing on the iPhone will not scan it’s own 172.20.10.0/28 network?

What about the ReachView app? Is that working for you on the iPhone to find Reach devices which are connected to your iPhone’s hotspot?

Bide
Yes that is correct it can’t find itself. I beleive that the Reach App worked but I will try it tomorrow and confirm it does, my memory is short some days.

That’s fair that iPhone doesn’t find itself, but it should find any devices which connect to it’s hotspot. e.g. Reach, your iPad, etc. Any of those connected devices will have been given an address from my list above and should appear in Fing. And most certainly the Reach devices should appear in the ReachView app.

The phone itself will keep these three addresses for itself:172.20.10.0, 172.20.10.1, 172.20.10.15 but that is inconsequential as there is no reason for us to be using them.

@bide, @jmcarthur , thank you for your feedback and advice. I have got it working on the Laptop with a certain level of confidence now. One of the problem is the long lag time for the Reach to respond when we load reach-base.local or reach-rover.local and rejections (unable to connect). So I kept refreshing until it got through eventually. It is faster with the Base but extremely slow with the Rover. Is there a reason for the difference?

I can imagine this can be a challenge for first-timers. And should be highlighted in the documentation. Or is it just me?

One key step (as pointed out by Bide) is during the switch-over from the Reach hotspot to the laptop Wi-Fi, it is necessary to reboot the Reach. Ensure only 1 Wi-Fi is operating at one time. Not sure if this is a factor but just to be on the safe side.

Once again, thank you for your help. Much appreciated.

1 Like

Glad to hear it! It can only get better from here!

Yep. Give it a couple of minutes to boot and get the web server running. When the blue network LED stops the quick flashing, then it can still take a minute or two before you can load ReachView in your browser. In the past I noticed that constantly refreshing the web page can put extra load on Reach and make it slower to respond. Best to try, then wait a minute before trying again.

Thanks, Bide. This should be highlighted in the documentation. It is very disconcerting for a newbie to stare at a frozen screen, unable to understand what is going on.

1 Like

This is the key. I am able to repeat the process with the iPhone. Thanks for your patience and guidance. Now for the field work.

1 Like

Just an update. Its cold here today -17c that’s a little early for us.
Anyways when reach modules are connected to my iphone’s personal hotspot:
1 > I am unable to find any device connected to the iphone hotspot in Fing
2 > I am able to get the address of the reach module on the iphone hotspot using the Reach App.

Just another observation:
When I have done the last couple of updates, when the update is finished installing, I have not had to reboot the reach module from the updater page. I just go back to the reach.local page and wait for about a minute and refresh the page and it will reconnect to the reach module with the update done. This is done from my laptop as I find it much easier to work from when I am able.

3 Likes