Getting more consistent Fix

I have reached pretty decent performance for RTK. But “Fix” is not consistent as I wish, so I was wondering - maybe I am missing something in settings, which could improve performance? Here is base’s setting:

And here is rover’s setting:

Perhaps, I can turn on Beidou. But what else? Max acceleration? More RTCM3 messages? Will it help to get more consistent “Fix”?

I like the word.

Less is more

Have you tried with only GPS and enable more If you need more?

2 Likes

I also notice you have great amount of data going out from base. You don’t need all of them and you might reduce speed for some of them to 0.1hz. More about it here
https://docs.emlid.com/reachrs/common/reachview/base-mode/#rtcm3-messages

2 Likes

I have tried combination GPS+GLONASS+SBAS.
Then I found this message - Slow RTKfix (AR validation ratio) - and turned on GALILEO and QZSS (I am in Japan, so I thought it will be reasonable). After that performance seemed more consistent, maybe just placebo. Well, at least it did not become worse. I was struggling with GLONASS AR mode + NTRIP bug, so there is no time left to play around with GNSS selection. I’ll try to follow your advice tomorrow and see if there are any improvements.

Please set GPS AR to “Fix and hold” and Glonass AR to “ON”. There is no issue with using Glonass AR when you are connecting two Reach units over NTRIP, it is when you are connecting Reach to a different receiver over NTRIP. In other words inability to do Glonass AR is related to different base and rover pair, not to the protocol of communication.

With version 2.13 we added ability to perform Glonass AR with different receivers, so this should no longer be an issue.

Here is a list of things that you can do to get better result:

  • As you are in Japan I recommend to actually use GPS+Galileo+Beidou instead of Glonass.
  • As you are using NTRIP connection you can actually set corrections to 5Hz, which would make fix even faster.
  • No need to send messages 1019 and 1008, this a legacy thing and we will remove them soon from selection at all. They are not used and are just wasting bandwidth.
  • Fix and hold on your rover instead of continuos.
  • Update to v2.13
1 Like

TB_RTK, thank you for suggestions, but actually non of them worked. I started with only GPS, did not get any fix, started adding other GNSS systems, but eventually ended up with same settings. Actual solution was increasing max horizontal acceleration. After that I was able to get pretty decent fix during walking (with AR validation ratio around 4-10) even with continious GPS AR.

Igor, thank you. Setting GPS AR to “Fix and hold” allowed me reach 999.9 ratio. Ditching Glonass over Beidou also gave me 3-4 sattelites more and faster fix. Sending RTCM corrections at 5Hz was too much for my budget&crappy mobile internet. But as I understand, 2.13 version is not stable yet. I do not wanna shift to dev firmware right before field works. And about Glonass AR and NTRIP on 2.11.0 - I hope no one will get angry, if I wrote my concerns in Russian for Igor (sorry, I do not have much time today).

Вы хоть и написали, что проблема с кастерами и глонассом не касается тех, кто пользуется одинаковыми модулями Рич и даже на предыдущих прошивках, но у меня упорно отказываются “фикситься”, если я включаю Glonass AR mode. Бывает, что если в самом начале, при включении, ratio доходит до 2,5 -3,5, но это длится пару секунд, а потом вдруг резко падает до 1,1 и остаётся 1,1-1,3 сколько ни жди. Стоит мне выключить Glonass AR mode(других настроек вообще не касаюсь), так сразу всё хорошо становится, ratio с лёгкостью доходит до 999,9. В общем, я без понятия, это происходило и когда GPS AR был в режиме continious, и происходит в режиме fix&hold. Так как завтра уже полевые работы, то не стал с этим бодаться, работает - хай с ним.

1 Like

In the configuration of your ROVER (RTK) place in: GPS AR mode “Fix and Hold”

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.