Getting Coordinates for a home base station?

I’m trying to set up a base station in my backyard and trying to find the exact coordinates over a spike soi can easy setup my reach to communicate using my home network.

I set up my REACH RS and let it log for 24+ hours. Following the GPS post-processing tutorial and using a local DMV observation post (5km away) as my base station. I got a close Grouping (see below). I then decided to test it against 2 other logs i ran before 0:00 UDT (1hr and 2hr) (didn’t touch tripod between logs) when I plotted them together my error went from 40cm to over 120cm (see image below).

Is there something I’m missing. It doesn’t seem to make a difference if I run it in kinematic or static mode.

Could you please share all three logs ( all files). I am pretty sure we will find an explanation for you.

Here are the 5 raw files (3 raw REACH RS files and 2 days of Observer Files)
Hope that helps. I re-ran them setting position mode to “static” and they made small groupings but where still 1m apart.

i cant see any files.

1 Like

If you open up each of your three .pos files, is the base station coordinate identical in the header of each file?

For example:


% obs start : 2018/02/26 01:03:50.8 GPST (week1990 90230.8s)
% obs end : 2018/02/26 01:23:50.6 GPST (week1990 91430.6s)
% ref pos : 9.529671001 -79.335202995 35.1233
%
% (lat/lon/height=WGS84/ellipsoidal,Q=1:fix,2:float,3:sbas,4:dgps,5:single,6:ppp,ns=# of satellites)
% GPST latitude(deg) longitude(deg) height(m) Q ns sdn(m) sde(m) sdu(m) sdne(m) sdeu(m) sdun(m) age(s) ratio

I upload them to my google drive

https://drive.google.com/open?id=1rcDx7DmV-2y29DXOq0k8artw_mTjQzyY

no :frowning:

1hr
% obs start : 2018/02/25 20:05:54.8 GPST (week1990 72354.8s)
% obs end : 2018/02/25 20:59:30.4 GPST (week1990 75570.4s)
% ref pos : 40.196190138 -75.059924118 72.6892
2hr
% obs start : 2018/02/25 21:04:49.8 GPST (week1990 75889.8s)
% obs end : 2018/02/25 23:58:02.6 GPST (week1990 86282.6s)
% ref pos : 40.196185635 -75.059916941 72.0855
24hr
% obs start : 2018/02/26 00:21:11.4 GPST (week1990 87671.4s)
% obs end : 2018/02/26 23:57:47.0 GPST (week1990 172667.0s)
% ref pos : 40.196190121 -75.059913050 72.1543

Did you convert basestation files?, if so then dont.
I used rinex header for base coordinates on all three measures and got almost bang on point every time. See screenshot below

2 Likes

I’m thinking the base coordinate setting that was used must have been “average of single position.”

@TB_RTK If the real base position (DMV observation post) has published coordinates, then they should be entered manually, no?

Also make sure that the published base coordinates are in WGS84, and if not, then convert them.

1 Like

Well… i think this looks right, but i could be wrong of course. What do you think?
The obs file has the coordinates located inside and with rinex header i get the same. The last digit is a bit of, not sure why

2 Likes

I am not sure, but it is definitely close enough!

1 Like

I just checked my settings. I did have the base station set to “average of single position.” I’m Rerunning them now with the Coordinates set.

1 Like

Ahhh,man!!! are you kidding, i just run a 1Gb obs file for hours just to get this result. :mask:
Edit: Just kidding, glad to help :kissing_heart:

@bide , then sigar it is :sunglasses:

2 Likes

Sorry :). I was just following the Documents

https://docs.emlid.com/reachrs/common/tutorials/gps-post-processing/

Select “Base Station”. Choose “Average of Single Position” for any log to average single point solution

I just didnt read the Or part :roll_eyes:

or “RINEX Header Position” to use approximate position in RINEX .obs header.

2 Likes

What do your results look like now? Did the time differences make much of a difference? I imagine the groupings will all be tight, but do you think the longer time logging improves absolute position much?

So if you enter an exact llh position for the base station location under RTKPOST->Options->Positions->Base Station it should show up as

% ref pos : coordinate you entered

in the pos file right? I am having the same issue as OP but I double checked my setting and it was llh not average single.

There could be some rounding issue in the least significant digits if RTKLIB is internally converting WGS84 --> XYZ --> WGS84.

Can you compute the distance error and see if it is substantial or negligible?

RTKPOST seems to be ignoring my input coordinate completely. Here are some ss I took of the setting and result. I put a random llh coordinate in setting and it is giving me same ref pos as “Rinex Header”.

nvm wasted 1 day to find out it wass a bug…

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.