Galileo M8T firmware is now available

Yey! U-blox finally released FW3.01 for the M8T chip used in Reach. That means that Galileo is coming to all users. We have not tested it yet, nor have we written the code to make update available through the ReachView. Just sharing the good news :slight_smile:

11 Likes

Where can I get this if I want to flash the ubox by myself? I really need to get the Galileo functionality asap.

You should check out u-blox website.

As far as I can see ublox have not made the firmware update publicly available. I just thought you guys might have more access as a manufacturer.

I’ll try sending ublox an email to hear if they are willing send it to me.

I’m not having much luck with this. The response I got from U-Blox was more or less a flat out no.

U-Blox seems to be intent on keeping the new firmware out of public circulation for the time being. So unless you are a important customer of theirs you will most likely not be granted access to it. It will probably be made public eventually but I have no idea when that might be.

My suggestion to the guys at Emlid is that they get in contact with U-Blox about the firmware as soon as possible if they haven’t already, because it will likely not be as simple as just asking for it.

@amswede We’re in the process. As soon as we have any results we will post an update.

Egor,
Heard anything from UBlox yet. Seems quiet on this tread.

So is this firmware update for the M8T dead in the water? Nothing about it for over a month?

We have the firmware and are able to track Galileo sats with Reach, but waiting for u-blox to provide us documentation for the flashing protocol so that we can upgrade all receivers for our customers.

7 Likes

Great thank you for the fast reply.

Ublox Ucenter has the function to flash firmware. If the Reach is connected to Ucenter, then a user should be able to flash the firmware.
You can access the M8T via Ublox Ucenter by ssh into reach module and then running:

socat /dev/ttyMFD1,b230400,raw,echo=0,unlink-close=0 tcp-l:4000,reuseaddr,fork

Open Ucenter and connect via tcp://URL:4000

then follow firmware directions provided by Ublox.

@lewissw We are well aware of this :slight_smile: But we would prefer not to force our users to do update this way and that’s why we are working on an automatic update utility built into ReachView that uses Ublox flashing protocol.

ok! what is the effect using galileo for reach. does it help to getting better solutions?
at the moment i am working with gps only > for me best an stable working!

a

Andreas,

I think Galileo will be more value in the future. It is still being deployed.

I believe that Glonass and Beidou will have more potential for now.

Galileo does have some changes in system design that should help under less than ideal situations( under poor sky views?). For now, I think it will be not first choice, but may add better performance in a few years.

1 Like

Wow, still no firmware from Ublox. I went ahead and used the 3.01 firmware for the M8N on one of my units and it works well getting the Galileo satellites but you definitely lose the timing messages not sure which is better :stuck_out_tongue: . I guess we just keep on keeping on.

We got required documentation and are working on implementing the update procedure. This is being done in parallel with more important features so do not expect it too soon :slight_smile:

1 Like

Igor, I was not commenting on the speed you are rolling things out but rather Ublox. The support Emlid provides their community is impressive and seems to have greatly advanced what would normally be called the lower end GPS field.

1 Like

Are there any known problems if Reach M8T is flashed to 3.01?
Is this the correct MD5 Hash of the firmware: 911f2b77b649eb90f4be14ce56717b49?
See also: http://wiki.openstreetmap.org/wiki/UbloxRAW

what is the status for updating m8t on reach to 3.01.
i think there are many advantages for us users?

what is the status of new reach view?

regards andreas

Why are the timing messages needed? RTKLIB does not use theses timing messages, as they are not definied in ublox.c.
The startup scripts for Reach UBX TIM TIM2 seem to enable the timing messages, but I don’t know why.

I have successfully flashed the SPG firmware and Reach works now with Galileo satellites.
Flashing was a bit complicated because it did work just after several tries. Be aware, that there is no way back at the moment.
The selftest during start-up (Ubloxtest.py) will no more work, it has to be disabled.

1 Like