Flashing Reach RS - Win10

Hello - I am having a heck of a time getting and older Reach RS unit flashed to the latest firmware.

Here’s what I’ve done so far:
Install Edison windows drivers (win 10)
Run Reach firmware flash tool - never gets past “Looking for Reach RS…”
Run through Edison setup and select image to install - fails with “Uh-oh! Your Intel® Edison image did not update. This is likely because the Intel® Edison did not reconnect properly. You’ll need to download the newer firmware and manually update the Intel® Edison board. Detailed instructions available at https://software.intel.com/en-us/flashing-your-firmware-edison
Tried installing generic WinUSB drivers via Zadig and running the above step again, with no luck.
Tried installing older 2.3 image with flashall.bat CLI (newest image doesn’t have this .bat file) - fails with “Device has DFU interface, but has no DFU functional descriptor
Cannot open DFU device 8087:0a99”
Tried looking for device in Intel Phone Flash Tool Lite and the Reach RS shows up, but immediately disconnects. Sometimes it does this a few times before ultimately showing as disconnected. Hardware alternates between “USB download gadget” and “MERRIFIELD”.

I’m out of ideas. Any help is very much appreciated.

1 Like

Hi @cojeffj,

Which firmware version is installed on the device now? It’s possible that you can just update the device without performing the reflashing procedure.

Also, just to make sure: do you use the latest version of the flasher from our docs?

Current firmware is 2.20.8
The ReachView app won’t update the unit automatically. The updates section says “this is a huge software update for original Reach RS and Reach RTK. It allows old Reach models to continue receiving every update in the future and support newest software”. So that led to the Emlid Docs section on firmware flashing, which is where I’m stuck currently.
Oh and yes, I’m using the latest version of the flashing software.

I finally got it to work. Hopefully this will help other people running windows 10 for updating the RS to the latest image.
Before installing any drivers, follow these instructions to disable driver signature enforcement:


Then, install drivers as usual. I installed the Edison drivers via the edison setup and placing IntelEdisonDriverSetup1.2.1.exe in the installs folder (intel workaround is here http://files.emlid.com/firmware-reflashing-tool/IntelGUIWindowsWorkaround.pdf) , and also installed winUSB drivers with zadig (I don’t know if this is necessary or not).
After this I was able to use the Reach firmware flash tool as normal.
2 Likes

Hi @cojeffj,

Thank you for sharing the solution!

We also tested this. It looks like some difficulties with the Edison driver may indeed occur on particular devices. We’re now working on enhancing the process of reflashing Reach RS devices so that no one won’t experience such difficulties in the future.

1 Like

Hi @cojeffj,

Just want to let you know that we’ve released a new The Flasher tool version. There should be no issues with Reach RS reflashing. You can download it from our docs.

2 Likes

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.