FieldGenius for Android Update 1.8.2

Hi, I received this e-mail that I thought would be of interest to Emlid users, about the just released update for FieldGenius for Android Update on March 1st. I was only able to download it yesterday on March 6th, so I haven’t had time to look into the new features/refinements.
Of interest to Emlid users particularly, is that have updated the driver to address Bluetooth reconnection issues. I was having some problems with it disconnecting intermittently from the rover, so we shall see if this corrects that problem.

Below is the text from their update notice:

FieldGenius for Android Update 1.8.2 - Release Notes March 3, 2021
NEW FEATURES

GIS AttributeCollection - FieldGenius for Android now has support for allowing users to tag attribute information with their point/line observations.

Feature File Manager - Provides the ability to manage existing feature files and create new ones within the application for GIS attribute collection. Also provides the ability to import and quickly extract features from a shapefile to produce a feature list.

Shapefile Import/Export – Shapefile import/export to support working with your GIS software.Report Feedback -Built-in report feedback option to allow for users to easily communicate with development to report issues and request new features.

COGO Pt…Pt Inversing - New enhancementto the COGO calculation to allow usersto easily inverse direction and distances while using the COGO calculation functions to compute new points.

DirectionalCurrent Position – Support to display the current direction the user is facing on the map view using the internal compass on their device to help indicate which way they are orientated.

NEW AND UPDATED INSTRUMENT DRIVERS
GNSS Tersus Oscar – Updated driver to resolve height issue + settings page loading time
Emlid Reach Receivers – Updated driver to address Bluetooth reconnection issues
CHC LT700H – Updated driver to resolve connection issue
TopCon – Fixed issue with not being able to receive internet corrections

DEFECTS FIXED Issue computing manual points – Fixed bug when trying to add local points using manual point mode
Crash when using duplicate point to define arc point for line staking
Fixed a crashing issue when selecting a duplicate point to define an arc for line staking defined by points.

REFINEMENTS
Deleting Points – No longer list all points selected
NTRIP Configuration – Added support for TCP/IP networks
Added Progress Spinners–Added progress spinners to show that a task is currently active

I have been running this a little early and while I have never had BT issues since the previous release there is still an issue with a memory leak that will eventually lead to an app crash. Data is preserved, but a restart of the app is required. A second outstanding issue was with DXF import. Points were being automatically created at each vertice of the lines. I have not tested this on this update nor the “shapefile” import. MicroSurvey is aware of both issues and working on it.

2 Likes

Thanks Michael for the update! I also was experiencing the app crashes, especially with using the Stakeout application. Only lost data the one time and that was luckily at the beginning of the project, but it is rather bothersome that the app slowly grinds to a halt and crashes. Sometimes I preempt it by rebooting when I see it slowing down, but that can be a time consuming experience when you’re trying to get the job done. I have to remove some of my projects and see if that will speed up the reboot time. I also have experienced the multiple points issue and I try to clean the DXF file up best I can before importing and then after importing the file. I really do like the program so far, and I know they working on getting these issues resolved. Regards, Mark

2 Likes

FGA User here as well.
I have been experiencing the issues stated as well.
To minimize app crashes I turn off Bluetooth connection to the receiver, particularly while moving over large distances.
I believe the DC is processing too much data at once and creates an overload resulting in the app crashing.
When I get closer to the point I want to shoot/stakeout I turn the BT back on.
Far from perfect but at present it’s a work-around.

I don’t mind that FGA produces points when importing DXF - it simply means I shouldn’t include those points in my control point file and I’ll have to relinquish control over the numbering which can be a minor inconvenience.

A larger concern for me is that radio connectivity via LoRa has been very unstable particularly since mid-February. Since then I have been experiencing significantly reduced (40-50% ??) radio range.
I wonder if this is related to some Firmware update on the GNSS receiver end that I was not aware of. - (Updates set to Auto)

Otherwise I am overall happy with the Emlid RS2-FGA combo.

I am eagerly anticipating some enhancements to the COGO routines such as pre-determined area calculations.

So you are basically manually disconnecting and reconnecting the instrument. Or are you actually turning Bluetooth off and back on?

This is an Emlid/Reachview thing - not FieldGenius.

Yes!!! I would love stake to linework!

This afternoon I ran a quick test using the 1.8 FGA update on a site I had previously worked on. It ended up crashing on me 3 times in about an 2 hour period during the survey, so that problem remains. It seems like it booted up faster though, maybe because I had simplified my DXF file to just the four corners and some other various points, for a total of about 20 points. I was only shooting points and not using the staking app. I didn’t lose any of the work when it crashed. I didn’t get a chance to test anything else.
Lately I have been using an NTRIP RTN Correction Service so I’m not aware of any LORA issues that Adrian has experienced.

I also was wondering which method Adrian used to disconnect the receiver, disabling the bluetooth on the data collector or disconnecting the receiver in FGA.

2 Likes

It’s definitely not a Bluetooth issue so turning it off wouldn’t do anything but serve the purpose of disconnecting the receiver so you might as well do it in Fieldgenius. I think he’s on the right track of breaking the data stream. There’s a memory leak somewhere. I should hear from them tomorrow and will report back. Thanks for the update.

1 Like

Yes. I go to the device settings and turn of the BT Radio

I realize this but since this is an Emlid board I just thought I would use the oppurtunity to mention my experience here.

In addition though, I do notice that there are occasions when trying to take a shot in FGA I will get a “No Link” response. But if I immediately toggle over to the ReachView app I will get a “Fix” solution just fine. This appears to be a FG issue.

2 Likes

I also have experienced the “No Link” situation on the rover when using FGA and trying to take a shot. It happens sporadically and I cannot pin down a cause for it. I’m in good view, clear sky and it still can happen. It has happen with both base and rover and rover/NTRIP setups. It seems to have occur more frequently when I had changed the GNSS settings from 1Hz to the 5Hz update rate, which was over a year ago. It happened to me on one job site the one day and the following day everything was normal. I will have to try rebooting the receiver next time it happens and see if that helps.

1 Like

I’ve found the “no link” status in FGA indicates that the ‘age of differential’ of the correction is more than what you have it set in the FGA tolerance menu. Some of the default profiles have this tolerance very low, like 2sec. So you’ll have this more if you have poor cell coverage for receiving NTRIP or if your Lora is dropping some frames due to an obstruction. You could try increasing the tolerance a bit depending on your project requirements. This has at least been my experience on FGA 1.7 and below…I’ve just started with 1.8.

I use a Samsung GalaxyA 10” tab and I’ve found it’s a little under powered to process FGA with the Bluetooth ERB stream at 5Hz from the RS2 when I have GPS, GLO, and GAL enabled. The responsiveness of FGA becomes slow. I’ve found a nice middle ground at 3Hz position output from the RS2

As an FGA user with the RS2, I’m glad you guys are posting on here with your experience with this combination. Hearing about potential bugs and tips is certainly helpful for me.

4 Likes

This is exactly right and because you can have different tolerances set between Reachview and FieldGenius you can have two different solutions.

Do you notice yours lagging immediately or does it seems to build up over time? I use a OUKITEL WP8 Pro with a Octa-core processor and 4GB of RAM and it is very snappy for about 30 minutes but an eventual lag appears. If I survey all day it will happen 2-3 times.

2 Likes

Thank you & Michael for the explanation on the no link status in FGA, I will have to take a look at my settings. I didn’t realize there was a 3Hz setting available, I just thought they offered 1Hz and 5Hz options in the drop down menu.

I purchased the Cedar CT8 tablet option with their FGA software package thinking that they would optimized the software to run on it and that they also would be able to test it on a “sanctioned” tablet. It has a Qualcomm MSM8953 8-core 2.2Ghz Snapdragon 626 processor w/3GB RAM and I’m not sure if that is considered fast or not, but for the most part it seems agile, except for the aforementioned slowdown and crash of the app. I do like the bigger screen and was one of the reasons I was willing to try out their Android version of FieldGenius versus my hard to read older data collector.

1 Like

I spoke with a mobile product manager yesterday and there are two different scenarios of crashes that can occur so we need to be clear on which one is happening. I think most of you are experiencing what I am where the app just crashes and returns to the home screen, but he explained that they were not familiar with that one yet and what they had seen was that it would stop responding and then you will get an error and have to force-close the app. Good thing is with the former that FGA should automatically be logging a crash report. I will be doing some additional logging to try to capture the data they need to investigate further and anyone who would like to participate is welcome to. All you have to do is go into a Project, Settings and System and enable the Trace File. Let me know if you want to submit some files and I will setup a place we can upload to.

On a better note he ensured me that they are at work on the issue with DXF’s auto-populating points. This was an intended functionality, but is not configurable and has been adding points to incorrect places causing an overabundance of points. In the meantime just attach the DXF as an XREF and the points should not be shown.

edit
One of the files I just imported still populated points. Difference being that they do not show up in project data, but if you select them on the screen they report as points and lines.

3 Likes

I also use this device as a data collector. All my RTK work so far has been with the built in Emlid LoRa solution

Since the first of the year, I have been using GNSS RTK Correction service for most of the time. I only pull out the base for logging for later processing on new job sites and sometimes for RTK corrections via LoRa when I lose cell service. It’s been mostly line of site, so I haven’t experienced the LoRa issues you have mentioned, though I will lose the LoRa connection it if I go over to the other side of a hill for instance.
Some of the sites I have worked on have trees and other conditions that sometimes limit the use of GNSS solutions and I then have to resort to a total station.

I have experienced the latter condition, where you have to force-close the app and then restart the FGA app. I don’t believe I have experienced it where it crashes and then it goes to the home screen of FGA, where you could just then restart the project you’re working on. I always had to restart the app, then go to my project.

To clarify it goes to the Android home screen and I relaunch FGA. The other scenario is that it stays hung with an error message and you have to force close through settings.

VRS?

Ok, that is what exactly happens to me when it crashes. Thanks, Mark

Yes, I have been using the VRS option from HxGN SmartNet Network, which they call it VIRS. They offer both Nearest and the VRS options for correction.

1 Like

Did a localization with layout of 8 points and collection of 8 different points for drone GCP’s. The app crashed at least 4 times in the span of 2 hours. I have yet to pull the trace files, but will do that in a little bit and get them to the mobile engineers.