Failed to use barometer

Another noob question but how do I download that? I tried wget and that wouldn’t work

should do the job and of course you need to be online

Thank you very much.

It’s now giving:
(4x) Failed to open device: No such file or directory
Temperature©: 20.010046 Pressure(millibar): 0.040460

could you post a pic of your navio/rpi?

also make sure you don’t have multiple instances of ArduPlane running; and make sure ArduPlane is not running during executing examples!

I’ve been running a clean startup each time so should be OK in that regard.

Do the pics help at all?

pics look good so far;

could you run :
in the command line and make sure no Ardu* instance is running?

are the values in the example constant or do they differ after time?

Yep, no Ardupilot or related processes.

The values are constant, and the same each time it’s run

last thing i can come up with would be switching to a different power source to rule out a power issue…
either from your esc/ubec or your power module

Unfortunately I don’t have those right now, I’ll try again in a couple of days when they arrive

go to the ADC folder (right where the Barometer folder is)
post a screenshot of the output!

seems fine;
i’m out of guesses;
I’m sure Mikhail/emlid will have a solution for you!

Oh well, thank you anyway

Hi there!

Is it possible that you use a stock Raspbian instead of ours?

This is very suspicious. The only way I see it coming is a missing /dev/i2c-1.

I’m pretty sure it’s your version of raspbian but I’ll try a reinstall.

How would I test if the /dev/i2c-1 is missing?

A fresh install us a good idea. ls /dev/i2c-1 should not yield errors.

The fresh install seems to have solved it.

Thanks everyone