Failed to use barometer

Hi, I’m trying to run with the command sudo ArduPlane FE udp:192.168.43.86:14550. It worked before but now it’s coming up with the error message: AP_Baro_MS56XX: failed to use device.

Any advice?

Could you please check that Navio2 is fixed properly to the Raspberry Pi with screws and then run the barometer example code:
https://docs.emlid.com/navio2/Navio-dev/barometer-ms5611/

Please post the output.

I’ve checked the screws and they’re fine. Could you clarify how to run the example? Do I just type that into the command line after starting up the navio2? In which case it just says 'No such file or directory after trying both C++ and Python methods

you need to download the examples first:

git clone https://github.com/emlid/Navio2.git

then
cd Navio2
cd C++/Examples/Barometer
make
./Barometer

Another noob question but how do I download that? I tried wget and that wouldn’t work

should do the job and of course you need to be online

Thank you very much.

It’s now giving:
(4x) Failed to open device: No such file or directory
Temperature©: 20.010046 Pressure(millibar): 0.040460

could you post a pic of your navio/rpi?

also make sure you don’t have multiple instances of ArduPlane running; and make sure ArduPlane is not running during executing examples!

I’ve been running a clean startup each time so should be OK in that regard.

Do the pics help at all?

pics look good so far;

could you run :
top
in the command line and make sure no Ardu* instance is running?

are the values in the example constant or do they differ after time?

Yep, no Ardupilot or related processes.

The values are constant, and the same each time it’s run

last thing i can come up with would be switching to a different power source to rule out a power issue…
either from your esc/ubec or your power module

Unfortunately I don’t have those right now, I’ll try again in a couple of days when they arrive

goaround:
go to the ADC folder (right where the Barometer folder is)
make
./ADC
post a screenshot of the output!

seems fine;
i’m out of guesses;
I’m sure Mikhail/emlid will have a solution for you!

Oh well, thank you anyway

Hi there!

Is it possible that you use a stock Raspbian instead of ours?

This is very suspicious. The only way I see it coming is a missing /dev/i2c-1.