Emlid

Community Forum

ESC calibration problems with navio2


(freda) #1
  1. Image and ArduPilot version.


    Raspberry pi 2 B + Navio 2

  2. Detailed problem description. How does observed behavior differ from the expected one?
    We’ve done frame class and type configuration, compass calibration
    ,radio control calibration in mission planner, accelerometer calibration in mission planner, and rc transmitter flight mode configuration.
    We tried three different methods to calibrate ESCs as follow.

a.I tried the “Calibrate ESCs” in mission planner.
After pressing the button “Calibrate ESCs” in mission planner, ESCs not beeped at first ,and after few seconds ESCs kept beeping unless I disconnect the battery.
b.I tried the " All at once calibration" from
http://ardupilot.org/copter/docs/esc-calibration.html
But my ESCs didn’t emit the musical tone and the 3 of beeps and then an additional two beeps.
I raise the throttle and they didn’t spin.
c.I tried the " Manual ESC-by-ESC Calibration" from
http://ardupilot.org/copter/docs/esc-calibration.html
It worked. But when I pluged ESC cables back to navio2, I can’t test motors.
Please help.

  1. Your step by step actions.
    a.
    -Pushing the button.
    -Disconnect battery.
    -Plug in battery
    -ESCs not beep twice
    https://drive.google.com/file/d/1h_55IiMtET9-Nf7qZKs_suda81f6QsZy/view
    -ESCs keep beeping
    https://drive.google.com/file/d/1NjbwLggHMngUmm2LzsCVKgU71rI-Gx5o/view
    b.
    -Turn on transmitter and put the throttle stick at maximum.
    -Connect the Lipo battery
    -With the transmitter throttle stick still high, disconnect and reconnect the battery.
    -ESCs didn’t emit tone like manual

c.
I pluged ESC cables back to navio2, I can’t test motors or control it via rc controller.

  1. Picture of the setup and connection scheme.

  2. If using any additional hardware please provide exact make and model.

(Tatiana Andreeva) #3

Hi @freda,

Could you please post here hardware setup photos?


(freda) #4


(Tatiana Andreeva) #5

@freda,

Do I understand correctly that you can go through the ESCs calibration, but after that motor test doesn’t work?

Unfortunately, I couldn’t manage to reproduce the issue.

Have you tried to arm? Are there any errors?


(Marc Lebret) #6

Hello,

Looking at the MP screen copies, Radio settings are out of range for channels 1,2 and 4. So if ESC calibration is well done with direct esc connect to Rx, it is not possible to arm motors with 1274-1781 channel 4 range.

Marc


(freda) #7

Hi,
I can go manual ESCs calibration one by one,but after that motor test failed.
The error is “Command was denied by the ardupilot.”
And I can’t make the motor spin via rc controller either.

Also, I can’t do all-in-one calibration.

Thanks!


(freda) #8

Hi ,Marc,

What’s the right range for the radio’s setting?

The problem is that my radio controller is not compatible with MissionPlaner? Should I buy a new RC hardware?Or I just do radio controller calibration wrong?

Thanks.


(Marc Lebret) #9

It is indicated in the Mission Planner RC calibration screen. Below 1100 and over 1900.

You have to adjust endpoints of your RC Tx (as you did for channel 3) and redo the Mission planner RC calibration. If you use the channel 3 Tx endpoints setting for channels 1,2 and 4, you are in the expected range.

Marc


(freda) #10

Hi Marc,

My RC Tx can’t expand the bandwidth to below 1100 and over 1900. For example,It was 1275~1787 at first ,I only can move it to 1190~1702 or 13xx~1900.
I’ll buy another RC Tx and try again.

Thanks.


(Marc Lebret) #11

Before buying another TX, can you share Manufacturer and name of your TX. I will try to find and read the user documentation.

Marc


(freda) #12

Hi Marc,
It’s MC6C from Microzone.
I’ve tried to find the documentation but found nothing.

Thanks!


(Marc Lebret) #13

A “maybe” solution:

You have the left switch A D/R. Move it in the other position, you should obtain full range.

Do not forget to zero your Trim.

Marc


(freda) #14

Hi Marc,

It works! Thanks!

But the ESCs still can’t be calibrated and keep beeping.
I tried to calibrate in MP, the message dialog said “Set param error”.
%E6%93%B7%E5%8F%96
My AC version is 3.6.5.

I also tried Manual ESC-by-ESC Calibration.After finished the calibration,I can’t test my motors so I think the calibration was failed.


(Tatiana Andreeva) #15

Hi @freda,

Did you reset settings to default after updating to the current image version?
Note, that after resetting you’ll need to calibrate everything from scratch.


(freda) #16

Hi tatiana:

Do you mean that we need to reset the mp after updating data or parameters?Or ardrucopter?


(Tatiana Andreeva) #17

Hi @freda,

I meant updating the firmware version with sudo apt update && sudo apt dist-upgrade.

May I ask you to reset ardupilot parameter in MP and try to calibrate everything once again? You can do it in the Full Parameter List tab.


(freda) #18

Hi @tatiana.andreeva
Is there a suitable version for RPi 2B ? My version on MP of arducopter is 3.6.5.
If I check the version of arducopter directly by "sudo emildtool ardupilot ", It only showed “3.6”. How can I know that the version of MP and Navio2 are the same?


(Tatiana Andreeva) #19

@freda,

The version that is shown in the MP is the Navio2 ArduPilot firmware version. So, 3.6 means 3.6.5 in that case.

All versions should work fine on RPi 2B.