Esc calibration, ppm channel mapping

Hi,

I managed to install the Apm software. The apm is launched by default on boot of the pi (navio + and raspberry pi 3).

I modified my Dx6e to have :

  • Channel 1 : Roll
    -Channel 2 : Pitch
  • Chanel 3 : Throttle
    -Channel 4 : Yaw

I have got an AR7700 which is a PPM receiver.

On boot, the led switch between blue and red only for a few seconds and motors make 1 beep, enven if throttle is high. Reboot doesn’t change anything.

Is this the good PPM channel layout ? Am i missing anything ?

Best regards,

Hi,

Did you connect to MissionPlanner? What does it say, any warnings?

Hi.
No i haven’t. What’s the best way to do it.

I noticed that most of the startuplog file is not readable. Is this a baud problem ?

https://docs.emlid.com/navio2/Navio-APM/installation-and-running/

The above link gives a good overview of how to connect up to Navio using Mission Planner, which can be found on the download link below:

http://ardupilot.org/planner/docs/common-install-mission-planner.html

Easiest way to connect is by doing the following:

sudo nano /etc/rc.local (this edits the rc.local file)

Add the following command to the rc.local file:

sudo nohup ArduCopter-quad -A udp:192.168.1.2:14550 -C /dev/ttyAMA0 > /home/pi/startup_log &

But change the IP address to the IP address of the computer you’re using to connect to the RPi. This will enable connection from a GCS, using UDP and the UART port when using a 433 Link etc.

Then open up Mission Planner, using the connection options, select UDP and connect.

If using a 433 link, select the Com port you have configured, and 57600 Baud.

Hi! I managed to do esc calibration, accelerometer calibration and radio calibration.

How ever i can’t do the compass calibration.

As i’m using linus mint 17, i can use the APM 2.0.18, next version require a lot of package update that mite breack the system.

From the console i can see that it gets 1 or 0 value each time. The APM don’t say that there’s no compass, the compenent shoul work.

i used mono and missionplanner with linux;
missionplanner calibration should work for compass (with on board calibration)!

Hi,

I tried with some android app and every time the compass calibration end with a message “not enough data”. Is there a way to calibrate the compass without the apmplanner ? I managed to do all other calibration (radio and accelerometer).

What is the best method to calibrate the compass (i have seen a lot of different method on youtube but i can’t get enough data)? What is the magnetometer i2c address ?

Hi,

I’m about to give up. I tried with 3 mission planner (android, linux, and windows) and the live calibration just doesn’t work. I have got a message : “Not enough data points to calibrate the compass”

I have noticed that i don’t get the image with the axes in the video : https://www.youtube.com/watch?v=CQjnwVFXhG0

Here is my i2cdetect log :

sudo i2cdetect -y 1
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – -- – -- – -- – -- – -- – -- –
10: – -- – -- – -- – -- – -- – -- – -- – --
20: – -- – -- – -- – -- – -- – -- – -- – --
30: – -- – -- – -- – -- – -- – -- – -- – --
40: 40 – -- – -- – -- – 48 – -- – -- – -- –
50: 50 – -- – -- – -- – -- – -- – -- – -- –
60: – -- – -- – -- – -- – -- – -- – -- – --
70: – -- – -- – -- – 77

Hi,

When you say Misson Planner, you are talking about the particular software, not GCS in general, correct?

Hi,

I used the apm planner 2.0.24 xenial 64, apm planner 2.0.24 win : http://firmware.eu.ardupilot.org/Tools/APMPlanner/. ON android an app called Tower (but there’s not live compass calibration).

Can you please try Mission Planner?

Hi,

I got those error code on the live calibration window :

compass 1 error
compass 2 error
compass 3 error.

The planner doesn’t get any data point… I think that the compass is dead…

What can i do now ?

I put 0 in the arming check (in the advanced param list). I configured the Alt hold accro and stailize modes…

But i think that get a +160€ flight controller that runs on a cortex A processor and be stuck with accro and stabilize is just so dissapointing… An atmega 328p could have do the job :neutral_face:

at the moment you should only use missionplanner and Onboard Mag Calibration for mag calibration!!
(as described in the docs https://docs.emlid.com/navio2/Navio-APM/ardupilot-tips/#onboard-calibraton )

Hi,
I have got a navio +.
And there’s in the navio + doc :

Further configuration

As other APM configuration procedures are very similar for most APM-running autopilot hardware, please use the APM documentation.

Thanks. I’ll take a look in the navio 2 doc to see if i can calibrate the compass with this method.

i didnt notice you’ve got a Navio+ - the statement for navio+ was correct and should be correct in the future again; i believe it’s just a software issue for current releases;
but yeah - it’s kinda misleading at the moment;
report if you’re succesful

I think that the compass is dead. I have sometimes bad compass health message. And when i clicked on start nothing happened.

Do i have to set pixhawk as type of board ?

Is it possible to fly without compass ?

possibly; do you have anything else connected to i2c?

here is a pic of what it looks like (thx @simonpmg)
https://community.emlid.com/uploads/default/original/2X/1/18f8d70ea925a9550dc6bd72cca2737e2707e296.jpg
MAG_CAL_SUCCESS only shows up when finished; before that there is no popup just a “id:” and several % numbers in the window in the lower right;

yes it’s possible; you can look up the flight modes which rely on compass on ardupilot’s hp! (eg stabilize doesn’t use compass)

No i don’t have any devices connected to i2c.

There’s no id or no % number. And on the first screen of the software i have a “bad compass health” message.

I’ll try the stabilize, althold and accro mode. So, i have an apm that can’t do apm :(!

What external compass breackout board are compatible with the navio + ?

are you using the beta image?
have you tried the other image as well to rule out any beta image with navio+ issues? ( i am not very familiar with the new beta image)

hmc5983 is a good choice!

I don’t think that i’m using a beta image. I’ll check.

For a quad X, on which pin do i have to connect front right, front lef right back and keft back motor for the navio + ?