ESC Calibration issue

I’m a newbie to this hobby. i’ve done the calibration of the ESC individually. The problem is even after calibrating the motors won’t spin till the throttle stick is half way through.

Transmitter: FlySky TH9X with FSR9B receiver
ESC; 20 A Flyline

Pay attention at the flight mode selected when you move your throttle stick. If in Stabilise flight mode, progression is following stick movement. If in Altitude hold mode (or loiter mode), power is increasing when throttle stick reach the middle.

You may have to increase MOT_SPIN_ARM and MOT_SPIN_MIN if your motor is not running after arming.

@mlebret thanx for the reply

But, i’ve not connected it to any FC. Just after calibrating when i check the response of the motors then itself it’s behaving like this(spin when the throttle is half way through)

Hi @deadlysaint,

Welcome to our community forum!

Can you post the pictures of your hardware setup? With them, it will be easier to check what is going wrong in that particular case.

It could be a bad FlySky TH9X transmitter setting with custom throttle mix (like for a copter?) instead of a clean new plane configuration.

i checked again…created a new model but no use…same result

if you are running the ESc straight of your receiver and having this problem, then it is likely to be an issue with power supply & setting mismatch.
What type of battery are you using and how many cells? What is your ESC set for ?
Could be your ESC is set for 4 cells but if you only have 2 cell battery connected that could cause a problem. In theory most ESC’s should recognize how many cells are connected, but if you have changed the settings of the ESC this may no longer be the case. Also many quality ESC’s will briefly beep multiple times when power is connected to confirm how many cells it has discovered.
I.e. 3 beeps for a 3 cell battery ,…providing you have correct cell type set.
…You could have yours set to LiPo yet are using NiMh battery back or vice versa.

@anon31534460 thanx for the reply!! check this video which i’ve uploaded showing the behavior of ESC while calibrating and the cell used is Li-Po 3 cell battery… and how can i change the setting now?

just had a look at your video. Did you buy those motors independently or was it part of a kit?
In my opinion a 840kV motor are more suited to 4S or higher battery. 3S hasn’t got enough voltage to start at low revs. Hence your problem with throttle control.
Just do a quick test: Connect everything and move throttle slightly up, but not as far that motor would start running - just stay slightly below that throttle stick setting. Then try to spin motor by hand and see if it starts running. If that is the case then clearly you’ve got the wrong motors or you have to go for a 4s or 5s battery.

@kschoelpple i bought those motors independently and i tried what you suggested, i didn’t spin when i tried to spin motor by hand and how to change the setting which you talked about in your previous reply?

There are many different ESC out there offering different functions and settings.
You need to find the specific instructions for yours - usually this can be downloaded from manufactures website.
I have one example attached but do not use on yours as it can be completely different and cause more problems if incorrectly set

…Just remembered: Some ESC require throttle range to be set. This might be the problem you are having.
In above instructions check the middle section out in regards to “Throttle Range Setting” .
With a bit of luck this will work on your ESC. If not then you definitional need to find and download correct instructions for yours.

Here is a different one.
As you can see completely different settings - Hence you need to find correct instructions for yours
.ESC 2

1 Like

thanx alot @anon31534460 tried finding this sheet for my ESC 20A but went in vain…but thanx alot!

Have you tried the instructions on the first set of instructions I’ve posted?
This appears to be a rather common way of setting throttle settings.
–> Turn RC transmitter on, move throttle to full, connect ESC and receiver to battery / power supply and turn on. Within a few seconds you should get a beeping signal indicating ESC has recorded max throttle values. Then move throttle down and once again ESC/motor should beep. Then disconnect everything and ESC should now be calibrated.

i did @anon31534460 previously i’ve also attached the video in my previous reply too

Sorry, you’re right. It’s been a few weeks and forgot about that video.
Have to agree, everything in the video suggests the ESC calibration is carried out as expected. - The only thing I can’t see in the video is if you disconnected the power after calibration? This is sometimes required to actually save the settings.
-In regards to your ESC’s I did have a brief look after my first reply and couldn’t find any information. It appears a importer / wholesaler got those made under own name and imported to your country. You will most likely find that it is just a standard ESC like found on Hence instructions from such a place might work with yours.

  • Another thing could be something weird going on with the transmitter as Marc has mentioned. Not sure what flight controller you are using, but when connecting to Mission Planner you should be able to check RC throttle input under the setup tab. This might give some more indication if the transmitter is to blame or in fact the ESC’s.

thanx alot for the relpy!! @anon31534460 I did try it by disconnecting the power after calibrating, but didn’t work either. And as you mentioned at the end I’m using Pixhawk 4 and I’ve also attached !the screenshot of the radio calibration from the mission planner

and also from QGround Control, as you can see I’ve marked in the screenshot that’s when the throttle stick is at the bottom.

And one weird thing is that even though it is a 8 Channel Receiver but when I toggle the switches it back and forth it doesn’t register those values, but sometimes channel 5 works , i don’t know what it is.

Throttle values appear to be as expected.
In regards to other channels not showing up / registering it might have something to do how your receiver is connected to FC. I’ve got no experience with Pixhawk but on some others you had the option of connecting just a single data / comms cable or connecting all channels with a cable each to the FC. There are some receivers where the single cable setup can be more difficult to get right on the FC side in regards to settings and how it communicates between Receiver and FC.
In regards to your original problem I think the ESC’s are to blame. As you can’t find any instructions for it or other specs for that matter (I also had a brief look without success), it may be those been made for a specific application but perhaps not for general use. If that is the case you won’t be able to get expected result / control from them.
All that is left to do is to borrow a different ESC from a friend or connect your receiver to a friend’s ESC and check throttle response with that. If my suspicion is correct you will find a different ESC works fine.

PS: Sorry about late response. For some reason didn’t get a notification sent to me.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.