ESC Calibration in Mission Planner - Raising throttle to high causes crash of Raspberry Pi2 with Navio2

Hello everyone,

I am having an issue where I am trying to calibrate my ESC’s through APM on my new Navio2, I am doing the following.

  1. Run Arducopter to connect to APM
  2. Arducopter connected to Mission Planner
  3. Navigate to ESC Calibration under “Mandatory Hardware” in “Initial Setup” on Mission Planner
  4. Make sure power to ESC is disconnected (currently have power using power module).
  5. ESC connectors are set to servo headers 1,2,3,4. Only one ESC connector provides power, the other three only signal.
  6. Radio throttle is set to high (1700) - I am using the Joystick for this as I don’t have a radio.
  7. Click ready button to run ESC calibration
  8. Connect power to ESC

At this point the raspberry PI crashes, there is nothing in the logs and it reboots itself.

I am running a 4S 5800mah 25c LiPo and the ESC module I am using is the Q-Brain 25a

Any help would be appreciated, I can’t do anything with it at the moment :frowning:

PWM of 1700 is not high.
Should be above 1900 maybe 2000

I have tried with 1900, 2000. And besides it shouldn’t crash the raspberry Pi2 at all no matter what RC3_MAX setting is.

Hi Craig,

This looks like a joystick specific issue, but the behaviour is still strange. We will have a look into this when devs are back to work ( We are on a public holiday until March 9th).

Brilliant, if theres anything I can do to make it easier for the devs just say, if you need any logs I can send them over, do you have a list of commands I can run to setup logging as the syslog shows nothing out of the ordinary.

I have a feeling that it could be a power spike that’s causing the hard reboot.

Could it be a power issue if there is nothing in the logs and the PI reboots ?

I believe so, strange thing is that its only on ESC calibration, ill reinstall the Navio2 image and APM deb to see if its a software misconfiguration.

We were not able to reproduce the issue. Have you completely powered off the flight controller when performing ESC calibration?

Are you talking about the Raspberry PI2, ArduCopter or something else? I’m unsure what you mean by Flight Controller.

When you are calibrating ESCs through the Mission Planner you are supposed to turn off everything (Raspberry,Navio), not just the ESCs.

Ah I wasn’t aware of that.

If I use these updated steps would this align with your own steps? and if not can you tell me what they should be?

  1. Power off Raspberry Pi/Navio2
  2. Power on Raspberry Pi/Navio2
  3. Run ArduCopter command
  4. Connect to Mission Planner
  5. Click ESC Calibration Button in Mission Planner
  6. Power off Raspberry Pi/Navio2
  7. Power on Raspberry Pi/Navio2
  8. Power off ESC’s
  9. Close Mission Planner and re-open Mission Planner
  10. Enable Joystick to control throttle in Mission Planner
  11. Run ArduCopter command
  12. Raise throttle to high for Joystick
  13. Connect to Mission Planner
  14. Power on ESC

Is it supposed to calibrate the ESC’s after these steps?

Thanks for the help!

Just a follow up, can anyone outline the steps they took to calibrate via Mission Planner? Still have not been able to do it, if I could see someone’s steps I can figure out where I am going wrong

If it helps I am using the PS3 Sixaxis via bluetooth.

To calibrate the ESCs you will need an RC receiver with SBUS or PPM. As far as I understand, you can not calibrate using Joystick.

Actually I was able to Calibrate it finally!

I didn’t realize that I had to kill the ArduPilot process and run it again after clicking on the ESC Calibration button in Mission Planner, I thought I had to restart the Raspberry PI, seems like I just had to kill the ArduPilot process. Upon doing this I was able to Calibrate it using the below steps.

My list of steps are as follows;

  1. Setup Joystick in Mission Planner
  2. Calibrate Radio (Joystick) in Mission Planner
  3. Run ArduCopter command
  4. Connect to ArduCopter using Mission Planner
  5. Click ESC Calibration Button in Mission Planner (this sets ArduCopter in Calibration mode on next run)
  6. Kill ArduCopter command
  7. Set Joystick throttle to max throttle
  8. Run ArduCopter command again (this starts in ESC Calibration mode because of step 5)
  9. Connect power to ESC & Motors
  10. Wait for 2 Beeps to confirm ESC Calibration mode
  11. Lower throttle to min throttle
  12. Wait for 1 Beep to confirm ESC Calibration settings
  13. Motors will start spinning and ESC & Motors now respond to Joystick throttle!!

So it does work, the difficulty was that I had no idea I only had to restart ArduPilot and not the entire Raspberry PI which is what confused me, the terminology used (Flight Controller meant the actual hardware itself and not ArduPilot) wasn’t very clear.

Could we get this up on the Docs perhaps to make it more clear?


1 Like


I already test Joysticks, work fine in Pos-hold flight mode, but in Stabilize take care, the problem is the latency.

very good steep by steep.

What is your setup for Joysticks if you dont mind me asking?

No problem, I did these tests more than one year ago …I don’t remember the parameters, but I follow this article and change small things.

I was using a Logitech joystick…after the first crash in stabilize mode I stopped.

For planes very good idea…but for quadcopters if you have to send fast commands and the commands arrive with delay…. Bye bye…… Ground……

In my case I was using a 4G modem, maybe slow connection for this, I really don’t know…

But please, thy and give us a feedback.

Look the comments at the end of this Article:

1 Like

Hi Craig,

I tried to calibrate the ESCs step by step by your instructions using joystick. But it did not work for me, because when I do Kill ArduCopter commands (step 5), the connection to the GCS is lost, and therefore I can not Set Joystick throttle to max (step 6). I clicked on the link Cannot calibrate ESC and connect to GCS simultaneously, but I did not find a solution there because in that case I don’t use the RC

I appreciate all the help I can get.

And in step 5 is this button need click?“Click ESC Calibration Button in Mission Planner”