Cannot calibrate ESC and connect to GCS simultaneously

To start up my quad, I tried to do steps as below.
(According to ESC Calibration in Mission Planner - Raising throttle to high causes crash of Raspberry Pi2 with Navio2)

  1. Click connection Button in Mission Planner
  2. Run ArduCopter command
  3. Connect to ArduCopter using Mission Planner through wifi
  4. Click ESC Calibration Button in Mission Planner
  5. Kill ArduCopter command
  6. Set throttle to max throttle
  7. Click connection Button in Mission Planner
  8. Run ArduCopter command again
  9. Connect power to ESC & Motors
  10. Lower throttle to min throttle

With this steps, I cannot calibrate ESCs.
Skipping step 7, motors start spinning ,but connection between Mission Planner and navio disabled. And when reconnect, ESC calibration will be disabled.
What is correct steps?

I appreciate all the help I can get.

Hi!
You can try this algorithm of calibration ESC:

  1. Turn on your transmitter and put the throttle stick at maximum.
  2. Connect the Lipo battery. The autopilot’s red, blue and yellow LEDs will light up in a cyclical pattern. This means the it’s ready to go into ESC calibration mode the next time you plug it in.
  3. With the transmitter throttle stick still high, disconnect and reconnect the battery.
  4. The autopilot is now in ESC calibration mode.
  5. Wait for your ESCs to emit the musical tone.
  6. Pull the transmitter’s throttle stick down to its minimum position.
  7. The ESCs should then emit a long tone indicating that the minimum throttle has been captured and the calibration is complete.
  8. If the long tone indicating successful calibration was heard, the ESCs are “live” now and if you raise the throttle a bit they should spin. Test that the motors spin by raising the throttle a bit and then lowering it again.
  9. Set the throttle to minimum and disconnect the battery to exit ESC-calibration mode.
    You may read more here and you should read user guide for your ESC.

Thank you for your response.

I can calibrate ESCs by your way.
Thanks a lot!