Emlid with a Autel Evo RTK UAV

Ok, that’s good you were able to update. The only thing I see peculiar is on a rectangular mission after completing the last leg, it turns on a diagonal line to the center home point and starts taking oblique pictures as it heads back to land. Also it take a nadair photo at the end of leg and as it heads to the next leg one photo in between, but it is at 90 degrees to all of the rest of the photos. I’m using 80/80 front/side overlap settings. So far the software has been able to handle the 90 degree photo.

That is a setting in the mission app. I think it is called “elevation optimization” or something to that effect. It is supposed to help software remove any “bowling” effect in the image set. You can select On or Off. It is on by default, I think. The DJI P4PRTK has the same option.

1 Like

Ok, thank you for the tip, I’ll check it out and see if it helps.

I tried it once and DroneDeploy didn’t like it so I just turn it off.

1 Like

Mark, I’m so grateful for the testing you did and for the thorough replies you wrote this weekend. Wonderful! My work partner and I will try setting up the phone as a hotspot and, as you stressed, try to make all 3 devices be on the same network. If I set the phone as the hotspot, cell turned off, what address and port info do I enter into the evo RTK settings: the hotspot data or the local NTRIP data from the emlid? How do I make the emlid connect thru the hotspot or vice versa?

Ken, your welcome, but really kudos go out to Dave and Michael for their great advice on this matter, much more than me. Ok, let me try and walk you through the process. This assumes that you are using your Ipad as your hotspot Wi-Fi connection and your phone as the EVO controller on the same Wi=Fi network.

  1. Turn on your hotspot on your Ipad.
  2. Next turn on your RS2+ Base and it should see and connect to the Ipad’s hotspot, since I assume you have already connected to it at least once already. You should see a steady blue light on the left Wi-FI status indicator that tells you that the Emlid is connected to the Wi-Fi network.
  3. Startup Reach 3 and you should see your RS2+ listed, tap on that and then go to Base Settings Tab and select Configure. Select Average Single and average for 2 minutes. Once done averaging, write down the position for later use if you return to the site. Note that this will be just an relative position and not a absolute or known position.
  4. Now go to the Base Output tab and select Local NTRIP. Click on the “i” Info icon and note all of the settings. This info including IP Address, Port, Username, Password and Mountpoint will be used in the Autel RTK setup screen.
  5. Go to your Autel app on your phone and start it up, making sure your phone is connected to the same network as the hotspot.
  6. Turn on your drone.
  7. Select RTK setup and enter the info from Emlid’s Local NTRIP tab.
    8, Hit connect and you should see Connection Successful.
  8. Setup your Mission and then fly away.
    You will want to enable auto logging on the Emlid in case you want to use PPK methods to later adjust your positions.
    I think you also mention that you would like to share the screen with another device. I don’t believe that is possible unless you get the Smart Controller with the built in HDMI port. Autel does or did make an LiveDeck Stream Anywhere device that I think would do what you want. Though not a 100% sure about that.

LiveDeck: Stream Anywhere

Stream live video feed directly from the EVO II Pro to any monitor with Live Deck, which supports HDMI, Ethernet, and USB output.

Please look at Dave’s advice at Message #29, and the Emlid’s info located at:

and I believe that will help you get set up. (I later edited some of details because I was at first thinking about how I connect with my different Smart Controller vs your standard controller.) Hopefully I haven’t left anything out, but maybe Dave or Michael will let us know.
Also want to add that each time you shut down to change batteries on a extended mission, you will have to reconnect the RTK connection on the EVO app.

Mark, Thank you so much for the procedure; we’ll test it shortly and reply back with any minor diff in the procedure. We have have several ios devices, inc multiple iphones and a portable hotspot, available, at least for the short term to make this work. We’ll try: the emlid, with reach app on a phone, with the cell turned off, the evo controller, w/ a non cell [wifi only] ipad, and a cell phone or portable hot spot controlling the evo explorer app.

1 Like

With the help of you fellows, we were able to to get our emlid to connect with our evo for RTK. Evo message went from float to fix in a few seconds and we were enabled to fly. I’ll post the procedure; apparently, we didn’t need to a dedicated ios hotspot. We used an ipad to control the evo, connected to the emlid and a phone, with the cell turned off, connected to the emlid. I’m not sure how it worked after we tried that before you advised us.


Good deal, sounds like you connected directly to the Emlid’s Wi-Fi Hotspot, like Dave outlined in message # 29 and also others have on the forum in previous messages. Glad you got it working for yourself.

Sketchy data and 3-4 cm residuals vs. setting a hard point, occupying and get 1-2cm… Seems about right.

Continuing connection problem. When we connect the emlid local ntrip to the evo, as stated in the above comment the evo explorer app indicated coords and elevation from the aircraft; I thought this was a red flag, but processed in emlid studio and Pix4D. The resulting contours were off 2.5’ vertical; this is approx the same amount of error from just flying the RTK evo without any correction. This makes me suspect that the evo was not getting the correction from the emlid ntrip, which was set up on a known monument in manual base mode. Can someone tell me how can we confirm that the evo is getting the ntrip correction? Has anyone seen a message in the evo app indicating correction from the emlid instead of the evo? This is a good time for somebody to remind me that we didn’t follow the suggested procedure of connecting the emlid and evo to a 3rd hotspot; we just connected the evo to the emlid hotspot.

Consistently 2.5ft? Normally you wouldn’t be able to takeoff if you don’t have a fix, although if you are already in flight it can drop and keep going.

Smart Controller > Verizon Router > RS2+

It may not work over a phones hotspot if there’s no/sketchy data.

How can I confirm that the evo is receiving the emlid RTK correction if the evo is connected and can take off?

I suppose it should have a Fix status in the Autel software? Something like here:

SN, thank you for posting that pic. That’s exactly what we’re seeing: a fix to the aircraft. Should we not see a fix to the emlid? Does the fix statement mean only the emlid is providing that accuracy of data?

Ken, you won’t see a fix from the Base, unless you are tied in to a NTRIP correction service.
The Autel Rover/Controller is reporting a fix because it is receiving corrections from your Emlid Base.
Emlid = Base, Autel = Rover. So if Autel is reporting a fix then you are good to go.

Agree with Mark. Base shouldn’t report a fix as it doesn’t receive any corrections. So, you can start a flight as soon as you see a Fix on your drone.

The base could be reporting a Fix if incoming and outgoing corrections are both on? Basically I never HAVE TO touch the settings whether I am shooting or casting unless I plan on flying the drone with RTKNET. In that case I turn off incoming.

Yes, of course. If a base is connected to an NTRIP service or another base. I didn’t mention it as it seems not to be Ken’s setup.

We’ve yet to try to connect to the NTRIP service, since, doing projects in remote areas of Nevada, we don’t expect to be able to get cell or ntrip service. I think that this field trial confirms that we were getting a local ntrip connection after set up the evo rtk

1 Like