Emlid Studio stuck on opening

hi,
when trying to open Emlid Studio, it stay stuck on the intro image, waited for many minutes, and it stay there until closing on task manager.

I uninstalled, reinstalled, diferent versions, and nothing, ver 1.7, 1.6, 1.4
also registry cleaned, remove all emlid studio data user folders, restart, install again, same…

it is happening on a new laptop I am migrating, here the specs:

Windows 11 Pro for workstations, ver 23H2
CPU: AMD Ryzen 9 7845HX with Radeon Graphics
RAM: 32.0 GB DDR5
GPU: gforce RTK 4070

2 Likes

I experienced the same thing with my laptop, then I try to run using NVIDIA GPU in graphics setting, check my screenshoot

2 Likes

Hi Roger,

We’re investigating this behavior with our development team. I’ll let you know once I have any updates.

1 Like

I experienced the same problem. In my case I could solve it by connecting to my work network, either physically or via VPN.
It seems Emlid Studio hangs when certain network drives are mapped but not available?
The installer suffers from the same issue (see Emlid Studio installer hangs).

2 Likes

Thank you for sharing this information! We’re still investigating this case and looking at what can cause this.

1 Like

Hi, any solution yet?

@4lo.ort4,

We’re still investigating this issue under different conditions. So far, we’re unable to recreate it, and Studio installed successfully from our side. I’ll notify you as soon as we have any updates.

Is there still no solution here? This has been going on for a while. I just tried to install on an AMD Alienware machine and it is stuck at the splash screen. I am guessing it has to do with it being AMD versus Intel. I have seen similar behavior in other geospatial software. I am going to try to see if the same workarounds for those other applications work for this one.

UPDATE: OK, after pointing Emlid Studio to the dedicated (versus integrated) NVIDEO graphics card, it opened immediately.

3 Likes

Thank you for the information on what helped you! We’re still looking into the possible reason, and I’ve passed your solution to our development team to try to replicate.

Hi @ridho and @Zaz5400,

Thank you for finding a workaround for the integrated vs dedicated graphics card issue and posting it to this thread! I believe it would be of a great help for other people while we are digging into the root of this problem.

It would really help if you could run Emlid Studio once again with an integrated card under Git Bash. There is a chance that some graphics-related logs/errors have missed the log files we’ve received, but will be visible in the application console output on your laptop.

Here is how you would do this:

  1. Set the integrated card for Emlid Studio once again in Windows Settings.
  2. Download and install Git for Windows.
  3. Open the Git Bash application using the Windows Search:
    image
  4. Open the location of Emlid Studio in Explorer – it should reside at C:\Program Files\Emlid Studio.
  5. Drag and drop the Emlid Studio application executable from Explorer to opened Git Bash. It should appear like this '/c/Program Files/Emlid Studio/Emlid Studio.exe'.
  6. Press ‘Enter’ to run the application.
  7. Once the application hangs, copy the text from the Git Bash (select the text → Right mouse button → Copy) – it should look like this (this is an output of the successful startup though):
    image
  8. Open Notepad or any other text editor, paste the text and save as a text file.
  9. Attach the file in this thread or send me in DM.
1 Like


Stuck when using integrated gpu

I see, thanks for your help!

Hi everyone,

I just wanted to update you that during our investigation, we weren’t able to reproduce the issue with our development team. We believe that changing the Graphics preference can be the solution in such cases. @4lo.ort4, @roger.itrans, @maarten.vergauwen please check if the changing graphics help you as @ridho suggested.

If there’s still an issue after the settings charge, please let us know!

Hello,

I encountered a similar issue, but thanks to your comments, I was able to resolve it successfully. By adding Emlid Studio to the ‘Manage 3D settings’ and selecting the High-Performance NVIDIA processor option, the program successfully ran on my laptop for the first time.

Below, I have attached a screenshot for your reference. I hope this solution works for you as well.

Best regards.

2 Likes

Hi @civilsurveyusa,

Welcome to the forum! Thank you for sharing that this solution worked for you; it can be helpful for other users.