Emlid Reach RS does not turn on/ not charging

Hello Community,

I have a Emlid reach RS that has been left unused for about a year, when I try to turn the rover on, there is no indication of power. Tried various method including holding it for 10 seconds, charging via usb. There is no sign of being online.

Any suggestion would be much appreciated. Thank you

Let it charge for a day


Hi @covingtonkua,

Welcome to our community!

I’d double Dave’s suggestion. Please charge the unit overnight with a different USB cable and power source, and check for any LED reactions after pressing the power button.


I just got one used and untested, and I think it’s the same issue the OP has. It does receive power through USB but only 0.02 amps. The orange LED is blinking in a pattern where it dips to off for a short time every 1 second.

I may try putting in a new LiFePO4 battery but I can’t find any info on the pinout. There’s a Youtube video showing how to replace the battery but now how to connect the wires. I would just use a smaller LiFePO4 single cell vs 3 cells in parallel, just to make it easier to fit

same problem, did you solved?

youtube link video battery?

1 Like

Try charging overnight again. Probably a few things u can try before replacing the cells. Don’t over voltage! (Must be 3.2V NOT 3.7V!) Try Google 26650 3200mah 3.2v.

Again… :wink: try @ceith too.

PS. I have 2 of the original Reach RS (Edison chips) also. I zero them on chargers ever since i had them… no battery issues at all to this day.

1 Like

for flashing? because no wifi , and led is on loading

pc win 10 not work + edison driver
mac os 13.1 not work.

Trying to use USB driver with Edison chip via Windows to reflash is a whole nether problem to get over. You can search here for that. :roll_eyes:

If there is no power or juice you won’t be able to reflash.

You really need to put on a charger for a good solid day 1st to see if u can get any power. If u get power, u could prob try to reflash fir whatever reason… but u have a power issue 1st.

I know youtube has videos how to wake or recover so-called dead battery cells as used in cordless tools etc that may also help. Basically JUMP STARTING them. Use at your own risk!


edison usb driver give errors and i think is not istalled, there is a sure mode ?

win 7 ? …

Again, you will have to search here and read up. It was quite a hassle at the time but eventually worked using Windows 10.

Again, if no power, you wont be able to flash and also brick it permanently. You need to fix the power issue first.


I was thinking about your words, the battery is similar a condesator, as the fuse break the circuit. only emlid cabel 6V… but is based on serial, and usb is not serial (need a TTL converter).
I understand there is a check in emlid but the next problem… warra
But you think it will work after battery pack upcycle?
Loading led wil be fixed?
now no connection wifi or bluethooth…

Hi guys,
We don’t recommend opening units for repairs. There might be different reasons for this behavior of Reach and a battery replacement may not solve the issue. Aside from that, opening a unit can affect its water protection, and the GNSS antenna can be misplaced, which can reduce the accuracy of the receiver. It’s best to handle each unit independently, and we are here to help you. My colleague, @olesia.riman, is currently in touch with Marco via email, and I advise anyone who has a Reach with similar symptoms to write to support@emlid.com.

is not a support from @olesia.riman is an accomodation on buy a new product because we not have warrancy for cunsumer… i think the best things is warrancy lifetime, hand made suggestion by forum comunity… we do not do reverce engenieering…

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.