Emlid M2 as primary GPS (RTK) for pixhawk

Hi,
I try to find best settings for emlid M2 to do RTK integration to pixhawk autopilot

hardware setup
-pixhawk cube orange running AC 4.1
-HERE 3 GPS as secondary
-emlid M2 as primary GPS (fw 27) connected to base RS2 with emlid LoRa

I already try with ERB and NMEA protocol, get RTK FIXED status at mission planner, but sometimes (1 of 5 flights) I get bad gps health message then copter doing toilets bowl movement when loiter.

can anyone suggest what setting that I need to change to get stable GPS with emlid M2?
thank you.

Hi @fajarsptian,

Do you change anything in the Reach settings when this message appears? If Mission Planner shows the Bad GPS Signal Health message, it’s essential to check that the GNSS update rate on Reach is 5 Hz or higher.

Hi,
yes I already changed rate to 5Hz and problems sometimes appear, trying with 10Hz too but still same

Hi @fajarsptian,

What is the Solution status on Reach when you get the Bad GPS Signal Health message? It may happen when Reach isn’t provided with a non-obstructed sky view which causes the signal to be not of good quality. For example, if you fly near tall buildings.

Hi @liudmila.slepova
emlid stats are same as displayed at mission planner, its RTK fixed
I do test flight at remote area, so there is minimum interference

but I already find solutions, change baudrate to faster speed, now almost 2 days the problem seems gone

Hi @fajarsptian,

That’s good news :slightly_smiling_face:

What baud rate did you choose? It’s just important to me to understand what configuration helped you with the issue.

I set emlid M2 output to ERB with 57600 baudrate
GNSS set to 5Hz
I think this is best setting I’ve get for now
thanks

Hi @fajarsptian,

Got it. Thanks for sharing your observations!

I’m going to look into this. Probably, we need to add that baud rate in our guide to avoid similar issues in the future.

hi @liudmila.slepova
you’re very welcome

l tested this settings for 2 weeks, and everythings just fine and working good, no problem anymore.

I’m flying at terrace area, and maybe extreme environment, flying low to the ground, good things RTK still connected from 1.5km distance


thanks for team emlid support

5 Likes

Hi @fajarsptian,

Thanks for the updates! I’m a bit scared about the extreme environments, though :sweat_smile: Reach M2 can handle a lot but everything has its limits :slight_smile:

Be sure to post more beautiful photos like this one :heart_eyes:

1 Like

I was not at all help to get RTK work with my Reach M2 after very long chat.

But atleast here one user got solution from himself not with technical support from emlid .

As a manufacturer emlid itself couldn’t provide proper solution to work around and get better result.

I just followed emlid and ardupilot forum and also there manuals and documents to get it work but still no luck…emlid said set NMEA protocol at some baudrate( I forgot the baudrate which I was set),but now from user point they concluded that RTK work with ERB protocol at 57600baudrate.

Please provide a valid document or support to your user to work .please conclude here atleast at what setting Reach M2 RTK works. I have searched emlid forum regarding this but 90% nobudy succeeded.

Hi @fajarsptian can you share your Pixhawk parameter file which Reach M2 getting working perfectly …so I will thankful to you I was struggling like anything to get it work.

hi @Kalai_Selvan
sorry I can’t provide param file, but here the settings

emlid M2 as rover and primary GPS of pixhawk:
-rtk setting, rate 5Hz, uncheck QZSS
-input, lora 920mhz
-output, UART, ERB protocol, 57600 baudrate
-base mode, off

pixhawk (cube orange, arducopter 4.1):
-I use emlid UART go to GPS2 port (serial4)
-GPS_AUTO_SWITCH = 4
-GPS_PRIMARY = set to emlid M2 (gps 1 or 2 depend on your settings)
-GPS_TYPE = auto

-SERIAL4_PROTOCOL = 5
-SERIAL4_BAUD = 57

2 Likes

Thank you for sharing your configuration…I will let try and give the feedback.

you’re welcome…
don’t forget to build ground plane for emlid M2 antenna for better performance when do RTK navigation flying

Thank you for your suggestions.ground plane material wouod be conductive material?

yes right,
for best build you can use blank PCB plate, but I already try use plywood covered by aluminum sheet it’s still work perfectly than not using ground plane…
size 7x7cm enough for that

1 Like

Little worry about here that emlid document itself suggested that don’t use Emlid gps as primary gps. Then how confident your using it .

yes docs says that.

but I need centimeters accuracy flying, as you can see at picture above, I developed precision spraying. I can’t achieve that with here3 GPS (already try that)
then I use emlid M2 as my primary GPS. connected to RS2 for RTK.
for now, more than hundreds flight I use this configuration

I just followed your setting but still I’m no luck.

Where I’m mission something…the correction I’m not send ing through lora radio…using the UAV radio itself so base correction inject to mission planner as follows.