Emlid lora radio not connected

Hi, i have problem with Lora radio connection with M2 and RS2.May i know the LED indicator in LoRa Radio. When the LED at Rx Tx blink and when connected what LED turns Out.

Plus, my LoRa radio can’t connected with M2 and RS2 it appeared Not connect in Emlid Flow. here is the attachment of simple report and full report https://drive.google.com/drive/folders/1nB4jhifUz47qb4ViXHWitiZD0yDjZtBT

Hi Fathan,

Welcome to our community!

Thank you for sharing the files. Could you please give me access to them? I have sent you a request about that.

Do you have another LoRa cable to connect the radio to M2? If yes, please try to use that to check whether the issue is related to it.

Besides, could you please send us a photo of your setup and a screenshot of the Correction input page in Emlid Flow?

1 Like

I already used original cable but the led won’t appear… it’s appear only early when power up the lora radio

Hi, I’m afiq. I’m one of Fathan’s team members.

so this is our correction input page in emlid flow.




Hi @fathan2620 and @afiqdaniel1803,

Thank you for the screenshots. As I see, you’ve configured the connection via local NTRIP. You don’t need LoRa to work with it. However, your base and rover should be in the same network. With the Reach hotspot, the available range will be just several meters. That’s why such a feature is usually used for integration with RTK drones only.

To pass the corrections via NTRIP on longer baselines, you can use the free Emlid Caster. However, you’ll need a stable internet connection on both the base and the rover for it. Here is a guide about how to use it.

If you want to use LoRa radio, let’s switch to it for correction input on the Reach M2 and base output on Reach RS2 in Emlid Flow. I found our old test of a similar setup, and I see that the correction streaming was fine, even though both RX and TX LEDs were off. So, let’s just configure the LoRa first and see how it goes. If it doesn’t help, I’ll need one more screenshot from the Correction input tab from your Reach M2, a photo of your setup, and the full system report from the receiver.

2 Likes

Here is the screenshot from Emlid Flow for the M2(rover) and RS2+(Base) as well as my setup




.

Here is the report for the base

Blockquote

Simple system report

app version: 31.8-r0
current_network:
ip: 192.168.42.1
security: wpa
ssid: RajaRondaReachBase:6C:61
enabled: true
mode: hotspot
base_mode:
base_coordinates:
accumulation: 60
antenna_offset: 1.134
coordinates:
height: 10.561004201680671
latitude: 1.8575665857899157
longitude: 103.08904024158826
mode: single-and-hold
output:
io_type: lora
settings:
lora:
air_rate: 9.11
frequency: 922700
output_power: 20
ntripcaster:
mount_point: REACH
password: ‘
port: 2101
username: reach
ntripsvr:
address: 192.168.42.1
mount_point: ‘9001’
password: '

port: 2101
serial:
baud_rate: 57600
device: ttyEXTS0
tcpcli:
address: localhost
port: 9001
tcpsvr:
port: 9000
rtcm3_messages:
message_1004:
enabled: false
frequency: 1
message_1006:
enabled: true
frequency: 0.1
message_1008:
enabled: false
frequency: 0.1
message_1012:
enabled: false
frequency: 1
message_1033:
enabled: false
frequency: 0.1
message_1074:
enabled: true
frequency: 0.5
message_1084:
enabled: true
frequency: 0.5
message_1094:
enabled: true
frequency: 0.5
message_1124:
enabled: true
frequency: 0.5
message_1230:
enabled: true
frequency: 0.1
bluetooth:
enabled: true
pairing:
discoverable: false
no_input_no_output: true
pin: ‘
correction_input:
base_corrections:
io_type: ‘off’
settings:
bluetooth:
send_position_to_base: false
lora:
air_rate: 9.11
frequency: 920500
output_power: 20
send_position_to_base: false
ntripcli:
address: 192.168.42.1
mount_point: REACH
password: '

port: 2101
send_position_to_base: true
username: reach
serial:
baud_rate: 57600
device: ttyGS0
send_position_to_base: false
tcpcli:
address: localhost
port: 10001
send_position_to_base: false
tcpsvr:
port: 9000
send_position_to_base: false
device:
power_on_bottom_connector: true
privacy_policy_accepted: true
role: null
rv3_banner_shown: false
usage_analysis_accepted: true
logging:
logs:
autostart: true
base:
enabled: true
format: RTCM3
raw:
enabled: true
format: RINEX
rinex_options:
logging_interval: 0
marker_name: null
pole_height: null
preset: default
satellite_systems:
beidou: true
galileo: true
glonass: true
gps: true
qzss: true
sbas: false
time_adjustments_enabled: true
version: ‘3.03’
solution:
enabled: true
format: LLH
started: true
settings:
interval: 24
overwrite: true
simultaneous_logging: false
network:
tcp_over_modem: false
position_output:
output1:
io_type: ‘off’
nmea_settings:
bluetooth:
ebp:
enabled: true
update_rate: 1
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
serial:
ebp:
enabled: true
update_rate: 1
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
tcpcli:
ebp:
enabled: true
update_rate: 1
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
tcpsvr:
ebp:
enabled: true
update_rate: 1
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
settings:
bluetooth:
format: NMEA
serial:
baud_rate: 57600
device: ttyEXTS0
format: NMEA
tcpcli:
address: localhost
format: NMEA
port: 9000
tcpsvr:
format: LLH
port: 9001
output2:
io_type: ‘off’
nmea_settings:
bluetooth:
ebp:
enabled: true
update_rate: 1
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
serial:
ebp:
enabled: true
update_rate: 1
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
tcpcli:
ebp:
enabled: true
update_rate: 1
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
tcpsvr:
ebp:
enabled: true
update_rate: 1
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
settings:
bluetooth:
format: NMEA
serial:
baud_rate: 38400
device: ttyEXTS0
format: ERB
tcpcli:
address: localhost
format: ERB
port: 9000
tcpsvr:
format: NMEA
port: 9001
positioning_settings:
elevation_mask_angle: 15
glonass_ar_mode: false
gnss_settings:
positioning_systems:
beidou: true
galileo: true
glonass: true
gps: true
qzss: true
update_rate: 5
gps_ar_mode: fix-and-hold
max_horizontal_acceleration: 1
max_vertical_acceleration: 1
positioning_mode: kinematic
snr_mask: 35
sound:
mute: false
volume: 100

Here is the report for the rover

Blockquote

Simple system report

app version: 29.2-r0
current_network:
ip: 192.168.42.132
security: wpa-psk
ssid: RajaRondaReachBase:6C:61
enabled: true
mode: client
base_mode:
base_coordinates:
accumulation: 120
mode: single-and-hold
output:
io_type: ‘off’
settings:
lora:
air_rate: 9.11
frequency: 919000
output_power: 20
ntripcaster:
mount_point: REACH
password: ‘
port: 2101
username: reach
ntripsvr:
address: ‘’
mount_point: ‘’
password: '

port: -1
serial:
baud_rate: 38400
device: ttyEXTS0
tcpcli:
address: localhost
port: 9001
tcpsvr:
port: 9000
rtcm3_messages:
message_1004:
enabled: false
frequency: 1
message_1006:
enabled: true
frequency: 0.1
message_1008:
enabled: false
frequency: 0.1
message_1012:
enabled: false
frequency: 1
message_1033:
enabled: false
frequency: 0.1
message_1074:
enabled: true
frequency: 0.5
message_1084:
enabled: true
frequency: 0.5
message_1094:
enabled: true
frequency: 0.5
message_1124:
enabled: true
frequency: 0.5
message_1230:
enabled: true
frequency: 0.1
bluetooth:
enabled: false
pairing:
discoverable: false
no_input_no_output: true
pin: ‘
camera_trigger:
duty_cycle: 20
enabled: false
period: 2
reverse_polarity: false
correction_input:
base_corrections:
io_type: lora
settings:
bluetooth:
send_position_to_base: false
lora:
air_rate: 9.11
frequency: 922700
output_power: 20
send_position_to_base: false
ntripcli:
address: ‘’
mount_point: ‘’
password: '

port: -1
send_position_to_base: true
username: ‘’
serial:
baud_rate: 38400
device: ttyEXTS0
send_position_to_base: false
tcpcli:
address: localhost
port: 10001
send_position_to_base: true
tcpsvr:
port: 10000
send_position_to_base: true
device:
privacy_policy_accepted: true
role: null
rv3_banner_shown: false
usage_analysis_accepted: true
logging:
logs:
base:
autostart: true
format: RTCM3
started: true
raw:
autostart: true
format: RINEX
rinex_options:
logging_interval: 0
marker_name: null
pole_height: null
preset: default
satellite_systems:
beidou: true
galileo: true
glonass: true
gps: true
qzss: true
sbas: false
time_adjustments_enabled: false
started: true
version: ‘3.03’
solution:
autostart: true
format: LLH
started: true
settings:
debug: false
interval: 24
overwrite: true
simultaneous_logging: false
position_output:
output1:
io_type: bluetooth
nmea_settings:
bluetooth:
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
serial:
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
tcpcli:
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
tcpsvr:
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
settings:
bluetooth:
format: NMEA
serial:
baud_rate: 38400
device: ttyEXTS0
format: ERB
tcpcli:
address: localhost
format: ERB
port: 9000
tcpsvr:
format: LLH
port: 9001
output2:
io_type: tcpsvr
nmea_settings:
bluetooth:
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
serial:
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
tcpcli:
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
tcpsvr:
gga:
enabled: true
update_rate: 1
gsa:
enabled: true
update_rate: 1
gst:
enabled: true
update_rate: 1
gsv:
enabled: true
update_rate: 1
main_talker_id: gn
rmc:
enabled: true
update_rate: 1
vtg:
enabled: true
update_rate: 1
zda:
enabled: true
update_rate: 1
settings:
bluetooth:
format: NMEA
serial:
baud_rate: 38400
device: ttyEXTS0
format: ERB
tcpcli:
address: localhost
format: ERB
port: 9000
tcpsvr:
format: LLH
port: 9001
positioning_settings:
elevation_mask_angle: 15
glonass_ar_mode: false
gnss_settings:
positioning_systems:
beidou: true
galileo: true
glonass: true
gps: true
qzss: true
update_rate: 5
gps_ar_mode: fix-and-hold
max_horizontal_acceleration: 1
max_vertical_acceleration: 1
positioning_mode: kinematic
snr_mask: 35

Hi Fathan,

Thank you for the photos. Did the setup work well before? When did this issue start?

I see that your rover is on the firmware version of 29.2. Let’s update it to the latest version and try the connection again. Can you also give me access to the Google Drive folder with the full system report? We’d take a closer look at it.