Emlid flow connection problem

Urgent: I completed a survey today but back at office , it is impossible to connect to the cloud service Emlid flow 360.

Can you please help to solve the problem so that i can get access to survey data?



Hi Stephane,

What do you see if you go to flow360.emlid.com ?

Hello Igor,

Thanks for your reply.

When i go to the link it shows a page with email accounts to log in but when i choose the email account the page remains blank

I tried with another android phone but i have same issue. it seems to me that there is a problem with thé Emlid flow server

Hi Stephane.

I just logged into Flow 360 on my Google Pixel phone using the Firefox browser. No issues

Thanks Dave,

I tried to connect with firefox but did not work.

I also updated Emlid Flow but does not work either.

Have you tried from a computer?

Is this the login screen you see?

1 Like

Hello Dave,

But when i sign in , the screen remain blank.

Hello Igor,

Yes i tried on my computer, same issue when i log in, the screen remain blank with the circle turning in the middle.

Just got this error message while trying to connect from my laptop.

{“code”:500,“description”:“The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.”,“name”:“Internal Server Error”}

I created a new account with Emlid and I was able to sign in, then signed out to connect with the old one, but I could not log in.

Definitely, the issue is from Emlid’s server.

Sounds like some sort of hiccup with that specific account. If you haven’t yet, send an email to: support@emlid.com

You should have the project on your mobile device for use in other software, correct?

Hello Dave,

Yes, I already contacted Emlid’s support team.

The issue is that I did not export the project, when I am not connected to the account I can’t access the data. What I did is, I created another account to be able to use my subscription for coding and lines and back to the site to survey again. now I have another issue with the new account, I can’t sign in on my computer. see error message below

So, you created a project on the web and not on your Emlid Flow App on your phone?
And, that project is now not syncing to your phone?

A quick web search says that the likely cause for that error message in not using the correct URL for the login page. Try clearing the browser cache and using the URL: flow360.emlid.com

Hopefully Emlid will get you on track on Monday.

I created the project on my phone in the Emlid Flow App.

Then, unless you deleted it, it is still there. You can export it directly from your phone to use in other software. You don’t have to use the web account to do that.

The moment I sign out from my account, the projects are no more accessible. I need to sign in to get my projects back.

Hi Stephane,

We’ll be sure to figure it out. We’re already in contact with you via email, so let’s continue our discussion there. Just wanted to leave a note here that the data is not accessible now because we’ve received a data deletion request from this account.