Emlid Caster Offline

Hey everyone,

I am attempting to connect my RS2 to Emlid Caster. I have verified all information is correct, I have a connection showing with the rover connections but the mount point is still showing offline and I am not receiving corrections.

I have found a few previous threads detailing things a little bit but when I have tried the solutions they have provided, I am still stuck with the same offline status in my mount point.

1 Like

Please send screenshots of base and caster, ms paint out any info you do not want to show.

Emlid caster is not offline I am using it right now, most likely your router/isp is blocking the port.

1 Like

I didn’t think it was offline but no matter what I’ve tried I still am unable to get an online connection for the RS2 to receive corrections.

Your rover side is fine and waiting for corrections. No need to send GGA to Emlid they currently do not have VRS or Auto selection. This will just burn your data for no benefit.

We need to trouble shoot the RTK base setup.
How does your base RS2/M2 receiver sending corrections connect to the Caster?
I think you have to navigate to the base output page first.
Also base settings and make sure you have the corrections you want selected.

Are you testing inside? the base will not make corrections indoors.


So I have the RS2 tethered to my iPhone’s hotspot in order to receive the corrections. I had the base on my balcony weathered to my phone, had 30 satellites in view but still didn’t maintain a good enough connection I’m assuming. going to try and get out this week to test in field.

Looking to have this set up including my P4 RTK to save lugging around multiple tripods and equipment. P4 RTK is connected to the base but have been working through this off and on throughout the weekend but haven’t had a chance to get out to verify the location was my issue in receiving corrections.

Hi @andrewross,

I agree with @PotatoFarmer. The issue is definitely on the base side.

Is it connected to your phone hotspot? Internet connection is the first thing I’d check here. Maybe you can try to connect to another network and check if it’s online on the Caster page.

1 Like

It was indeed connected to the hotspot, verified through my laptop which was also tethered and using the reach panel to view the RS2’s information.

Currently out in the field testing this to see if I have made any progress with the connection to Caster’s mount points to receive corrections but I have not yet received a fix or float status for some reason and am not sure how to correct this.

I have the RS2 tethered tp my phone as well as my laptop. Base settings have both correction input and base output set as NTRIP and I am showing online in both the mount point and the rovers thankfully.

Now my need I guess is to connect my P4 RTK to the RS2 base but with both base input and output connecting to Caster, how would I enable a connection to the P4 RTK? would I simply input the rover details into the remote under the custom network RTK section? I have tried that and am seeing now 2 rovers connected on the Caster Side of things

In your photo there are some issues.

Why is your base receiving corrections? Are you trying to sync to another base?
The 8390km baseline is telling me you probably connected to something randomly selected, or missed a - sign on the base tab.

Your base setup should look something like this.

Ok some of the confusion here is I was thinking you are setting up two RS2. But instead its more like this?

RS2 Base ----->> sends corrections to ----->>>>emlid caster ----->>>>> sends corrections to —>>> P4 RTK

This is what the corrections page should look like, unless you are optionally syncing to another base during initial setup using average fix. Once you locked the coordinates into manual, then its turned off again.

Okay bare with me as I am now lost again and back home so would have to get out to the field again to test connection.

With my base correction output and input set to NTRIP I was able to gain a fixed correction and run a 30 min solution. The P4RTK was connected and maintaining an RTK signal but I am in very close proximity to an airport here in Toronto so I did not take off.

With those settings I did have a 2 rover connections online and a mount point online as well which now that you mention it, there would have been no need to set the base as a rover I am assuming? So really what I should be seeing under the caster account is a mount point online, and 1 rover being connected being the P4RTK unless I have my RS2 rover also hooked up.

To yourself, its a neat trick that yields nothing.

I think you did something wrong. Do you have one RS2 or two?
If you have one you can’t have it acting like a base station and connect to the ntrip stream it sends with the same receiver.
So if you have one RS2 you should set it as base station without correction input.
Then connect the P4RTK in the emlid caster like it was a rover.
If you want absolute position on the base you should connect it first to another base or ntrip service and the collect 5min average fixed solution.
Then you can close the correction input and continue the setup.


Still confused, only try to solve one problem till it works. Just work on rs2—>caster0—>P4 until it works.

Then try rs2 #1base -->caster —>rs2 #2 rover,

Rs2 #1—>caster-----> Rs2 #1, will “fix” but does not do anything meaningful.

Alright I think I finally have a grasp on things.

So breaking it down, I will set up the base (RS2-1) without correction input for 30 min fix solution if possible. Input the rover credentials in the P4RTK Custom RTK network settings, which if done correctly should show the same base information under the custom network as on the base (RS2-1) Reachview section of the base settings and fly the mission.

For utilizing my RS2 Rover (RS2-2) I can input the coordinates manually into my base (RS2-1) and connect the base and rover VIA LORA connection being base output and rover correction input. Or I can leave the base (RS2-1) sending corrections to NTRIP Caster and set the rover (RS2-2) up to relieve corrections from Caster’s Rover tab. That one still confuses me a little becauseI’m not sure if the base (RS2-1) is in the same network as the rover (RS2-2) if that makes sense.

In theory I guess the set ups should look something like this:
Base >>>> Emlid Caster >>>> P4 RTK
Base >>>> Emlid Caster >>>> Rover
Base (manual FIX entry) >>>> Rover

I think you are starting to get it.

The base does not need to fix, it just needs to know where it is at.

Only in one specific condition if you are temporarily using yet another bench marked base we will call RS2 #3, to initially get an average fix on base RS2#1. Once you have the coordinates, RS2 base #1 no longer needs any corrections.

But if you do not need to be synced to a local reference frame or datum, just average float the base for 5min. In RTK all measurements are always right relative to each other. It takes a bunch of extra steps to get them lined up with a map.

Once your base rs2#1 is sending corrections it is like a radio station, and devices that can get the data can use the corrections. So your drone and rs2#2 can both use the same base at the same time.


Maybe you mean 30 min average single? For the solution to be float the user must connect to some ntrip source and then if the conditions are not good the solution will be float.
Anyway I think the OP succeeded with P4RTK. He just have to clear up the terminology and the proper workflow in order to have absolute accuracy. BTW the P4RTK rocks!

Trying to get it all figured out lol. Operator turned grademan turned sewer water foreman turned drone op business owner haha. 15 years in the industry and never in my life would I have thought I would start my own business doing drone work for a living.

First piece of equipment I bought and love “flying” it lol. Not that you really do much when flying it but still so cool to watch and see how far tech has come.

Yes sorry average single, but still no need for 30min if you are only doing relative measurements. Its a lot of waiting around to still get a random number.

1 Like

Hi Andrew,

First of all, I think this guide should be of help for you because it describes how to use Reach RS2+ as a base for DJI P4P RTK. The connection is made through Emlid Caster exactly as in your setup. I couldn’t describe it better than it’s described in this guide. But if something isn’t clear enough there, let me know!

You don’t need LoRa in your setup as both drone and Reach rover can be connected to one base via Emlid Caster.

All devices should be connected to the Internet, but they don’t need to be in the same network.

Regarding the base setup, as the guys above said, it’s a question about absolute and relative measurements.

If you need absolute accuracy, you need a known point. The easiest option is to connect your base to some NTRIP service (don’t confuse it with Emlid Caster) and average its position in Fix. Otherwise, you can average it in Single for a couple of minutes and go.


I am unable to connect to the caster as well
Just this morning we tried via 3g which was sending data out via checking that it had internet. We also changed the base to hotspot and still no luck. When we put the base and rover close to each other via lora we had fix. I just updated from firmware 26 this morning. Spent a half day trouble shooting and still no solution.