Emlid caster - no connection to base

Hi. I’m trying to set up two RS+ to work via Emlid Caster. I have entered configuration as described in the instructions for both base and rover. They are both connected to a mobile hotspot. The rover shows online, but the base shows offline.

Both units are getting raw GPS signals and have single positions.

I have tried changing the address from url to ip address. I have tried changing passwords. I’m using port 2101 which works with rtk2go, so the port isnt blocked. I’ve tried creating a new account - same problem.

The units work together with Local NTRIP no problem.

Any suggestions as to why I cant get a connection to the caster for my base?

Please take pictures of settings, omitting sensitive information

Try typing in caster.emlid.com, instead of the IP.

1 Like

Thanks, yes, already tried that with no luck.

This is tough because it is so simple usually to connect.

Try regenerating the base password and re entering it.

What type of hotspot are you using, some have some very arbitrary restrictions.

Have you already tried switching their roles?

Hi @boatgypsy,

Can you please share a Full system report from the base? I’ll check what’s going on with the connection. Please send it to support@emlid.com or via PMs here.

It’d be also great if you could test the connection by switching the roles as Dave suggested.

3 posts were split to a new topic: The base remains offline

Hi. I have tried switching roles with no effect. I have tried two different RS+ units with the same results. I have tried using both the URL and the IP address with the same results. I have tried different mobile hotspots and one broadband landline.

I’m away from work until next week, but will get the sys rep posted as soon as possible.

@liudmila.slepova Hi. I came to try again as I had some time over the weekend. Despite all settings being the same, it logged in a registered as online immediately.

Given the various permutations I have tried and that essentially nothing at my end is different, I can only look assume it was a server issue.

If I have any further problems, I will report back.

1 Like

Nope, I had it working briefly at home while both base and rover were on the same wifi hotspot. I had both base and rover showing online on the caster and I got corrections on the rover and a fix. As soon as I took the rover out on site with another hotspot, nada, nothing, not a sausage. Endlessly “waiting for corrections”. As soon as I switched to a public CORS - instant corrections.

Checking the caster page again showed that the base was online, but not the rover. Note, originally it was the other way round.

I got home and spent another 5 hours trying to get it to work. The process was made doubly frustrating by the units repeatedly refusing to connect to wifi or when connected, refusing to talk via Emlid Flow, needing a hard reset, followed by alternately refusing to boot at all, or to boot to internal hotspot, or just randomly shutting down for no reason.

Another point of interest is that the caster page was still showing the base as online even when it had been switched off for some time. Only logging out of the caster and back in again cleared this flag, after which I could get neither base nor rover to connect.

If I was being paid for my time spent trying to get these bloody units to work, I could have afforded a Leica or Trimble by now!

Hi @boatgypsy,

Sorry for the delayed response.

This behavior of Emlid Caster is quite strange, it shouldn’t work this way. I’ll do my best to figure out what could cause such issues. Please share with me the following details so I could analyze them:

  1. What email address is used for the Emlid Caster profile?
  2. The Full system report from the base and the rover.

Please send it to support@emlid.com and I’ll take care of it.

A post was split to a new topic: Issues with connecting to Caster with Reach