Edge Video Transmission

Hello everyone,

I am experiencing issues with the video transmission. I am using windows 10 with the wifi location disabled.
I updated all the driver, edge (v1.4) and wifi modules (Win10_x64_Realtek_USB_Driver_1030.24.0601.2017). i list down here my procedure:

  1. i connect to edge wifi
  2. i launch QGroundControl and initialize UDP connection on Default Port (14550) and IP
  3. Once the connection is established, i receive a bounce of errors from QGC voice because of the pre arm check failure (of course it fails, there is no vehicle connected!), therefore i disable those checks on the safety tab. i still get the yellow blinking led on the edge though.
  4. I go on the flight panel to start the video streaming. i have the prove that the connection is really established because if i tilt the edge, the artificial horizon moves.
  5. i hit the video streaming configuration wheel, but when i click the start streaming button, nothing happens. i tried both a GoPro hero 2 and a FDR AX 53.

Any suggestion?
thank you for your time,


What HDMI cable do you use? Do you turn the camera on after Edge booting?

Sorry Alexey for the late reply, i thought i would receive an email when some would answer…

Anyway the problem was not on the HDMI as everything worked fine when using a ubuntu computer. The problem is with windows, and i am narrowing it down to the Gstreamer compatibility… any way gstreamer is a black hole for those who are not in the field, and i am having major issue in understanding which library/code segment is not working. i would just like to hear that someone is using it on Windows 10 successfully before thinking that the problem is on our computers…

Ciao Marco,

I use Emlid Edge with W10, both field one with Edge wifi modem and home with an Intel Wifi Card.

With the latest version of Edge software, I used a Gopro Hero3+Black, following Edge wiki. I had good video with 1080-30fps(or25 pal) or 720-60fps.

I changed the camera for a Firefly8S. Video is OK at 1080-30fps but link do not work if I follow the wiki:
Boot computer
Boot Edge
Boot camera
Ask video from QGroundControl…

With the Firefly, I had to ask video from QGC then turn “on” the camera. There is also a bug in the camera firmware, so sometimes camera freeze at boot and I have to reset it by removing the battery (not Edge related).


Hey Marc,

thank you for the reply. with latest firmware you intend the v1.4 released 02/04/2018?
i was thinking that maybe i should try a roll back to a previous version because i could not obtain the videostream from a hero2 even following the wiki step by step. on a Ubuntu pc instead, the same setup worked just fine. I bought this module mainly for streaming an hd video from a thethered inflated balloon 2km away, i do not care for all the QGround Control features. i would love if there was just a single Software tool for video streaming… it would be easier.

Hi Marco

I’m in the same boat as Marc - using Windows 10 with either the dedicated WiFi module or the internal wifi card.

HDMI stream stability is definitely improved in the latest firmware release - it was one of the first things I immediately reported as feedback when I recieved my unit last year. The fickle “process” for opening the stream as described in the Wiki did work, but they’ve updated it to allow a bit more hotswapping in terms of removing the need to have things turned on in a particular sequence. I can confirm it works much smoother on latest firmware - I’m running the Firefly Q6.

If it works with Ubuntu and not W10, I’d suggest the old uninstall/reinstall of QGC. Annoying yes, but maybe it will clear your issues. Also 100% double check you have the latest drivers and firmware on both the PC and Edge/RPi. Comb through the Wiki to make sure you haven’t missed anything. If you’ve updated to the recent firmware released last month, then making sure you’re also on the latest QGC version too will serve you well.

Even for me, the video stream system doesn’t work on the first try every single time. But it is certainly the best FHD UAV integrated video stream client I’ve used outside of DJI systems and I’d encourage you to stick with it.


Hey Kyle,

thanks for your reply. An old software version was my first thought as well, this is why i checked my QGroundControl version more than once before posting here… I also tried on different Windows pc. i guess i will try one more time, check listing every step i do and writing it down so that if it doesnt work again and i am doing something wrong, maybe you guys can spot it out for me.

Anyway, right now i have : 2018-04-02 v1.4 version on EDGE and QGroundControl for EDGE v3.2.4-edge-2.3. I feel like something with gstreamer doesnt quite works out but who knows…

Which HDMI cable should we use for video streaming. Is there any specific cable that should be used for video streaming because we are using micro HDMI to HDMI and then using a converter to convert it to micro HDMI and we are getting signals distorted.

The specifications for the HDMI port don’t single out which generation of HDMI interface the Edge supports - ie HDMI 1.1, HDMI 2.0, etc. Perhaps someone can shed some light on which specification the HDMI port is?

Regardless, I wouldn’t think it should cause any troubles using any old cable. It’s really not pushing a large amount of data as far as high-end HDMI throughput uses go. I ran the same setup as you before I could get my hands on a end to end Micro-Micro HDMI cable (very rare to find!).

I did however have intermittent issues with a particular cable I used. I isolated the HDMI source and the destination (ie various cameras connected to the Edge or a computer monitor) and the cable worked fine except with a particular camera conected to Edge. So I think you may just have to use trial and error until you find one that works for you. I went the custom connector and ribbon cable route and it has worked flawlessly.

A post was split to a new topic: Edge - Can’t get the stream

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.