Emlid

Community Forum

Drone lands with power loss, help needed with BIN logs


#1

Hello everyone,

I built a basic quadcopter which is like Igor’s (Navio+, RPi2 with APM 3.3, Q450, 4-in-1 20A ESC, Multistar 2212-920). I also added Airborne’s 3D printed case.

Everything worked fine last summer. Then I tried to protect the barometer from UVs with a foam, and finally removed the foam since the 3D printed case should suffice.

Today my problem is: the drone takes off, flies fine for ~30 sec in Loiter mode at 3 meters altitude, then the engines progressively lose power and the quadcopter lands quite harshly despite full throttle. I tried to take off again with different flight modes, but the quadcopter lacked power to succeed.

Do you have any idea why the drone can’t fly more than a minute ?

I have 3 different batteries which look fine.

Thank you,
Best regards


#3

Hello,

The “Battery problem” preset in Mission Planner log review shows a voltage drop despite full throttle.
I think I may have killed my 3000mAh 20C Lipo with overweight caused by an additional landing gear.

Best regards


(Andrew Yushkevich) #4

Hi @deltasight

Was it the reason for the issue?


(system) closed #6

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.