Drone Just Crushes and never flies!

Hey Guys, so finally I have created this drone which now does not even fly. And the worst part is I do not even know what the problem is. Any will be greatly appreciated.

So I have tested the motors individually and all of them works with propellers in the right direction and tend to lift the copter at the same threshold when I test them individually. My ESCs are calibrated and are from the same manufacturer.

Video to see it crash: https://drive.google.com/drive/folders/1qV4WtPxXhCjW9IspbQd4myalI6DMWz3K?usp=sharing

Logs for two flights today and yesterdays which continuously would crash 2020-05-19 14-20-26.tlog (4.1 MB) crashed:

My qadcopter health status pictures (some arms are a bit unhealthy; see pics for more info):

Hi Abdul,

It seems you uploaded the log from GCS. Could you also share with us the dataflash log? It’ll provide us with much more info on this.

Do you plan to fly without the GNSS antenna? Is it possible to place the drone on a more slippery surface?

Hey Tatiana, thanks for the reply much appreciated. I plan to fly with gnss antenna but just not now due to the crashes.

All kinds of logs from yesterday today: https://drive.google.com/open?id=1k7TcqECHHPa8q6PffYCN1bM7wKUkxS5X

Video on a smoother surface: https://drive.google.com/open?id=1qV4WtPxXhCjW9IspbQd4myalI6DMWz3K

Thank you for your reply and looking forward to hearing you in solving this problem.

Hi , i think the problem could be wrong order of esc’s . Check this picture out and make sure propeller for each motor is in correct direction ( cw or ccw )

Make sure that the front of the navio2 board is between esc’s 1 and 3 as in picture .
You may need to recalibrate compass too .

Thank you for your response. Unfortuantely that is not the problem and I have already made sure that those are correct multiple times.

have the props been balanced ?


I’m sorry, what do you mean by balancing?

Hi Abdul,

I’ve noticed from the video that Navio2 and RPi setup oriented improperly. The arrow on Navio2 should be pointing forward.

You may change the standard orientation, however, you need to configure some additional parameters in MP for it. Check the ArduPilot docs for more details.

Oh I see, well even after I fix it, it does the same. I think the problem is in the arms because some of the arms are tilted while one of it isn’t causing one of the arm to have more force; thereby, causing the crash. I also attached the videos with the correct orientation and the same results. Thank you for your help though!


Hi Abdul,

I’ve requested access to the video, could you please share it?

I’m sorry Tatiana, I don’t know why the setting had been tweaked. You should be able to view it now.

Hi Abdul,

Sorry it took so long to get back to you.

I’ve checked the videos, and, I’m afraid, at this stage, it’s quite difficult to understand from them why the build behaves this way.

Any chance you can share the dataflash logs with me once again? It’s possible they can lit a light on all the situation.


First read the link that tatiana shared with you very carefully

FIrst of all. Never fly your drone indoors like that esopecially on a first setup.

Please attatch the top plate of your frame directly to your arms and do not use standoffs like that and then find a vibration mount for your navio and attach that to your top plate.

Replace your arms. It seems that you have had a couple of crashes already or that you are overtightening your arms.

There are a couple of things that you need to check.

Which software are you using to setup your copter. QgroundControl or MIssion Planner?

As Mohammadsahaab said. Have a careful look at your motor orientation. and set it up according to the sketch ensure that the motors correspond to the arrow of the Navio2.

Make sure of the following is set correctly

You have the correct dram selected in your software. Your frame setup should be Quadcopter X make sure it is not H configuration

Your board orientation is is set to 0

Motor 1 is top right of the arrow on of your navio
Motor 2 is bottom left
Motor 3 is top left
motor 4 is bottom right

Ensure that your motors are correctly soldered to the speed controllers so that the motors rotation is as followes.

Motor 1 Top right Counter ClockWise
Motor 2 Bottom left Counter Clockwise
Motor 3 Top left Clockwise
Motor 4 Bottom right clockwise

When you have this set correctly now ensure that you have the correct propellers on the correct motors.

Thank you all for your responses, I have already bought new arms and new frame kit and will replace them since I already had many crashes. I will connect the top plate directly to my drone as advised and will reply back with data flash logs and video God willing. The other instructions have been done accordingly.

Before you fly you can contact me and we can go through your setup step by step.

Good idea, thank you, I will contact you when I’m finished with replacing and fixing the set!

All the settings and adjustments are not fixing everything if underlying issue(s) are not fixed.
In order to prevent vibrations it is important to balance any propeller. Even brand new propellers often are somewhat out of balance and hence causing vibrations. From my experience plastic propellers are worse than lets say carbon fibre propellers. But even those should be checked and if needed balanced.
There are a number of videos available explaining the procedure. One such example is:

Only after this has been done you should look at more advanced steps to solve problems, if they are not already resolved.

@anon31534460 Thank you for that, when I’m finished with my hardware set up back, if it doesn’t fly I will definitely balance the prop because the problem with my drone is that it doesn’t fly from the start, I don’t think balancing has a major part in that.

Hey Barry, can this type of scotch tape be used for RC damp mounting?

I just use a proper vibration dampning system.

There are example of a vibration mounting system in the navio2 docs :slight_smile: