DJI P4RTK w/ Emlid RS2 RTK Connection Issues


I have a customer who purchased a DJI Phantom 4 RTK. He wants to use his RS2 to receive RTK corrections via NTRIP. For whatever reason when connecting the P4RTK to the Local NTRIP from the RS2 I continually am getting a “Connection Success” on the P4RTK and jumping between a Single or FLOAT position. I can never achieve a FIX position, and the P4RTK continually has a “WEAK RTK Signal” Error. I have tried connecting via the Local NTRIP and using the Emlid Caster method and configuring the Base NTRIP credentials on the RS2 and the Rover NTRIP credentials on the P4RTK. Both methods are having the same result. This is also odd because using a DJI M300 or DJI M3E w/ the RTK Module the NTRIP connection can achieve a FIX position using both methods. Also, for whatever reason for the M300 and M3E can connect directly to the RS2’s wifi via hotspot and connect. For the P4RTK I must connect the RS2 and P4RTK to a hotspot to even have the P4RTK attempt to connect. I know people are having success with the RS2 and P4RTK, so if someone can please provide any suggestions that can come to mind with my current issues connecting the Emlid RS2 with the DJI Phantom 4 RTK.

Thank you,


Hi Austin,

Welcome to our community forum!

At the first glance, it looks like some kind of issues with this particular drone because such integration with M300 and Mavic 3 Enterprise works fine. However, they should integrate smoothly as well, so let’s try to figure it out.

Do you use the same flight controller when you connect P4RTK with Reach? Besides Reach’s hotspot, have you tried other Wi-Fi networks for connection? For example, you can check the connection with your mobile hotspot. It may help to understand on which side a possible issue’s source lies.

Is it possible to check age of differential when you connect P4RTK to Reach and start receiving corrections? If so, is it stable and equal to one, or it rises up?

1 Like

So I am able to connect the drone directly to the hotspot of the RS2, however I am not able to connect to RTK via NTRIP. The only workaround I have been able to do to just get a successful connection with a “Weak RTK Signal” error was by connecting the RS2 to a mobile hotspot and then my flight controller to that same hotspot. Using the hotspot as a way to route the connection to the RS2 between the flight controller. I have never had to do such things with any other aircraft (M300, M3E, P4, etc.). You could always just connect directly to the WiFi emitted by the receiver. However, this does not work for the P4RTK. I would think it was a faulty aircraft too, but this is happeneing on both his brand new P4RTK’s which I now have to test and figure out the underlying problem before returning. Let me know what you think.

Thnak you,


Both controlled from the same remote or with different remotes?

Different remotes.

1 Like

Hi Austin,

In the same setting, the other drones obtain FIX and then with everything else the same, the P4R does not? That sounds like something is wrong with the P4R. I know for certain that the P4R integrates well with the Emlid receivers.

I generally work off my phone’s hotspot. I’ll have to see if the P4R has any issues connecting to my RS’s hotspot. I don’t remember there being a problem but I’ll check it out. But in any case it should work fine with the phone’s hotspot.

1 Like

Are you normally connecting your P4RTK controller directly to the Emlid’s hotspot or routing through a mobile hotspot? I can only get to a FLOAT connection when routing through a mobile hotspot and connecting both the RS2 and P4RTK controller to that same hotspot.

So, you can set up the RS2 and connect a M3E and receive a FIX. Then, with the exact same setup at the same time, the P4R can only achieve FLOAT sitting right next to the M3E that has FIX, correct?

That is exactly correct. Also, why can I connect the M3E directly to the RS2’s “Hotspot” WiFi while I have to route the NTRIP connection for the P4RTK through a mobile hotspot?

Interesting. The M3E says it uses the same constellations as the P4RTK, so I’m not sure why it would not FIX sitting next to the M3E that will. And both P4R’s have the same problem, right? If you get FLOAT, that is telling you that the P4 is receiving corrections. The other drones are demonstrating that the corrections are sufficient. That points the finger at the P4RTK, right?

I don’t know. I’ve seen others report the same thing with the P4RTK though. Tomorrow, if it’s not raining too badly, I’ll set mine up and see if it connects to the RS’s hotspot.

I would agree it is a P4RTK issue, however I know there is a solution. It is so odd to me that the only way I can connect to the RS2 is via a mobile hotspot. That is just so unnecessary for any other UAV with RTK capabilities: the standard workflow is always to connect directly to the receivers broadcasted WiFi signal to receive corrections, not have to have another piece of equipment (mobile hotspot) to route through. Now if you are receiving corrections from a VRS Network obviously needing the hotspot is a necessity, but if you have a local base on site that emits a WiFi signal, there should not be a need to have to route through a mobile hotspot.

If I can establish that my P4R will also not connect to the RS’s network, maybe we can get Emlid involved in looking for an answer.

One other thing. Have you tried with the P4R SDK remote and a smart device. I have a hunch that if there is a problem, it may be with the ancient android kernel used by the P4R’s standard remote.

1 Like

Did you guys manage to get to the bottom of this? I’m using RS2+ as a base and running P4R as a rover, getting fix solution on the base but only single or float on the drone, connected using EMLID Caster.
On a separate note would you recommend getting the SDK remote as currently just running the standard RC.

Hi James.

Can you clarify. The base in a base-rover setup does not receive corrections, so it cannot be Float or Fixed. Do you mean that you receive corrections from an NTRIP service to collect a point and then switch to using that point to broadcast corrections to the drone via Emlid Caster?

If so, that setup does and has always worked just fine. The problems were with using Emlid’s Local NTRIP AND using the RS2’s hotspot rather than a phone’s hotspot for the shared network.

If you are specific about your workflow, maybe I can help.


I would update the firmware on all devices involved to see if that makes a change.
Other than that maybe you should check the base position lat-lon-height?
One time I put the lat-lon as lon-lat and of course the rover(a regular one - not drone) could never fix!

1 Like

Hi Dave,

This may be where I am going wrong - I was setting up the reach and connecting it to an NTRIP service provider (RTKPremium) and achieving a fix solution, I was then outputting corrections via EMLID caster to the rover (P4RTK) and only getting a SINGLE or FLOAT on the drone. I am a newbie so trying to learn the best practices and a sustainable workflow for our projects.

Am I right in saying I could use the RS2+ with a fix solution to pull the GCP’s and then disconnect the RS2+ and connect P4RTK to the NTRIP Network to achieve a FIX and run the missions?

Hope I have explained that clearly enough.



This is okay. When setting up the Reach to establish the point, you want to ensure that the receiver starts the averaging of the point after obtaining a Fix.

This is fine too. How are you handling the networking with all of this?

Yes, perfectly fine. The advantage to using the RS2+ as the base to send corrections to the drone is that your baselines are very short compared to a service. But, depending on the service, it could be negligible or significant.


Great thanks Dave, really helpful.

I think one thing I didn’t do is average the point after achieving a FIX solution, I didn’t know this was necessary as I thought that the point was only averaged for a AVERAGED SINGLE SOLUTION, I wasn’t aware I had to average if the rs2+ had a FIX. So once I have a FIX on the RS2+ I then need to average the point?

Re networking I was in my garden at the time using the home WiFi :joy: I have a data sim in the rs2+ and in the drone and in my phone, am I correct in saying all need to be connected to the same network connection?

Thanks again


If you have “Average Fix” selected in Base Settings, you should be okay.

If using an NTRIP service, or Emlid Caster, it’s all internet based, so all the devices can log in however you want, so long as they all have data, which it sounds like yours do.

If you are using “Local NTRIP”, then the base and rover have to be on the same network.

Ok I’m going to have another crack over the weekend so Il likely be back with more questions :slight_smile:

Thanks again it’s much appreciated.

1 Like