DJI M600 Reach M+ Intergrartion

Hi All,

I am new to the community so apologies if I am asking basic questions.

We have recently purchased a RS+ and M+ as a PPK/RTK setup for our M600 Pro.

I have got it right to get the event positions for the images but with some accuracy issues. I believe this is due to 2 issues

  • The GPS not being mounted directly above the camera, thus not having only a height adjustment but a y,x adjustment aswell. We are using the DJI ground station pro as a flight planning software. This app gives me the ability to maintain the orientation of the aircraft which will then not effect the orientation of the GPS. I do understand that this is not perfect as there is no compensation for the tilt of the aircraft but it will be drastically better than the results I am currently achieving.

  • Some settings in the RTKpost app. I have fiddled with the settings a little but have not got to a sound confirmation, if anyone has had joy with the settings for the PPK it would be greatly appreciated.

Look forward to getting some feedback.

Hi @donaldac87,

Regarding your questions:

  1. I believe there should be a possibility to correct the camera offset later while processing in photogrammetry software.

  2. We have a guide about analyzing logs from Reach in our docs. It might be useful for a better understanding of RTKLib.

Continuing the discussion from DJI M600 Reach M+ Intergrartion:

Hi @svetlana.nikolenko
Thanks alot for the response.

I have run a job with the RS+ and the M+.

We cant seem to get a good quality? We only get a Q 5 fix. I Have attached my RINEX Data

I am sure this is due to settings on the base and rover on the Emlid App. I cant seem to find a precises workflow for the RS+ and M+ on the web. Do you perhaps have an idea what the settings should be or where I can find the settings to use.

Cheers
Andrew
Base.zip (4.0 MB) Rover.zip (2.2 MB)

Hi Andrew, I have processed your two datasets in RTKLIB and the results seem fine (Q1 85.4 % and Q2 14.6%). I suspect it may be a setting in the RTKPOST ‘Options’ tab that is incorrect.

Hi Peter,

Greatly appreciate the help. I have set my RTK post the way the net is suggesting. Do you perhaps have screenshots of your settings or a link to the page that will give me the correct settings?

Cheers

Definately getting better with a couple of settings but still not great.!

The setting that is changing the result drastically is the “RINEX header position” but if this is selected I am not able to type in the co-ords of the base forcing it to a known point.

The quest continues.

Continuing the discussion from DJI M600 Reach M+ Intergrartion:

Ok I have been Able to process so that I get Q1 all round.

But what I have found is that my SNR is quite high. Not sure if there is any obvious reason for this.

Output Position Settings1 Settings2

Statistics

What is quite high?
According to normal RTK practice, SNR mask should be set to 40, but can be set to 35.

Thanks alot. The article i made reference to was indicating that the values are a bit high.

I am glad that this is not the issue. I will carry on fiddling with a couple of settings and so on to hopefully get the accuracies.

Thanks
Andrew

It seams I have found the issue.

When adding check points into P4D project my yx errors are looking ok (taking into consideration that my reciever is not vertically above the camera).

My z is out by -18m, I presume that this is due to an ellispoid/ geod shift.

Is there a way to change the export elevation?

Rather than changing export datum from RTKPOST, you can specify the appropriate input datum in Pix4D when you import your GCPs or camera positions.

Hi @donaldac87,

Could you clarify the coordinate system of the coordinates you entered manually instead of the RINEX header position?

Hi @svetlana.nikolenko

The co-ordinates are from the mine surveyors. Their co-ordinates in hartebeeshoek LO29.

I have tried using yxz as well as lats and longs?

Not sure if this is what you meant by the question?

Hey, It seems that the datum change in rtk lib did do the job

Hi @donaldac87,

Do I understand right that you’ve resolved the issue?

I just want to clarify that RTKLib supports WGS84 only. However, for some coordinate systems such as NAD83, RTKLib can calculate the positions in the coordinate system in which the base position is specified. In other cases, you need to convert the coordinates to WGS84.

Hi @svetlana.nikolenko,

No, unfortunately I am not winning.

I have converted the co-ordinates of the beacon (where the base is set up) to WGS84. Unfortunately I am not getting it right to force the base on to the position before starting the processing, thus i need to adjust the co-ordinates in excel.

Hi @donaldac87,

You can still post-process the data using the converted base coordinates. While post-processing in RTKLIB, on the step of selecting base coordinates source, choose the option “Lat/Long/Height (deg/m)” instead of “RINEX Header position” and enter them manually.

Hi @svetlana.nikolenko,

Ihave got a positive result tthanks. The deliminator i was using between degrees,min and sec was icorrect so the RTK lib software did not recognise.

Here is the P4D report for my results.HPGR PPK -200_report.pdf (244.5 KB) One or two of the check points are a little unsatisfactory but believe that is an error not related to the PPK but more due to overgrowth close to the markers.

thanks for all the guidance.

1 Like