DataFlash, No Log, Log lenght =0, Missing FMT Msg from log

Navio2 ROS (latest), Arducopter 3.5.2

Logging is not working well…

It could be no log, or log lenght = 0, or FMT MSG missing from log, or a good Log.

Latest try, DataFlash log erased,
BackEnd type = 1
Bitmask = 830
BufSize = 16

Small Try at home, log is OK
Small fly (4mn), FMT is missing from log…

Logging was OK with 3.4.6 but erratic since using 3.5.x

7mn flight and empty log:

Thanks for your help.


Okay, this is a tricky one. Did you get any “SD card faulty” messages during the flight?

I’m also interested in SD card class you’ve been using. ArduPilot has set a little higher constraints on DataFlash logging speed in the latest release which might in fact yield these kind of errors. We’ll be looking into this problem. Thank you for confirmation.

1 Like


It is a Verbatim 8GB class 10 card. I will backup and restore it on a 16GB Sandisk Ultra class 10.

Keep you in touch,



With SanDisk card, first log is OK then I have BadLogging msg and no registered log.



Same problem,

The logs file I have yields the same error,

Also, I’m not gererating logs files, I started and tested my unit a dozen or more times, yet only one log file was created.


May be a solution, I have to try it:

There is an option to close the log when disarming. More secure than closing by unplugging battery.

I activated it, but I have to fly (to much rain)


1 Like

If I might ask @mlebret , what other settings are you choosing, file, mavlink, file+ mavlink?

also, here is my SD card (sorry about the blur pic)


Sorry for the delay, I was moving my Navio2 from Hexa Gopro frame to a large Octocopter (QuadX) with Sony QX1.

Setting is file only.

Closing and saving log when disarming produced a valid file. I will fly later and feed back.


Thanks @mlebret, I found that deleting all the old logs corrected not generating a log file error, Kinda, Navio2 is generating log files, mission planner is still barking bad logging yet when I try to view the files I get an error no FMT messages in you log


I have no more problems with Log since I changed to “close log when disarming”.


Thanks for reporting. Where is that option?

Mission Planner:

Full parameter tree, Log entry.



1 Like

anyone know why I wouldn’t have this option?

Maybe with Mission planner update? I have version

I use Arducopter 3.5.2 (update from Emlid available)


@mlebret is the update available using the “update -upgrade” process?"


OK, I updated successfully

Thanks @george.staroselskiy and @mlebret for the help.

I am now at Arducopter V3.5 and Mission Planner V1.49.4 and successfully enabled “Stop logging to current file on disarm”

I’m still not logging and now apparently because of one or both of the updates, not logging causes the HEX to fail pre arm checks. Now I can’t even arm the copter, or even worse, fly the copter. BRICK!

Any Ideas???

Sorry for your logging problem.

You can uncheck “logging available” in mission planner Standard Params.


1 Like

What makes this “Tricky” and what steps would you suggest to fix this. Thanks!


Maybe a bit of solution:

Now, I managed to have logging OK by closing the log when disarming. Until last flight, the log is on the card but mission planner download an empty file…

So, I dig Linux doc, and search the forum to access Log directory on Navio card /var/APM/Logs

pi@navio:/var/APM/logs $ ls -l
total 19804
-rw-r–r-- 1 root root 2490368 Sep 21 12:51 00000008.BIN
-rw-r–r-- 1 root root 581632 Sep 21 12:53 00000009.BIN
-rw-r–r-- 1 root root 737280 Sep 21 12:54 00000010.BIN
-rw-r–r-- 1 root root 520192 Sep 21 12:56 00000011.BIN
-rw-r–r-- 1 root root 811008 Sep 21 12:58 00000012.BIN
-rw-r–r-- 1 root root 1753088 Sep 25 14:07 00000013.BIN
-rw-r–r-- 1 root root 321429 Apr 1 15:27 1.BIN
-rw-r–r-- 1 root root 103748 Apr 2 12:38 2.BIN
-rw-r–r-- 1 root root 1775897 Apr 5 12:26 3.BIN
-rw-r–r-- 1 root root 784163 Apr 8 13:26 4.BIN
-rw-r–r-- 1 root root 3379056 Apr 9 09:08 5.BIN
-rw-r–r-- 1 root root 4729122 Jan 12 1980 6.BIN
-rw-r–r-- 1 root root 2254040 Jun 1 15:34 7.BIN
-rw-r–r-- 1 root root 4 Sep 25 14:04 LASTLOG.TXT
pi@navio:/var/APM/logs $

A bit of sftp (transmit) on my mac and i got the log from the card.

Now Mission Planner “Review a Log” can read the imported log.

So where is the problem with Download DataFlash Log via Mavlink?

Dropbox Log import:

The relevant files are dated sep 21 to 25. (Octocopter).

Files dated sep 21 are fine with Download DataFlash

EDIT: Today download of log number 13 was fine… ?? Don’t ask ??