CSV file not recognized by RV3

Good day, sorry for barging in.

I have a similar issue. However in my case, the csv file it’s not recognized by the app. I don’t get to the next step, where the reachview app verifies if the information I created is correct.

I have an earlier project. I exported it directly from the reachwiew app into google drive, and it shows as a csv file but with a different icon than the one I want to upload to reachview. The one I try to upload (the unrecognizable file), shows as a green google sheets icon, but the csv that was exported to drive directly shows as a blue sheet icon. What would be the problem? What am I doing wrong?

I just tried something different. I exported the same csv project (the one that works) to my pc, and upload it to drive, and i doesn’t recognize it either, it becomes a green sheets icon. What can be happening?

Hi Sergio,

Welcome to the community forum!

Could you please share the screenshots of the differences between the files?

Thank you for your swift response. I just saw your message. My apologies.

I am new to all this GNSS stuff, I have no civil or topographic background whatsoever. I tried to find a solution to my problem using the forum but I haven’t seen the issue I have.

I am terrible at explaining myself. I just hope I can do this.

I am trying to stake out some points but I can’t figure how to import them to reachview 3.

Screenshot 1.- I open google drive from my pc and you can see the same file except by the “(1)”. The blue icon was exported to drive directly from reachview 3. The green icon showed in the same screenshot, shows the same file but it was downloaded to my pc and uploaded to drive.

Screenshot 2, Shows the blue icon opened preview.

Screenshot 3, Shows the green icon opened while the information is the same, however it’s displayed very different.

Screenshot 4, It’s a screenshot from the same google drive file as in the pc screenshot. I have only one file that reachview identifies.

Screenshot 5, It’s a notepad image with the information that I want to stake out before converting it to a csv file.

Screenshot 6, Shows the text file converted to csv.

Screenshot 7, Shows the file created on my pc.

Screenshot 8, Shows the file uploaded to google drive.

Screenshot 9, Shows the image from the phone, which I try to import to reachview.

I apologize if it is a very simple solution. I just can’t see what I am doing wrong.

screenshot 6

Hi @deraciao,

Thanks for such a detailed description!

Indeed, it looks quite strange. However, it’s hard to say why it goes that way for now. Could you please share these files with me? I’ll check them and write you back.

In case these files contain some sensitive info, you can send them to support@emlid.com.

I have resolved my problem for now. I just edited a file that works and replaced the information with the coordinates I want to stake out. It has worked, however, I still don’t know what the root of my problem is. Thank you very much for looking into this.

I am sharing the same file, one was imported directly from reachview and the other file imported to my pc and uploaded to google drive, and according to me, this file can’t be uploaded to my reachview app.

https://docs.google.com/spreadsheets/d/1FHweDs_1q0UlDky8PAfqmKWSd9GYJiYM3a3YW79GF54/edit?usp=sharing, https://drive.google.com/file/d/1RRHswPigXEYqMbZnJgulWbE7ccsjbDMI/view?usp=sharing

1 Like

Hi, @deraciao !

I performed the CSV import without any problems in ReachView 3.

I’ll send images of how the file turned out. I followed the instructions that Emlid gives about this, on the page for importing points for the survey.

Coordinate system: WGS 84, EPSG 4326

Name,Easting,Northing,Elevation,Description
1,-105.8087468,26.90433325,1804.11,Test 1
2,-105.8091879,26.90389215,1803.449,Test 2
3,-105.809491,26.9044521,1802.867,Test 3
4,-105.8092671,26.90457496,1802.609,Test 4
5,-105.8095429,26.90500609,1802.186,Test 5
6,-105.80978,26.90537401,1802.042,Test 6
7,-105.8095502,26.90563438,1801.732,Test 7
8,-105.8092534,26.90515547,1802.032,Test 8

Hi Sergio, just to make sure, how do you save the unrecognizable .csv file? Notably, there are a few different types available in Excel and I have seen students here saving their .csv in a different type (for example macintosh csv) that would not be recognised by some software.

That would be one explanation for your solution of copying your data in a working csv.

1 Like

Hi @deraciao,

Thanks for sharing these files with me. I’ll check them and write you back.

Thank you for the reply Gabriel.

The weird thing is that both files are the same file. The csv file was uploaded from reachview 3 directly to my google drive account. The other file was created by downloading the same csv file from google drive to my hard drive and re-uploaded to google drive. But this time reachview 3 doesn’t recognize it.

Hi @deraciao,

I checked the files that you shared. Both files are fine, and I successfully opened them in ReachView 3.

However, Google Drive may see the CSV file incorrectly if it was previously opened as an Excel. It may accidentally change the formatting, and ReachView 3 couldn’t import Excel files.

To download such a file in CVS format, please choose the option as shown on the screenshot:

Please check this way, and let me know if it works.

3 Likes

Some of my tests were made using that specific CSV format. What I am understanding is that google drive converts the CSV files into a different format. Are there other platforms I can use to import projects into RV3?

I just created a new CSV file. From Notepad to Excel. At first, I was not able to import it to RV3. The process was unsuccessful due to errors “in lines”. However, I saved the already created CSV file again, although this time I use “comma-delimited CSV”, and I did it. The file was imported swiflty to RV3.

I will not use google drive to import projects to RV3, for the moment.

Thank you for your help Pedro Augusto, I just found the solution to my problem. Apparently google drive is modifying the CSV file without even asking.

I will import the csv files directly to my phone.

2 Likes

Hi @deraciao,

Available sharing options differ for each phone and depend on apps installed on your device. This functionality is provided by the phone itself, not ReachView 3.

You can continue to use GoogleDrive. However, you just need to be careful and not to save/open files as Excel. As I said above, ReachView 3 doesn’t support importing Excel files.

1 Like

I ran some other tests. I created a new project using Excel. I saved it as a comma-delimited file.

I uploaded it to Google drive and it was not recognized, the same as before.

I uploaded it from my PC to Gmail, and save it to my phone. Imported the file to Reachview3 and the file was uploaded and showed me the points.

I still find it weird as to why Google Drive modifies the file, somehow.

My problem has been solved anyway. I will keep practicing this feature.

Thank you all, for yourr much appreciated help

1 Like

Hi @deraciao,

Glad to hear it works. I just wanted to add a comment.

We can’t say for sure why Google Disk identifies files in this way. In this case, the problem is mostly not related to ReachView 3 since it just can open CSV files only.

To prevent such issues in the future, I’d recommend you make sure that the file was not created, opened, or saved via Excel before uploading it to Google Disk.

1 Like

Thank you Elena, will do so. I will keep myself close to the forums to learn more.

1 Like