CSV export all messed up with special characters

Hello everyone!

I have tried some times to use special characters in the ReachView 3 description, but i’m always got issues when exporting. The file gets scrambled after the special character, not showing the said character and jumping lines in the CSV file.

Also it only shows the standart deviation after the description line with the special character, cutting out the coordinate and also the name and description.

The workaround is obviously deleting any special character and not using them after. If possible to correct this issue it will be amazing!

Follow an image and the CSV file.

Erico.zip (4.5 KB)

Looks allright here. Try changing letter coding or language during import and make sure you format import data for CSV. Right now you have all data imported without using function " text to coloum"

1 Like

I actually configured the csv file to always open in excel when executed.

If you grab this file i sent and open it as TXT you will see that the description is between “”.

Follow image below:

Correct !! Check the regional settings

Ok, I see.
Just simply not using special character would solve it but in your case it adds two enter stroke.

May i ask what your special character looks like?

It’s a double apostrophe, before and after the description.

I’m not generating these files, just receiving them. So i can’t see how they are inside the ReachView 3.

The issue is not deleting special characters, probably the smartphone that’s generating these files.

At the moment ReachView 3 doesn’t detect the native smartphones file manager so maybe the issue is when exporting CSV file via third party. I received this CSV via Whatsapp

Inside the ReachView 3 it’s normal. Follow image:

Just tested on my phone and it comes out just right. Might be issue with language or letter coding

1 Like

I see. So could be the smartphone whne generating theses files. I will be checking the configs inside the smartphone and in the notebook that was sent to me these files.

Thanks everyone for the help!

Hi Adriano,

Thanks for the report! We’ll look into that and try to reproduce.

We’ll also keep you posted on it.

1 Like

Ok Tatiana!

Probably is the smartphone configuration or maybe the Excel that’s changing theses configs in the transfer.

If you find anything of notice, let me know!

The smartphone used is a Motorola G7 Power with Android 10

Hi Adriano,

I’ve tried to reproduce your issue on an Android smartphone. I’ve exported a CSV file with points that descriptions contain " character. ReachView 3 output doesn’t have excess blank lines, and the file can be imported to Excel fine.

May I ask you to clarify if you are working with the latest ReachView 3 version?