Connecting RS3 to QField (ios)

Hi there,

I am trying to connect the RS3 rover to QField but I get the following error in QField: “Positioning device error: The connection was refused by the remote host”

I’ve found this thread already, I checked my settings and it hasn’t solved my issue: Connecting Emlid Reach to QField iOS

I have the following set up:
The Base is an RS2 device with the base output set to LoRa

The Rover is an RS3 device with the correction input set as LoRa.
Position streaming 1 is set to TCP server localhost:9001 NMEA. The NMEA settings are Talker ID: GN and Message type: all ticked at 1Hz as recommended in the link above.
Position streaming 2 is turned off.

In Qfield:
I added a new TCP (NMEA) connection.
The address that automatically appear there is (I’ve also tried typing “localhost”)
Port: 9001

I’d appreciate your help.


Hi Roberto,

Welcome to our community!

When you add the TCP connection in QField, the address should be the rover’s IP address. It can be seen on Emlid Flow’s opening screen under the receiver’s name. For example:


Let’s check if you can set up the connection using this address.

Thanks Kernel, this solves the issue.

Also to help other users, we need to make sure we connect to the rover via the phone’s WiFi settings before attempting to connect with QField. I was trying while it was connected through Bluetooth and it didn’t work of course.

Now that I have you here, what is position streaming 2 for? Can I keep it off?

Hi Roberto,

Thanks for the update!

Bluetooth connection for such workflows indeed works only for Android and Windows devices. But I’m glad to hear that it’s working fine for you via TCP.

Position streaming 2 is only an option to set another output if needed. In your case, let’s leave it as Off.