Connecting Reach to Internet to upgrade from 2.14 to 2.18

Good afternoon,

Since I first bought my 2 Reach RS units in June 2017 I’ve never been able to connect them to the internet to be able to perform upgrades.

I’ve tried 6 different devices so far - 2 x MacBooks, an iPad, 2 x iPhones and an Android pad.

I’ve had to send the units to an agent to get them reflashed and that got them working but it was just before 2.16 came out with the new stake out mode etc.

And so I am trying to connect these units to the internet to upgrade them — stuffed if I know what I am doing wrong as I have followed every instruction I can find and yet…

This is the screen I get to on every device.

If someone could free me of this frustration I would be most grateful.



Thanks for your help,


Simply connect your device to that same network as reach just connected to and use fing app to get the ip address reach now has ,input that address into your browser then you should be set . Good Luck

Thanks Dave,

I’ve done this and gone through 3 devices so far with no progress unfortunately.

I think I need more luck :wink:

3 devices to go!

Thanks again,


Do you see reach as a device on that network list?

Thanks David - I tried the address to no avail - I’ll keep trying other devices

You have to connect your hand held deviceto that TP Link wifi in your settings - wifi , you are still connected to reach wifi.

Thanks Dave,

I’ve already been through all of the devices using the TPLink wifi.

Dmitriy has advised me to use a mobile hotspot instead with a simpler name.

Doing that now on the android pad.

Can you show that fing list when your connected to tp-link network

Also is the blue light on the unit slowly flashing? or solid?

Solid light which is curious

That means its still in hotspot mode, it didnt connect to the network

And so what should I do then?

You will notice when you press to connect to a network the blue will flash rapidly (searching for networks), if it connects it will blink slowly (connected) , and if it goes back to solid (hotspot) connect to reach hotspot again and try again , check if password is correct.

1 Like


Yes went straight from rapid flash to solid straight away - I’m assuming you mean the wifi password?


I got the same issue with my units , they don’t want to connect to our network for some reason but to a mobile hotspot, no problem :disappointed_relieved:

Yeah - unfortunately my android unit won’t connect to my (iphone) hotspot.

With the security type which should I select?

WPA Enterprise

The iphone hotspot is listed as ‘WPA Personal’

should work but try the open one see if it will connect

It should look like this once you have the unit and your device on the same network

Progress in the sense that I was able to connect to my sons iPhone this time - the blue light has a slow flash

1 Like