Connect Mission Planner

I asked this almost five times on the forum. But, I never got apparent answer.

Please, I want some apparent answers.

This is what I got so far.

1. connect to my home network (local network).

2. do not need any screen monitor anymore because I can access to Navio 2 OS on MacOS Terminal wirelessly.

3. I do not have any radio or RC receiver as telemetry receiver. (I have asked before for do I need one, and the answer was No. So I did not buy it.)

4. When I tried to connect Mission Planner, it asked that is this Linux board, Bebpo2, and Disco. I think this Navio 2 is Linux board but this is obviously not bebpo 2 or disco. So how can I connect it?

And now I have very serious problem as cannot connect to Mission Planner…

I do not want to say this. If it doesn’t work I will return back to Emlid. And I think they need to describe some materials user might need for newbies like me. I never got an apparent answer before. I am sorry.

Make sure Arducopter is running on your Raspberry pi with emlidtool and that it is sending telemetry to your GCS computers address via udp. ( sudo nano /etc/default/arducopter )

Open Missionplanner select “UDP” in the upper right dropdown (there should be “TCP” selected by default).
Click on connect and if you did not change the port in /etc/default/arducopter, 14550 should be right.
Now it should be connected and collect all the parameters. After it has all parameters, you can start to setup and tune your copter.

Alright thank you.

  1. I am much way far from that just turning on arducopter or pilot. That was just on the beiggining page.

  2. I will try that.

But you know I do not have Radio telemetry. Right?

My instructions above are meant for a connection over network. Be it wired or wifi.
You said you can connect to the Raspberry Pi via ssh, so if you configured arducopters telemetry options right, it should work.

1 Like

So is it mean instruction for connecting Navio 2 to mission planner.

What do you mean by “Click on connect and if you did not change the port in /etc/default/arducopter, 14550 should be right.”?

Sorry my fault. I shortened the instructions a bit.
14550 is the default udp port arducopter uses. If you click connect in Missionplanner, a dialogbox comes up, where you can enter the port. 14550 should already be entered there.

Why do you not just follow the instructions and see what happens?

because we already followed or tried all of the instructions. And my mom is getting angry about this. Her major is computer science. Also, why don’t you want to update that document. Some of the commands do not work. Even says “Not found 404” when I tried to download what is on the docs. Also, I was worrying about that RC Radio telemetry. Because it just did not work.

Still, it does not work.

You did everything I wrote above? What does not work?

I will try it again. But, that is why my mom is getting angry. Also, my mom wants to know that is there anyway to operate Mission Planner on Mac OS? if It is please let us know in detail.

What GCS are you using now? You wrote Missionplanner all the time?!

Yeah Mission Planner, and we do not have any radio telemetry.

You do not need telemetry radios! Network/wifi will work too.
Why do you want to run Missionplanner on MacOS if you have it running already elsewhere?

Why do you not answer my questions? You want specific answers, but do not provide any information what exactly does not work.

My mom said her windows laptop is weird so it does not work…

We tried it for whole week.

You can use Qgroundcontrol on Mac OS. Getting Missionplanner to run on Mac OS is not straightforward. Qgroundcontrol will pickup an incoming UDP telemetry stream on port 14550 automatically

http://qgroundcontrol.com/downloads/

Oh yeah of course, I tried it. But, I think that map system is slightly having a problem. Do you know that represent bar? |___________| 100m? That is not correct. I compared with Google Maps. I think it is more closer than Google Maps.