Cellular Data Service for RS2 built in modem for NTRIP Connection (in US)

I am based in Chicago area and tried using several different sim cards on the RS2. The only one that activated mobile data on the device was T-Mobile (voice+data card). With the other cards it reads the them and shows the cell bars on the top of the screen, but it would not allow to turn the mobile data on. I tried using APN but that didn’t help. I tested this with Verison (data card), Sprint (voice+data card) and a hologram.io data sim card (auto switching carriers). Don’t have an AT&T card to try.

I’ll add that I had an old TracFone SIM lying around (AT&T service version) and I purchased some data for that and it activated fine on the RS2. This was in Vermont.

I have used a t-mobile and a google FI card and both worked and are GSM sims vs. CDMA sims- One thing I did notice that can effect some people is that the reach app acts like a word processor and begins the line with a capitol letter and some apn’s will not work unless correct so you have to enter the first letter than backspace to enter the first letter as a non capitol.

Any update on mobile data for Verizon in reachview app?

Just tried my sim card in the RS2, the cell bars show up, but the mobile data will not turn on.

Hi there,

As far as I know Verizon uses CDMA, it won’t work with RS2 cellular modem. By the way CDMA will be soon wiped out so I’d recommend checking for other providers anyway

Thank you for the information. I figured it was something like that.

So I now recieved an AT&T sim card and have it installed and mobile data connected. However, I cannot connect to the NTRIP caster. I can connect the NTRIP through a wireless network to get corrections, but when I turn mobile data on, it won’t connect.
Any thoughts?

Thank you for the help and being patient with me.

It’s interesting, I also can’t connect to this caster. Could you check with them if they are online? Perhaps, they can also provide alternative IP address to connect to.

I tried the different IP address that they provided me to no avail.
If I turn mobile data off, and connect to a wireless network, I can connect to the caster as shown below:

Ah I see, thanks! In this case please send us simple system report (you can get it from settings) from the unit with SIM card installed and activated. This is to check whether RS2 actually gets Internet access.

Simple system report
app version: 2.20.7-rs2-rc0-r0
'wifi_status, interface: wlan0':
- wifi_mode: ap
- access_point:
    band: bg
    channel: 1
    password: null
  ip: 192.168.42.1
  is_added: true
  is_connected: true
  mac_address: 6C:21:A2:92:7B:26
  security: wpa-psk
  ssid: reach:46:AE
  uuid: a8d2d9f5-b9ba-4707-aad4-b44efd865dea
base mode:
  base coordinates:
    accumulation: '2'
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    coordinates:
    - '0'
    - '0'
    - '0'
    format: llh
    mode: single-and-hold
  output:
    enabled: true
    format: rtcm3
    path: tcpsvr://:9000#rtcm3
    type: tcpsvr
  rtcm3 messages:
    '1006':
      enabled: true
      frequency: '0.1'
    '1074':
      enabled: true
      frequency: '1'
    '1084':
      enabled: true
      frequency: '1'
    '1094':
      enabled: false
      frequency: '1'
    '1124':
      enabled: false
      frequency: '1'
bluetooth:
  discoverable: false
  enabled: false
  pin: '***'
correction input:
  input2:
    enabled: true
    format: rtcm3
    path: fgls/brfrierm:***@wiscors.dot.wi.gov:2101/RTCM3Net
    send position to base: single
    type: ntripcli
  input3:
    enabled: false
    format: rtcm3
    path: :9028
    type: tcpsvr
logging:
  base:
    format: RTCM3
    started: true
    version: null
  correction:
    format: RTCM3
    started: true
    version: null
  interval: 24
  overwrite: true
  raw:
    format: UBX
    started: true
    version: null
  solution:
    format: LLH
    started: true
    version: null
lora:
  air rate: 2.6000000000000001
  frequency: 868000
  output power: 20
position output:
  output1:
    enabled: true
    format: nmea
    path: bluetooth
    type: bluetooth
  output2:
    enabled: true
    format: llh
    path: :9001
    type: tcpsvr
  output3:
    enabled: true
    format: llh
    path: :2014
    type: tcpsvr
  output4:
    enabled: true
    format: llh_ext
    path: :2015
    type: tcpsvr
rtk settings:
  elevation mask angle: '15'
  glonass ar mode: 'off'
  gps ar mode: fix-and-hold
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: kinematic
  positioning systems:
    compass: false
    galileo: false
    glonass: true
    gps: true
    qzss: false
  snr mask: '35'
  update rate: '5'

Hi @Brfrierm,

Have you already tried entering the IP address instead of domain name?
May I ask you to send me the Full System report in PM as well?

Hi @Brfrierm,

Thanks for sharing the report!

Have you tried to enter APN in the Mobile data tab?

1 Like

I have entered an APN, I’m not sure it is the correct one though. Hopefully today I will be able to figure out if it is the correct one.

Hi @Brfrierm,

Please keep us posted regarding your tests with APN.

I had a couple of Reach RS2 units I could not connect to Telstra’s mobile network with the internal SIM slot. Thanks to Emlid support I learned to input the APN.

For me to connect to Telstra’s mobile network in Australia, I found the following worked really well as an APN value: telstra.iph

Can someone correct me if I am wrong but as of current you cannot use a Verizon sim card in the RS2? I tried today and even used the apn without caps but it will not allow me to turn on the mobile data, it thinks about if for a few minutes then doesn’t turn on. @tatiana.andreeva is there a reason that the sim card reader is only 2/3g and not 4g or even 4/5g? will there ever be any functionally for verizon sim cards? We are very limited with our cellphone signal here in montana.

1 Like

In APN you must enter your cell phone provider for data. In my case it is data.personal.com.ar

Hi Matthew,

If it’s GSM SIM Card from Verizon, then it should work.

In case it’s CDMA, it won’t work. Moreover, as far as I know, Verizon is wiping out its CDMA network, it will be deprecated by the end of 2019.

Leaving this here as a reference for others. I’m in the US; I went with AT&T service. Our IT person ordered service and provided AT&T with the IMEI number and device description. I installed the SIM card, powered up the RS2, set the APN value to ‘broadband’ and turned wireless data on. Worked great!
Also, I noticed the IMEI number is also visible at the bottom of the wireless data setup screen, I used that to confirm that I had the right SIM card in the right RS2 device by matching up the IMEI number I gave AT&T with the IMEI number on that setup screen.
Data seems to be working great so far.

Thank you for the information Ryan. I’ve been trying to find the right APN. I entered the one you suggested and it connects and shows 3G, however I still can’t get any data through the receiver. I can’t connect to the NTRIP or the hotspot to the internet. I have been trying to get this going to no avail.