Can't get NTRIP to give corrections

Dear Sir,
I can’t get the stationary antena to give me corrected coordinates. It jumps up and down
several meters so I know it is not recieving corrections. I am including several screen
shots . Please tell me what I am doing wrong.
Thank You

You need to use NTRIP client option in this case and specify mountpoint.

1 Like

@igor.vereninov Hi Igor, can you help me figure out how to connect to NTRIP service? I’m sure I set things up correctly, even reach connected to wifi and set NMEA GPGGA to single, but didnt get any gray bars. swipos said that i have successfully logged in but their system didnt receive my coordinates.Please let me know if you can get correction data using following info…

port: 2101
u: T9991
p: xxxxx

Thank you.


Do you have an NTRIP or network option in this drop down? I do not recall of the top of my head as my setup is out in the field.

There is a location where you can select NTRIP, and then input the values you have to connect to the network. Once connected, it is slick. Use it quite frequently.


Yeah I’ve entered the required NTRIP info under the dropdown.


And? No go?

@timvand no go. swipos said i logged in but they didnt receive my coords.

Thank You Tim V,
A screenshot is just what I’ve been wanting to see all along. I changed the settings per the attached shots but I still can’t get it to work.

Thank you for that piece of information. I double checked the info I put in the “Input source for base corrections”.
I know the user and password are correct and I suppose that “” means Ip and port. Unfortunately it is still not working.
I have included screenshots for your review. If you could post the screenshots for all the settings which would include the setting boxes that are to be changed and the setting boxes that are not to be changed that would be greatly appreciated.
Thank You

@keepclicking Please try setting “Transmit NMEA GPGGA to base station” to “single” because your NTRIP provider might require that.

I was not able to connect to NTRIP using your data with Reach or with RTKNAVI. Even though the connection is present the data with corrections never comes back. I am not sure what the problem is… We have tested reach with other NTRIP services without any issues so far.

I am not sure how to help you without some additional information.


Still the same thing it doesn’t work.

@igor.vereninov Igor, thanks for testing the NTRIP to confirm no corrections are coming back. What additional info could I get you to get things working?

1 Like

I still can’t get the NTRIP to work. I bought another receiver for a base station. That works well in the back yard but as soon as I get to the street with the rover and the cell phone hotspot the base reach loses the network connection and the correction link is gone. I need to use these receivers to survey the land. Please advise.
Thank You

Well, your easiest and free option is to log the data from base and rover, then post-process.

Either that, or:

  • buy a wireless repeater/extender
  • get a second cell phone hotspot for the base
  • buy a pair of radios, such as RFD900 or 3DR
1 Like

RTKLIB has a built-in NTRIP explorer. You can try it to check whether the base station is accessible.

@igor.vereninov @egor.fedorov I have found information that may solve our NTRIP problem. When I talked to swipos today, they said that they were able to receive my single position coords, but satellite count was missing. They said that once satellite count is received, GNSS corrections will be sent. This may be the problem for me and the other guy. Can you guys look into this? I have provided my swipos login to Igor.

Do they have a specific NMEA message required?

@igor.vereninov @egor.fedorov I think its best if you guys can contact George directly to verify the NMEA format and any additional information at +41 58 469 01 21 or

They respond better to calls.

I cannot post process because I cannot get the receivers to cooperate. I try everything to download a file and " Your download will begin shortly" is all I get. I already have the other receiver downloaded but those files are no good to me. So now I have ordered RFD900 radios and get my field work done if I can make them work. I will try later to make NTRIP work because I like that feature.