Can't connect to the Internet using a SIM card

I updated to v2.23.6 dev and it didn’t fix the SIM card connection issue. I’m still waiting on a resolution to the problem. Like you, I can connect to the office wifi but not to the internet in the field. I have tried the SIM card and hotspots on two different carriers. All are known to be good and working on other devices.

1 Like

Hi John,

Please contact us on support@emlid.com with a Full System report from the device

Thanks Tatiana,

Full System report has been sent.

Hi John,

I received your report. I’ll examine it and write you back as soon as possible.

Hi John,

Could you clarify whether your SIM-card supports 3G and GSM?

It is AT&T GSM 3G

Hi John,

May I ask you to try entering APN? Your provider requires this info for the Internet connection in some cases.

Also, could you please provide me with a Correction input tab screenshot?

I have sent an email with the screenshot. The correct APN is “broadband” and it recognizes it. The RS2 is not working like it has been, but rather it is doing some strange things when the SIM card is installed or when I’m trying to conect to a hotspot. It seems to work normally on the office wifi which is really confusing.

Edit to add:No sooner than I send you the last email and it quits working on the office wifi too. It will connect to the wifi but not connect to the Reach View app. The only way I can connect the Reach View app is to do so on the RS2 hotspot. Of course, then I don’t have any access to the internet for correction.

So, to be clear, it will not connect to any of the hotspots I have tried. It will connect to the office wifi but not to the Reach View app while on the wifi. It will only connect to the Reach View app when using the RS2 hotspot. It will display 1 bar when the SIM card is installed, but it will not connect to the internet or show the actual signal strength with multiple bars, even though the signal strength is showing multiple bars on a cell phone.

Hi John,

Did I get correctly that the device doesn’t even appear in the device list?

Could you PM me with a new Full system report so that I can check the issue with the Wi-Fi connection as well?

Hi John,

Thanks for the report! I’ll examine it and get back to you.

I’m not trying to be a “smart ***”, I thought I had a problem with my sim card ATT in another device. I checked all settings, re-installed twice, even rebooted device to default settings. I even thought there was some kind of conspericy with ATT trying to convert me and others to 5G.

Guess what… the bill hadn’t been paid ! I had my credit card hacked back in January and got a new card. The monthly bill was set on auto draft for the old card and I hadn’t updated my new card to ATT. I can say one thing good about ATT, they waived the reconnect fee.

Sometimes you can’t see the forest for the trees.

1 Like

Hi John,

According to the Wi-Fi connection log, Reach is successfully connected to your Wi-Fi network. Do you use the Android or iOS app?

I do use the iOS app and it does connect via my office wifi or via the RS2 hotspot.

What isn’t working is RS2 won’t connect to my Verizon hotspot or my AT&T SIM card. Therefore, I can’t connect to the internet in the field to use NTRIP for correction.

It was working just fine with my Verizon hotspot, and in fact was working on the day that this problem developed. The SIM card has never worked for internet data, and I have tried multiple SIM cards.

There aren’t any forests out here in my part of Texas !!

The bill has been paid and the card according to AT&T is good and working like it should.

1 Like

Today my RS2 appears to connect to the office WiFi but I can’t connect Reach to it on the same network. It doesn’t appear in the device list. This is an additional change as it has been working fine on the office WiFi.

I can connect Reach to the RS2 via the hotspot mode. I tried to force it to connect to the WiFi and I got the steady blue light, but still can’t connect the Reach app to to the RS2 via the same WiFi.

I cancelled and returned my SIM card since in three months it had not once worked. I have reset to the default settings and turned off the Base mode button. Also, I “forgot” all of the networks previously used except for the office WiFi.

Is there a way I can reinstall the software on the RS2 to see if that helps?

A post was split to a new topic: Can’t configure RTK link between base and rover

RS2 magically started working again after I cleared all of the known networks and re-entered the login info for them. However, I purchased another SIM card and tried it to no avail. It will not connect to the internet via the SIM card. It does however show 3G and one bar when the card is installed. It shows one bar when I’m in a 5 bar area and it will work with the hotspot on an AT&T phone using the same SIM card. I have entered the APN and tried multiple ones, all with the same result.

Are there others using an AT&T SIM card that could comment on what is working for them? I may simply be overlooking something that needs to be corrected.

Thankfully, I got it solved. I needed to go online and enter my IMEI number with AT&T, then reboot. The IMEI number for the device is displayed at the bottom of the Mobile Data screen and I registered it with AT&T along with the ICCID of my SIM card. It was easy and quick as soon as I figured out what to do.

1 Like

Hi John,

Thanks for keeping me updated.

Did I get correctly that you have no issues with the second SIM-card as well? Does it provide an Internet access?

Could you also clarify whether you can access the Reach via Wi-Fi and hotspot?

Yes, after I registered the IMEI code with AT&T it began working and is providing internet access via the hotspot mode to my other devices. I can connect Reach to the RS2 via hotspot mode and also via Wifi as I could before. I think I had two issues, first was not having the SIM card registered with the IMEI code, and the second was some issue with the Wifi logins that went away when I erased them and re-entered them. At this point everything is working correctly for the first time since I have owned the RS2. I used it again yesterday and it is working really well and is achieving a FIX via NTRIP in only a minute or two. I’m now quite pleased with it.

Thanks for the follow-up.

2 Likes