Can´t get fix - please help

Hello! If have tested reach but i can´t get fix.

my reach network:

Base is on the roof of my house - connected to dsl router with wifi - send Output path for corrections over tcpsvr (ping is 20ms)

server: now 5 km away on a fixed position - connected to dsl router with wifi - gets corrections over internet.

gets float after 10 seconds - but no fix.

i have testet several things but i cant find a way to get fix!! thanks for help

There’s a second setting for GPS/Glonass 5Hz lower down on the rover page. Right now it is on GPS 10Hz. Maybe set that to match the others.

You seem to have enough GPS satellites for a GPS-only fix. So you could change over to GPS only, and yet another thing is to switch to 1Hz. Then if you get your fix, start switching settings back one at a time until you’re back to what you have now.

I’m actually in a similar situation :frowning: but the base and rover are only about 20ft apart. Both base and rover have tallysman 3710 antennas and the entire setup was in FIX last weekend with heavy clouds.

Then today nothing but float, with clear skies. I tried the working setup for about 45 minutes and then decided to go the 5hz GPS + GLONASS thinkng maybe even more satellites would help. Tried that for about 1.5 hours and nothing but float.

So there are a few things I would like to see:

  1. Guides for GPS and GLONASS recommended setup. The Reach docs don’t cover much on this. I’ve been digging through forums and when trying the GLONASS there are all types of setting ppl say that work but none of the settings agree. I actually don’t know what is the best way to setup RTK with GLONASS.
  2. Maybe a crash course on troubleshooting by using logs. I’ll admit, I’m new and learning about GNSS but really don’t want to be another poster, “Heres my logs, please tell me what is wrong” vs learning how to investigate. Empirically I’m noticing an uptick of similar situations for getting float but never reaching FIX.

Currently this is how I feel after having a setup that has worked pretty well for the last few weeks to watching a laptop for about 3 hours waiting for float to go to FIX.

I feel the frustration. There was a ReachView update yesterday. I’ll update my units and try a test and see how I do.

To add to the wishlist, I’d like to have a way to visualize what RTKLIB is doing in real time (e.g. showing the Kalman filter doing it’s thing). Not all the time, just for debugging and to help us understand what is going on ‘under the hood.’

ok now i go back.

base and rovers are connected to samy wifi connected over tcpsvr und tcpclt…

i will test…

i have all switched back to gps 1hz (base, rover and advanced settings)…

@igor.vereninov Is there a formal method to submitting features requests for the Reach, other than PRs :smiley:

i give up!! no solution… maybe start with reflashing firmware… will there an update ?

Not a firmware update that I know of, but a ReachView update. Last night I too updates to I thinking v.44. It had all 4s lol

can i use the update button on internet interface of reach? (edison setup)?

@mr337 @Andreas_Ortner If you could upload RINEX log files( both rov_ and ref_) I could try to debug what the issue might be. Which version are you on?

I will as well document the steps of debugging.

If you would like to start from the beginning, here are the docs for reflashing.

You can start a new topic with the suggestion :slight_smile:

i start from beginning / then i will try again and send you the data!

after a fresh install my files for debugging. one times i got a fix for seconds that was all…!

first is gps only with 1hz
second is gps_glonass with 1hz
no fix also with 5hz …

gps 1hz (647.5 KB) (1.4 MB)

gpsglo1hz (3.7 MB) (7.0 MB)


I have the same problem. Last time it gave me fix all day. Today after a short time of float I get a fix for maybe 10 seconds and then back to float and never another fix. I tried all types of settings just like you and nothing works. I am using RFD 900 radios and getting good signal but no fix. These tests are in the backyard at very close range. I didn’t see anyone using radios so I can say that this problem is also there when using radios.

I think the solution may be found in advanced settings…
Corrections, emphasis, integer ambiguity resolution…

When i play with this settings some things change…

I’ve been weary of going into the advanced settings without fulling knowing. I do know that you might want to keep the ambiguity resolution set to its default. There was another post who set that to 1 and had RTKFix that was showing wrong coords and fluctuating very heavily. Another poster in that thread said for live RTK they can only do 1-1.5. I only run that with 3 to get the accuracy I need.

At the moment I have fix with this:

Apply earth tides corrections

Ionosphere corrections

Troposphere corrections
Type off satellite ephemeris


GPS integer ambiguity resolution mode

GLONASS integer ambiguity resolution mode

Integer ambiguity validation threshold

Minimum lock count to fix integer ambiguity

I should clear my logs more often so I know which logs belong to what. I narrowed it down to these, first set should be GPS only and 2nd set should be GPS + GLONASS. (720.0 KB) (4.1 MB) (2.3 MB) (1.4 MB)

I tried to move over to GPS only and still got nothing.

Update: The above issue I’m going to chalk up as bad config.

I’m not sure how relevant this is, but I said I’d try a test, so here is what I found:

For the past few days, I’ve been testing RTK with the latest ReachView (0.4.5) under an obstructed sky:

  • ~80% sky view for base (north 20% blocked by trees)
  • ~45% sky view for rover (north 55% blocked by building)
  • 15m distance apart

Because of the poor sky condition, take this with grain of salt. :wink: I was able to get a fix for a very short time, but nothing lengthly. The details:

Some testing I did was with Reach sending over TCP to let `RTKNAVI.exe` do the processing and `RTKPLOT.exe` do the plotting. In `RTKNAVI.exe`, I could watch the 'ambiguity ratio' live. When a satellite appears or dissapears or slips above or below the minimum SNR value, I notice it **resets the ambiguity ratio back to 1.0** and that is a major setback in the quest for a fix, as it must reach 3.0 (default) for a fix. I watched this happen repeatedly, over and over under these conditions. Understand that this is not ReachView doing this, it is RTKLIB, and I know ReachView uses modified RTKLIB binaries so this particular quirk may or may not be _is not_ present when ReachView is handling the processing.

Another thing I noticed with both ReachView and RTKNAVI.exe is a stalling effect where there is no output for 1 to 30 seconds, and then it continues. I thought it might be network latency, so I switched things up and was able to get the age down to 0 or 0.1 seconds, and it still had stalling problems. I don’t know why. My setup: I had the rover connected with ethernet over USB and the base was connected to a wireless router 3m away and that is wired to my computer. In the RTKNAVI.exe window, I can see the base and rover input icons stay bright green when it stalls and the processing(?) icon goes dark.

Another thing I noticed in the RTKPLOT.exe window a couple of times was a very stable float with an extremely tight grouping (only about 20mm) for several minutes, but with the ambiguity ratio hovering at 2.0 it was to low to become a fix.

In this testing with an obstructed sky, the best of my poor results were obtained with GPS and SBAS only, 14Hz (but I don’t think frequency mattered here) and picking a minimum SNR that would allow at least 5 or 6 satellites to be used in the processing.

I was really hoping to get a decent RTK fix this way, but it appears I will be off to find more open sky to achieve that.

Spent about 8 hours outside messing with the Reach in 94F weather, currently burnt to a crisp and sad :(.

On the rover reverted back to the original RTK settings and plugged in only ERB output to Navio2, base corrections, and tcp output port, so I can pipe into RTK plot.

GPS Setup:
Was able to get fix for about ~30 minutes, then dropped to FLOAT and stayed. Everything is vanilla as mentioned above. I think I have enough good satellites to get a FIX but no luck. This is the most frustrating as I don’t know why or what to do next.

Attempted to see if I had better luck with GPS+GLONASS. I was never able to get a fix. Strong conclusion I might not know what I’m doing or how to tweak the settings for GPS+GLONASS. Would welcome official settings from Emlid on how to setup GPS+GLONASS ;D

Base rover was sending GPS+GLONASS_1Hz, rover has base settings matches, and was set to GPS_GLONASS_5Hz. GLONASS should have been sent as seeing RXX satellites come in. There is some mention that GPS+GLONASS should help with faster and strong rtk FIX, is that true?

Here are pictures of the site which I think was a perfect day fro rtk FIX: