Emlid

Community Forum

Can´t connect to WiFi


(G Naveiras) #1

Hi there
I have recently acquired a Raspberry Pi 3 B and a Navio 2 hat. I have been following the steps at the Emlid Docs and modified the wpa_supplicant.conf file as it is said there:

network={
ssid=“myssid”
psk=“mypassword”
key_mgmt=WPA-PSK
}

But I am not able to connect anyway. It´s not a hardware problem as I tried the same RPI3 and the same microSD with normal version of raspbian (with it´s wonderful GUI not just a naked console) and it worked perfectly.
I have some doubts about the supplicant file maybe someone can help me with:

  • SSID is the name of the network that appears when you look for it on a device or it is the one that figures at modems back?
  • In my modem says WPA2-PSK instead of just WPA-PSK, should I writte it like in the modem?
  • Should I change “country” from GB to ES? (as I am in Spain)
  • Is there any easy way to install a GUI for this navio raspbian version?

Any help?


(Andrew Yushkevich) #3

Hi @g.naveiras,

Did you manage to connect your Navio2 to WiFi?

Yes, you need to type network name which you see on the device.

WPA-PSK, in that case, includes WPA2-PSK, so you don’t need to change it

It’s not necessary to change it, you can leave it as is.

This is not an easy task, but you can check the forum, this question was previously discussed.


(G Naveiras) #4

Hi
Yes I managed to connect to wifi. In fact I did it by two different ways, none of them with this wpa_supplicant.conf file. One of them I just installed the GUI (using the information of the same thread you send me) and connected to the wifi, like in any other mobile device. Other way was trough the raspi-config menu. Both of them were just very easy.
Thank you very much for your answer anyway!


(Andrew Yushkevich) #5

Glad to hear you’ve resolved the question, @g.naveiras
Thank you for sharing your solution!


(system) closed #7

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.