Can connect phone to reach wifi, but RS2 unit not listed in the app

I can see and connect to reach in the wifi settings of my phone:

But when I start the app (Reach View 3), the unit is not listed:

Wifi symbol in the unit keeps white.
How to solve this problem?

Hi Agustin,

Can you please check the behavior on the latest ReachView 3 7.5 update? Let me know if the receiver is still not found then.

Depending on your settings, the update can be already installed or you will need to update it manually.

1 Like

I thought i was the only one with this problem . My receivers both have the latest stable and Dev versions

1 Like

Hi everyone.
Thanks to the new update of RV3 7.5

Many thanks to Emlid


1 Like

Hi Mon,

Thanks for sharing the update! Good to know the access is quick and easy now :slight_smile:

Hi David,

Let’s look into it closely.

Can you connect to the receivers via the Reach Panel? For that, use their IPs to enter them in the address bar of your Internet browser. In case you use Reach’s hotspot, the IP address is

works every time

1 Like

Hi Polina,

Jumping in here as well as I’m experiencing similar issues.

For reference, I was on a archaeology project back in October with the same phone and devices (two Reach RS+) and used everything successfully for a month.

I’m back in Greece at the project and and trying to test things out, etc, and am experiencing the same issue where I can connect to the Reach RS+ wifi, but cannot find any receivers in ReachView 3.

I can access the panel via

This behaviour stays the same whether mobile data is on or off.

My phone is a Samsung Galaxy S20 FE. As I mentioned, same phone in October, but I believe android had one update since then.

ReachView 3 on phone is version 7.5. I tried uninstalling and reinstalling to no avail.

This is all on the Base.

I managed to connect to the Rover for a bit, and turned on its wifi to hotspot to update the firmware. That seemed to hang, and now it’s stuck in wifi mode and I can’t access it either via my local hotspot.

Any help is much appreciate as we have a lot of measuring to get done!

Hi David,

Do I get it right that the same issue is present both with Reach on 28.4 and 29 beta 3?

Have you checked the connection to any other phone, just to eliminate the phone’s issue?

Hi Myles,

Welcome to the forum!

Can you please specify what firmware you have installed on your Reach devices?

You can check out the IP address of the Reach device in your network by running a network scanning app, like Fing.

1 Like

Hi Polina,

Both units are currently at firmware 27.1

Yes on both version. I only have this tablet

Further, it seems a colleague can use ReachView 3 no problem. Galaxy A12, Android version 11.

So the difference in phones seems to be my S20 FE is running Android version 12.

Regarding WiFi connection settings, the only different is security. My phone is utilizing WPA/WPA2-Personal and shows network speed of 58 Mbps while colleagues’ shows WPA2 PSK with network speed of 65 Mbps.

I’d hazard to guess that this suggests there is something going on in changes applied in Android 12 given this is the one change in my setup that has occurred since last October (my phone only updated to 12 a couple months ago).

I have similar connection problems with both my RS+ and M+. My phone is a Samsung S21 ultra and I am using reach view 3 version 7.5. Turning network data on or off does not seem to have an effect on this behavior.

Often, when I try to connect to a unit it will not show up in the list of available receivers, even though I am connected to the receiver’s wifi hotspot. I can get connected eventually by hitting refresh, or closing and re-opening the app several times (often 10 or so times). If that doesn’t seem to be working, I will disconnect from wifi, close the app, re-connect to the wifi hotspot and then it will work. If that fails, a phone re-boot always seems to work. I generally have to go through this process 2-3 times in a day of data collection. I have not had trouble connecting to the receiver via reach panel when I am connected to the wifi hotspot, but I have not tried to do so very often.

I use stop and go in RV3 and also have an issue where the app looses connection with the receiver and I have to re-connect to the receiver before almost every point. Most of the time, the receiver can be found in the receiver menu, so this is just a few clicks to get re-connected. The issue of not being able to find the receiver (previous paragraph) is a much more time-consuming problem.

In general, the receivers have done what I needed them to, but it would be awesome to have these connection issues resolved.


Same problems here, just took the RS2 out of the box this morning! Pretty straightforward instructions aren’t yielding a connection between the RS2 and Reachview 3.

Once the wifi connection occurs to my local network, I am no longer able to connect to the RS2. I can’t see it in the menu of devices to connect to. I have tried most everything in this thread and have an email to support. Hoping we can connect!

Hi David,

I got you! We’ll try to reproduce this issue. Does the same behavior happen when you connect to any other Wi-Fi network?

Hi Myles,

Thanks for the details! So, just to get it right, the same behavior on the same units doesn’t repeat when you use another phone, correct?

Also, can you please update the devices to the latest Reach Firmware 28.4 and check if the issue is still present?

yes it does

Hi @christy.tanner,

Thanks for the report! What Reach Firmware is installed on your Reach devices? Does this behavior repeat when you switch to another phone/tablet?

Hi Jeff,

Welcome to the forum! I can see you’re already in touch with my colleague via email. Let’s keep all of the details in one place there so that we don’t start confusion.