Bluetooth Baud rate? And serial connection freeze's

Hi,

What Baud rate does the emlid reach RS+ output when using Bluetooth as a correction output? There is no field to select the Baud unlike UART. Through trial and error, my auto steer is smoothest when I set it to 57600, but there still appears to be NMEA sentences missing. Whole seconds will go past without a sentence when set to 5Hz.

Also, I’m only using Bluetooth because the serial connection using UART appears to freeze and crash my software after about 1 - 3 minutes of perfect NMEA sentences. I have already tried resetting com ports, reinstalling FTDI drivers (usb to serial, which then connects to bottom connector of reach), and I’ve tried a new FTDI cable. Any ways to diagnose the problem here?

Have you tried with a cable instead?

Yes. In the 2nd half of post I was referring to emlid’s bottom connector rs232 cable which connects to my tablet via a FTDI usb cable. Or do you mean direct usb cable to the micro B port? Last time I tried that it worked fine. But the rover is set up permanently on the roof of a tractor, so I’m hoping to not use that mini B port, so water cannot short a connection, and also so it doesn’t wiggle loose.

Hi Josiah,

May I ask you to specify the firmware version that the Reach RS+ runs on?

Version 2.20.8, but it was the same with version 2.18.xx.